omap3-pandora-kernel2: update
[openpandora.oe.git] / recipes / pandora-system / pandora-version.bb
index 99d2fdf..05dd298 100644 (file)
@@ -1,20 +1,34 @@
 DESCRIPTION = "Installs /etc/op-version file."
 LICENSE = "Public Domain"
-PR = "r0"
+
+# a reminder: update the changelog!
+PR = "r40"
+
+SRC_URI = " \
+  file://changelog \
+"
 
 do_install() {
   OLD_PWD=$PWD
-  opvf=${D}/${sysconfdir}/op-version
   cd `dirname "${FILE_DIRNAME}"`
+  tag=`git describe --abbrev=0`
+  commits=`git log --oneline ${tag}..HEAD | wc -l`
+  updv=""
+  test "$commits" = "0" || updv=" update $commits"
   install -d ${D}${sysconfdir}/
+  opvf=${D}/${sysconfdir}/op-version
   echo "Tag Name: `git describe`" > ${opvf}
   echo "GIT-VERSION: `git log -n1 --pretty=oneline|awk '{print $1}'`" >> ${opvf}
   echo "Branch: `git branch | awk '/*/{print $2}'`" >> ${opvf}
-  echo "Version: 1.8.0.6 - R1.55 Codename Super Zaxxon" >> ${opvf}
+  echo "Version: 1.9.7.6 - R1.76 Codename Super Zaxxon" >> ${opvf}
+  echo "Display Ver: SuperZaxxon 1.76${updv}" >> ${opvf}
   echo "Image Builder: ${LOGNAME}@`cat /etc/hostname`" >> ${opvf}
   echo "Time Stamp: `date -R`" >> ${opvf}
+
+  install -d ${D}${prefix}/pandora/
+  install -m 0644 ${WORKDIR}/changelog ${D}${prefix}/pandora/
 }
 
-FILES_${PN} += "${sysconfdir}/op-version"
+FILES_${PN} += "${sysconfdir}/op-version ${prefix}/pandora"
 
 COMPATIBLE_MACHINE = "omap3-pandora"