pandora-state: change nubs.state permissions
[openpandora.oe.git] / recipes / pandora-system / pandora-state.bb
index d5c02d6..4f5cc4a 100755 (executable)
@@ -5,7 +5,7 @@ COMPATIBLE_MACHINE = "omap3-pandora"
 
 RDEPENDS = "pandora-scripts"
 
-PR = "r22"
+PR = "r25"
 inherit update-rc.d
 
 INITSCRIPT_NAME = "pandora-state"
@@ -27,10 +27,17 @@ do_install() {
           install -m 0644 ${WORKDIR}/gamma.state ${D}${sysconfdir}/pandora/conf/gamma.state
          install -m 0644 ${WORKDIR}/dssgamma.state ${D}${sysconfdir}/pandora/conf/dssgamma.state
           install -m 0644 ${WORKDIR}/brightness.state ${D}${sysconfdir}/pandora/conf/brightness.state
-         install -m 0644 ${WORKDIR}/nubs.state ${D}${sysconfdir}/pandora/conf/nubs.state
          install -m 0644 ${WORKDIR}/dirty_expire_centisecs ${D}${sysconfdir}/pandora/conf/dirty_expire_centisecs
+         # nub configurator runs without root
+         install -m 0666 ${WORKDIR}/nubs.state ${D}${sysconfdir}/pandora/conf/nubs.state
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 FILES_${PN} += "${prefix} ${datadir}"
+
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/nubs.state
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gamma.state
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/dssgamma.state
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/brightness.state
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/nubs.state