op_osupgrade: ask for reboot after kernel change
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index e9db8eb..da824ae 100644 (file)
@@ -6,22 +6,31 @@ COMPATIBLE_MACHINE = "omap3-pandora"
 DEPENDS = "zenity dbus"
 RDEPENDS = "zenity dbus"
 
-PR = "r79"
+PR = "r136"
 
 SRC_URI = " \
           file://op_paths.sh \
           file://op_bright.sh \
           file://op_cpuspeed.sh \
-          file://op_cpuspeed.pnd \          
+          file://op_cpuspeed.pnd \     
+         file://op_usbhost.sh \
+          file://op_usbhost.pnd \
+          file://op_osupgrade.sh \
+          file://op_osupgrade.pnd \
+          file://op_sysspeed.sh \
+         file://op_createsd.sh \
+         file://op_createsd.pnd \
           file://op_wifi.sh \
           file://op_wifi.pnd \  
           file://op_bluetooth.sh \
+          file://op_bluetooth_work.sh \
           file://op_bluetooth-check.desktop \
           file://op_bluetooth.desktop \          
           file://op_startupmanager.sh \
           file://op_startupmanager.pnd \
           file://op_switchgui.sh \
           file://op_switchgui.pnd \
+          file://nettool.pnd \
           file://startnetbooklauncher \
           file://startmmenu \    
           file://startpmenu \ 
@@ -34,6 +43,8 @@ SRC_URI = " \
           file://op_usermanager.pnd \
           file://op_lcdsettings.sh \
           file://op_lcdsettings.pnd \
+          file://op_ledsettings.sh \
+          file://op_ledsettings.pnd \
          file://op_cpusettings.sh \
           file://op_cpusettings.pnd \
           file://op_lcdrate.sh \
@@ -42,8 +53,10 @@ SRC_URI = " \
          file://op_storage.pnd \
           file://op_nubmode.py \
          file://op_nubmode.pnd \
+         file://op_nubchange.sh \
          file://op_lidsettings.pnd \
          file://op_lidsettings.sh \
+         file://op_touchinit.sh \
           file://op_tvout.sh \
          file://op_tvout.pnd \
          file://ConfigModel.py \
@@ -51,6 +64,7 @@ SRC_URI = " \
          file://op_inputtest.pnd \
           file://gui.conf \
          file://cpu.conf \
+         file://led.conf \
           file://gamma.conf \
           file://service.conf \
          file://nub_profiles.conf \
@@ -78,34 +92,46 @@ SRC_URI = " \
          file://op_bright_up.sh \  
          file://op_menu.sh \ 
          file://op_xfcemenu.sh \
+         file://op_hugetlb.sh \
+         file://op_gamma.sh \
 "
 
 do_install() {
           install -d ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_osupgrade.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
-         install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_createsd.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_usbhost.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_bluetooth_work.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_ledsettings.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_nubchange.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_battlow.sh ${D}${prefix}/pandora/scripts/ 
+         install -m 0755 ${WORKDIR}/op_touchinit.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
          install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
+         install -m 0755 ${WORKDIR}/op_hugetlb.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_gamma.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/ConfigModel.py ${D}${prefix}/pandora/scripts/
@@ -119,9 +145,11 @@ do_install() {
 
           install -d ${D}${prefix}/pandora/apps/
           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
+          install -m 0755 ${WORKDIR}/op_createsd.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
+         install -m 0755 ${WORKDIR}/op_ledsettings.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
@@ -129,9 +157,11 @@ do_install() {
          install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
+         install -m 0755 ${WORKDIR}/op_usbhost.pnd ${D}${prefix}/pandora/apps/
           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
+         install -m 0755 ${WORKDIR}/op_osupgrade.pnd ${D}${prefix}/pandora/apps/
 
          install -d ${D}${prefix}/pandora/mmenu/
           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
@@ -142,6 +172,7 @@ do_install() {
           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
          install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
+         install -m 0755 ${WORKDIR}/nettool.pnd ${D}${prefix}/pandora/mmenu/
 
           install -d ${D}${datadir}/applications/
           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
@@ -151,6 +182,7 @@ do_install() {
 
           install -d ${D}${sysconfdir}/pandora/conf/
           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
+          install -m 0644 ${WORKDIR}/led.conf ${D}${sysconfdir}/pandora/conf/led.conf
          install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
@@ -174,3 +206,11 @@ do_install() {
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 FILES_${PN} += "${prefix} ${datadir}"
+
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gui.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/cpu.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/led.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gamma.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/service.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/nub_profiles.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/tvout-profiles.conf