pandora-scripts: Added Wifi Nettool for MiniMenu
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index ec97f27..ca552b9 100644 (file)
@@ -6,7 +6,7 @@ COMPATIBLE_MACHINE = "omap3-pandora"
 DEPENDS = "zenity dbus"
 RDEPENDS = "zenity dbus"
 
-PR = "r129"
+PR = "r135"
 
 SRC_URI = " \
           file://op_paths.sh \
@@ -30,6 +30,7 @@ SRC_URI = " \
           file://op_startupmanager.pnd \
           file://op_switchgui.sh \
           file://op_switchgui.pnd \
+          file://nettool.pnd \
           file://startnetbooklauncher \
           file://startmmenu \    
           file://startpmenu \ 
@@ -42,6 +43,8 @@ SRC_URI = " \
           file://op_usermanager.pnd \
           file://op_lcdsettings.sh \
           file://op_lcdsettings.pnd \
+          file://op_ledsettings.sh \
+          file://op_ledsettings.pnd \
          file://op_cpusettings.sh \
           file://op_cpusettings.pnd \
           file://op_lcdrate.sh \
@@ -61,6 +64,7 @@ SRC_URI = " \
          file://op_inputtest.pnd \
           file://gui.conf \
          file://cpu.conf \
+         file://led.conf \
           file://gamma.conf \
           file://service.conf \
          file://nub_profiles.conf \
@@ -111,6 +115,7 @@ do_install() {
           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_ledsettings.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
@@ -144,6 +149,7 @@ do_install() {
          install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
+         install -m 0755 ${WORKDIR}/op_ledsettings.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
@@ -166,6 +172,7 @@ do_install() {
           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
          install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
+         install -m 0755 ${WORKDIR}/nettool.pnd ${D}${prefix}/pandora/mmenu/
 
           install -d ${D}${datadir}/applications/
           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
@@ -175,6 +182,7 @@ do_install() {
 
           install -d ${D}${sysconfdir}/pandora/conf/
           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
+          install -m 0644 ${WORKDIR}/led.conf ${D}${sysconfdir}/pandora/conf/led.conf
          install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
@@ -201,6 +209,7 @@ FILES_${PN} += "${prefix} ${datadir}"
 
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gui.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/cpu.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/led.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gamma.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/service.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/nub_profiles.conf