op_power: try to handle mounted-cards-on-suspend mess
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index 08a83d3..9d4c234 100644 (file)
@@ -6,12 +6,14 @@ COMPATIBLE_MACHINE = "omap3-pandora"
 DEPENDS = "zenity dbus"
 RDEPENDS = "zenity dbus"
 
-PR = "r67"
+PR = "r90"
 
 SRC_URI = " \
+          file://op_paths.sh \
           file://op_bright.sh \
           file://op_cpuspeed.sh \
           file://op_cpuspeed.pnd \          
+          file://op_sysspeed.sh \
           file://op_wifi.sh \
           file://op_wifi.pnd \  
           file://op_bluetooth.sh \
@@ -41,17 +43,24 @@ SRC_URI = " \
          file://op_storage.pnd \
           file://op_nubmode.py \
          file://op_nubmode.pnd \
+         file://op_lidsettings.pnd \
+         file://op_lidsettings.sh \
           file://op_tvout.sh \
          file://op_tvout.pnd \
+         file://ConfigModel.py \
+         file://TVoutConfig.py \
          file://op_inputtest.pnd \
           file://gui.conf \
          file://cpu.conf \
           file://gamma.conf \
           file://service.conf \
          file://nub_profiles.conf \
+         file://tvout-profiles.conf \
          file://nubmode.glade \
          file://reset_nubs.sh \
          file://pndlogo.png \
+         file://tvicon.png \
+         file://tvout.glade \
           file://default_up \
           file://none_up \
           file://op_env.sh \
@@ -74,9 +83,11 @@ SRC_URI = " \
 
 do_install() {
           install -d ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
-         install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
@@ -99,7 +110,12 @@ do_install() {
          install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
+         install -m 0755 ${WORKDIR}/ConfigModel.py ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/TVoutConfig.py ${D}${prefix}/pandora/scripts/
+         install -m 0644 ${WORKDIR}/tvicon.png ${D}${prefix}/pandora/scripts/ 
          install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
+         install -m 0644 ${WORKDIR}/tvout.glade ${D}${prefix}/pandora/scripts/ 
+         install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
 
 
 
@@ -117,6 +133,7 @@ do_install() {
          install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
+         install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
 
          install -d ${D}${prefix}/pandora/mmenu/
           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
@@ -140,6 +157,7 @@ do_install() {
           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
          install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
+         install -m 0666 ${WORKDIR}/tvout-profiles.conf ${D}${sysconfdir}/pandora/conf/tvout-profiles.conf
 
           install -d ${D}${sysconfdir}/pandora/conf/dss_fir/
           install -m 0644 ${WORKDIR}/default_up ${D}${sysconfdir}/pandora/conf/dss_fir/