pandora-scripts: allow to configure idle power LED brightness
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index dd96849..7f98f57 100644 (file)
@@ -5,16 +5,18 @@ COMPATIBLE_MACHINE = "omap3-pandora"
 
 RDEPENDS = "bash sed gawk grep zenity"
 
-PR = "r144"
+PR = "r168"
 
 SRC_URI = " \
-          file://op_paths.sh \
           file://op_bright.sh \
+          file://op_common.sh \
           file://op_cpuspeed.sh \
           file://op_cpuspeed.pnd \     
+          file://op_dspspeed.sh \
          file://op_usbhost.sh \
           file://op_usbhost.pnd \
           file://op_osupgrade.sh \
+          file://op_osupgrade_work.sh \
           file://op_osupgrade.pnd \
           file://op_sysspeed.sh \
          file://op_createsd.sh \
@@ -23,9 +25,7 @@ SRC_URI = " \
           file://op_startupmanager.pnd \
           file://op_switchgui.sh \
           file://op_switchgui.pnd \
-          file://startnetbooklauncher \
           file://startmmenu \    
-          file://startpmenu \ 
           file://stopmmenu \
           file://op_calibrate.sh \
           file://op_calibrate.pnd \
@@ -39,6 +39,7 @@ SRC_URI = " \
           file://op_ledsettings.pnd \
          file://op_cpusettings.sh \
           file://op_cpusettings.pnd \
+#          file://compo4all-manager.pnd \
           file://op_lcdrate.sh \
           file://op_videofir.sh \
           file://op_storage.sh \
@@ -49,13 +50,15 @@ SRC_URI = " \
          file://op_lidsettings.pnd \
          file://op_lidsettings.sh \
          file://op_touchinit.sh \
-          file://op_tvout.sh \
+         file://op_tvout.sh \
          file://op_tvout.pnd \
+         file://op_tvout_layer.sh \
          file://ConfigModel.py \
          file://TVoutConfig.py \
          file://op_inputtest.pnd \
           file://gui.conf \
          file://cpu.conf \
+         file://dsp.conf \
          file://led.conf \
           file://gamma.conf \
           file://service.conf \
@@ -86,15 +89,19 @@ SRC_URI = " \
          file://op_xfcemenu.sh \
          file://op_hugetlb.sh \
          file://op_gamma.sh \
+         file://op_getpndmg.sh \
          file://op_dsp.sh \
 "
 
 do_install() {
           install -d ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
-         install -m 0755 ${WORKDIR}/op_osupgrade.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_common.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_getpndmg.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_osupgrade.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_osupgrade_work.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_dspspeed.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_createsd.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
@@ -111,7 +118,8 @@ do_install() {
          install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_nubchange.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_tvout_layer.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
@@ -151,6 +159,7 @@ do_install() {
          install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_osupgrade.pnd ${D}${prefix}/pandora/apps/
+#        install -m 0755 ${WORKDIR}/compo4all-manager.pnd ${D}${prefix}/pandora/apps/
 
          install -d ${D}${prefix}/pandora/mmenu/
           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
@@ -166,6 +175,7 @@ do_install() {
           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
           install -m 0644 ${WORKDIR}/led.conf ${D}${sysconfdir}/pandora/conf/led.conf
          install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
+         install -m 0644 ${WORKDIR}/dsp.conf ${D}${sysconfdir}/pandora/conf/dsp.conf
           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
          install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
@@ -179,9 +189,7 @@ do_install() {
           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
 
           install -d ${D}${bindir}/
-          install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
-          install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
 }
 
@@ -191,6 +199,7 @@ FILES_${PN} += "${prefix} ${datadir}"
 
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gui.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/cpu.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/dsp.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/led.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gamma.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/service.conf