pandora-scripts: Removed wifi-stuff (will be moved to pandora-scripts-wifi)
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index dae10f7..1297941 100644 (file)
@@ -3,10 +3,9 @@ LICENSE = "GPLV2"
 
 COMPATIBLE_MACHINE = "omap3-pandora"
 
-DEPENDS = "zenity dbus"
-RDEPENDS = "zenity dbus"
+RDEPENDS = "bash sed gawk grep zenity"
 
-PR = "r117"
+PR = "r140"
 
 SRC_URI = " \
           file://op_paths.sh \
@@ -20,8 +19,6 @@ SRC_URI = " \
           file://op_sysspeed.sh \
          file://op_createsd.sh \
          file://op_createsd.pnd \
-          file://op_wifi.sh \
-          file://op_wifi.pnd \  
           file://op_bluetooth.sh \
           file://op_bluetooth_work.sh \
           file://op_bluetooth-check.desktop \
@@ -42,6 +39,8 @@ SRC_URI = " \
           file://op_usermanager.pnd \
           file://op_lcdsettings.sh \
           file://op_lcdsettings.pnd \
+          file://op_ledsettings.sh \
+          file://op_ledsettings.pnd \
          file://op_cpusettings.sh \
           file://op_cpusettings.pnd \
           file://op_lcdrate.sh \
@@ -61,6 +60,7 @@ SRC_URI = " \
          file://op_inputtest.pnd \
           file://gui.conf \
          file://cpu.conf \
+         file://led.conf \
           file://gamma.conf \
           file://service.conf \
          file://nub_profiles.conf \
@@ -90,6 +90,7 @@ SRC_URI = " \
          file://op_xfcemenu.sh \
          file://op_hugetlb.sh \
          file://op_gamma.sh \
+         file://op_dsp.sh \
 "
 
 do_install() {
@@ -101,7 +102,6 @@ do_install() {
           install -m 0755 ${WORKDIR}/op_createsd.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_usbhost.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bluetooth_work.sh ${D}${prefix}/pandora/scripts/
@@ -111,6 +111,7 @@ do_install() {
           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_ledsettings.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
@@ -135,7 +136,7 @@ do_install() {
          install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
          install -m 0644 ${WORKDIR}/tvout.glade ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
-
+         install -m 0755 ${WORKDIR}/op_dsp.sh ${D}${prefix}/pandora/scripts/ 
 
 
           install -d ${D}${prefix}/pandora/apps/
@@ -144,13 +145,13 @@ do_install() {
          install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
+         install -m 0755 ${WORKDIR}/op_ledsettings.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
-         install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_usbhost.pnd ${D}${prefix}/pandora/apps/
           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
@@ -175,6 +176,7 @@ do_install() {
 
           install -d ${D}${sysconfdir}/pandora/conf/
           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
+          install -m 0644 ${WORKDIR}/led.conf ${D}${sysconfdir}/pandora/conf/led.conf
          install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
@@ -198,3 +200,11 @@ do_install() {
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 FILES_${PN} += "${prefix} ${datadir}"
+
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gui.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/cpu.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/led.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gamma.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/service.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/nub_profiles.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/tvout-profiles.conf