pandora-scripts: Removed wifi-stuff (will be moved to pandora-scripts-wifi)
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index 8386d4e..1297941 100644 (file)
@@ -3,10 +3,9 @@ LICENSE = "GPLV2"
 
 COMPATIBLE_MACHINE = "omap3-pandora"
 
-DEPENDS = "zenity dbus"
-RDEPENDS = "zenity dbus"
+RDEPENDS = "bash sed gawk grep zenity"
 
-PR = "r138"
+PR = "r140"
 
 SRC_URI = " \
           file://op_paths.sh \
@@ -20,8 +19,6 @@ SRC_URI = " \
           file://op_sysspeed.sh \
          file://op_createsd.sh \
          file://op_createsd.pnd \
-          file://op_wifi.sh \
-          file://op_wifi.pnd \  
           file://op_bluetooth.sh \
           file://op_bluetooth_work.sh \
           file://op_bluetooth-check.desktop \
@@ -30,7 +27,6 @@ SRC_URI = " \
           file://op_startupmanager.pnd \
           file://op_switchgui.sh \
           file://op_switchgui.pnd \
-          file://nettool.pnd \
           file://startnetbooklauncher \
           file://startmmenu \    
           file://startpmenu \ 
@@ -94,6 +90,7 @@ SRC_URI = " \
          file://op_xfcemenu.sh \
          file://op_hugetlb.sh \
          file://op_gamma.sh \
+         file://op_dsp.sh \
 "
 
 do_install() {
@@ -105,7 +102,6 @@ do_install() {
           install -m 0755 ${WORKDIR}/op_createsd.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_usbhost.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bluetooth_work.sh ${D}${prefix}/pandora/scripts/
@@ -140,7 +136,7 @@ do_install() {
          install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
          install -m 0644 ${WORKDIR}/tvout.glade ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
-
+         install -m 0755 ${WORKDIR}/op_dsp.sh ${D}${prefix}/pandora/scripts/ 
 
 
           install -d ${D}${prefix}/pandora/apps/
@@ -156,7 +152,6 @@ do_install() {
          install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
-         install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_usbhost.pnd ${D}${prefix}/pandora/apps/
           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
@@ -172,7 +167,6 @@ do_install() {
           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
          install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
-         install -m 0755 ${WORKDIR}/nettool.pnd ${D}${prefix}/pandora/mmenu/
 
           install -d ${D}${datadir}/applications/
           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/