op_switchgui.sh: Exits the script when no selection was made (instead of dropping...
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index c410dda..0c668ca 100644 (file)
@@ -5,13 +5,14 @@ COMPATIBLE_MACHINE = "omap3-pandora"
 
 RDEPENDS = "bash sed gawk grep zenity"
 
-PR = "r148"
+PR = "r159"
 
 SRC_URI = " \
-          file://op_paths.sh \
           file://op_bright.sh \
+          file://op_common.sh \
           file://op_cpuspeed.sh \
           file://op_cpuspeed.pnd \     
+          file://op_dspspeed.sh \
          file://op_usbhost.sh \
           file://op_usbhost.pnd \
           file://op_osupgrade.sh \
@@ -56,6 +57,7 @@ SRC_URI = " \
          file://op_inputtest.pnd \
           file://gui.conf \
          file://cpu.conf \
+         file://dsp.conf \
          file://led.conf \
           file://gamma.conf \
           file://service.conf \
@@ -86,15 +88,18 @@ SRC_URI = " \
          file://op_xfcemenu.sh \
          file://op_hugetlb.sh \
          file://op_gamma.sh \
+         file://op_getpndmg.sh \
          file://op_dsp.sh \
 "
 
 do_install() {
           install -d ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_common.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_getpndmg.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_osupgrade.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_dspspeed.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_createsd.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
@@ -168,6 +173,7 @@ do_install() {
           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
           install -m 0644 ${WORKDIR}/led.conf ${D}${sysconfdir}/pandora/conf/led.conf
          install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
+         install -m 0644 ${WORKDIR}/dsp.conf ${D}${sysconfdir}/pandora/conf/dsp.conf
           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
          install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
@@ -191,6 +197,7 @@ FILES_${PN} += "${prefix} ${datadir}"
 
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gui.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/cpu.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/dsp.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/led.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gamma.conf
 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/service.conf