op_switchgui.sh: Exits the script when no selection was made (instead of dropping...
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
index 641df0b..0c668ca 100644 (file)
@@ -3,32 +3,28 @@ LICENSE = "GPLV2"
 
 COMPATIBLE_MACHINE = "omap3-pandora"
 
-DEPENDS = "zenity dbus"
-RDEPENDS = "zenity dbus"
+RDEPENDS = "bash sed gawk grep zenity"
 
-PR = "r106"
+PR = "r159"
 
 SRC_URI = " \
-          file://op_paths.sh \
           file://op_bright.sh \
+          file://op_common.sh \
           file://op_cpuspeed.sh \
           file://op_cpuspeed.pnd \     
+          file://op_dspspeed.sh \
          file://op_usbhost.sh \
-          file://op_usbhost.pnd \     
+          file://op_usbhost.pnd \
+          file://op_osupgrade.sh \
+          file://op_osupgrade.pnd \
           file://op_sysspeed.sh \
-          file://op_wifi.sh \
-          file://op_wifi.pnd \  
-          file://op_bluetooth.sh \
-          file://op_bluetooth_work.sh \
-          file://op_bluetooth-check.desktop \
-          file://op_bluetooth.desktop \          
+         file://op_createsd.sh \
+         file://op_createsd.pnd \
           file://op_startupmanager.sh \
           file://op_startupmanager.pnd \
           file://op_switchgui.sh \
           file://op_switchgui.pnd \
-          file://startnetbooklauncher \
           file://startmmenu \    
-          file://startpmenu \ 
           file://stopmmenu \
           file://op_calibrate.sh \
           file://op_calibrate.pnd \
@@ -38,8 +34,11 @@ SRC_URI = " \
           file://op_usermanager.pnd \
           file://op_lcdsettings.sh \
           file://op_lcdsettings.pnd \
+          file://op_ledsettings.sh \
+          file://op_ledsettings.pnd \
          file://op_cpusettings.sh \
           file://op_cpusettings.pnd \
+#          file://compo4all-manager.pnd \
           file://op_lcdrate.sh \
           file://op_videofir.sh \
           file://op_storage.sh \
@@ -49,13 +48,17 @@ SRC_URI = " \
          file://op_nubchange.sh \
          file://op_lidsettings.pnd \
          file://op_lidsettings.sh \
-          file://op_tvout.sh \
+         file://op_touchinit.sh \
+         file://op_tvout.sh \
          file://op_tvout.pnd \
+         file://op_tvout_layer.sh \
          file://ConfigModel.py \
          file://TVoutConfig.py \
          file://op_inputtest.pnd \
           file://gui.conf \
          file://cpu.conf \
+         file://dsp.conf \
+         file://led.conf \
           file://gamma.conf \
           file://service.conf \
          file://nub_profiles.conf \
@@ -83,38 +86,48 @@ SRC_URI = " \
          file://op_bright_up.sh \  
          file://op_menu.sh \ 
          file://op_xfcemenu.sh \
+         file://op_hugetlb.sh \
+         file://op_gamma.sh \
+         file://op_getpndmg.sh \
+         file://op_dsp.sh \
 "
 
 do_install() {
           install -d ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_common.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_getpndmg.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_osupgrade.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_dspspeed.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_createsd.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_usbhost.sh ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_bluetooth_work.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
+          install -m 0755 ${WORKDIR}/op_ledsettings.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_nubchange.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
-          install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_tvout_layer.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/op_battlow.sh ${D}${prefix}/pandora/scripts/ 
+         install -m 0755 ${WORKDIR}/op_touchinit.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
          install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
+         install -m 0755 ${WORKDIR}/op_hugetlb.sh ${D}${prefix}/pandora/scripts/
+         install -m 0755 ${WORKDIR}/op_gamma.sh ${D}${prefix}/pandora/scripts/
          install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
          install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/ConfigModel.py ${D}${prefix}/pandora/scripts/
@@ -123,25 +136,28 @@ do_install() {
          install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
          install -m 0644 ${WORKDIR}/tvout.glade ${D}${prefix}/pandora/scripts/ 
          install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
-
+         install -m 0755 ${WORKDIR}/op_dsp.sh ${D}${prefix}/pandora/scripts/ 
 
 
           install -d ${D}${prefix}/pandora/apps/
           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
+          install -m 0755 ${WORKDIR}/op_createsd.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
+         install -m 0755 ${WORKDIR}/op_ledsettings.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
-         install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_usbhost.pnd ${D}${prefix}/pandora/apps/
           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
          install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
+         install -m 0755 ${WORKDIR}/op_osupgrade.pnd ${D}${prefix}/pandora/apps/
+#        install -m 0755 ${WORKDIR}/compo4all-manager.pnd ${D}${prefix}/pandora/apps/
 
          install -d ${D}${prefix}/pandora/mmenu/
           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
@@ -153,15 +169,11 @@ do_install() {
           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
          install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
 
-          install -d ${D}${datadir}/applications/
-          install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
-          
-          install -d ${D}${sysconfdir}/xdg/autostart/
-          install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
-
           install -d ${D}${sysconfdir}/pandora/conf/
           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
+          install -m 0644 ${WORKDIR}/led.conf ${D}${sysconfdir}/pandora/conf/led.conf
          install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
+         install -m 0644 ${WORKDIR}/dsp.conf ${D}${sysconfdir}/pandora/conf/dsp.conf
           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
          install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
@@ -175,12 +187,19 @@ do_install() {
           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
 
           install -d ${D}${bindir}/
-          install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
-          install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
 FILES_${PN} += "${prefix} ${datadir}"
+
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gui.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/cpu.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/dsp.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/led.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gamma.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/service.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/nub_profiles.conf
+CONFFILES_${PN} += ${sysconfdir}/pandora/conf/tvout-profiles.conf