task-pandora-*: Commit latest Xfce and Core tasks to build PAM correctly and package...
[openpandora.oe.git] / recipes / pandora-system / pandora-matchbox-gtk-theme.bb
index 41d7d1a..ec89057 100755 (executable)
@@ -4,7 +4,7 @@ DEPENDS = "matchbox-wm"
 SECTION = "x11/wm"
 
 PV = "0.1"
-PR = "r0"
+PR = "r1.2"
 
 PACKAGE_ARCH = "all"
 
@@ -15,7 +15,7 @@ SRC_URI = " \
        git://git.openpandora.org/pandora-libraries.git;protocol=git;branch=master \
 "
 
-S = "${WORKDIR}/git"
+S = "${WORKDIR}/git/gui_theme"
 
 do_install() {
        find ${WORKDIR} -name ".git" | xargs rm -rf
@@ -24,10 +24,14 @@ do_install() {
        rm -rf ${D}${datadir}/themes/pandora-standard/patches/
        
        install -d ${D}${sysconfdir}/gtk-2.0
-       echo 'include "${datadir}/themes/openmoko-standard-2/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
 }
 
-CONFFILES_${PN} = "${sysconfdir}/gtk-2.0/gtkrc"
+#CONFFILES_${PN} = "${sysconfdir}/gtk-2.0/gtkrc"
+
+pkg_postinst() {
+#!/bin/sh
+echo 'include "${datadir}/themes/pandora-standard/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
+}
 
 PACKAGE_ARCH = "all"
 FILES_${PN} = "${datadir} ${sysconfdir}"