pandora-first-run-wizard: blacklist wifi modules
[openpandora.oe.git] / recipes / pandora-system / pandora-first-run-wizard.bb
index d2a9adb..e3da76b 100755 (executable)
@@ -1,15 +1,17 @@
 DESCRIPTION = "Scripts to support the first run wizard on the OpenPandora."
 LICENSE = "GPLV2"
-RDEPENDS = "hsetroot zenity dbus"
+
+DEPENDS = "hsetroot zenity dbus"
+RDEPENDS = "hsetroot zenity dbus pandora-wallpaper-official tslib tslib-calibrate pandora-skel xmodmap"
 
 COMPATIBLE_MACHINE = "omap3-pandora"
 
-PR = "r2"
+PR = "r30"
 
 SRC_URI = " \
           file://first-run-wizard.sh \
-          file://rc.firstrun \
-          file://op_default.png \          
+          file://op_startup.sh \
+          file://rc.firstrun \          
 "
 
 inherit update-rc.d
@@ -20,12 +22,12 @@ INITSCRIPT_PARAMS = "start 29 2 3 4 5 . stop  29 2 3 4 5 ."
 do_install() {         
           install -d ${D}${prefix}/pandora/scripts/
           install -m 0755 ${WORKDIR}/first-run-wizard.sh ${D}${prefix}/pandora/scripts/
-          
+          install -m 0755 ${WORKDIR}/op_startup.sh ${D}${prefix}/pandora/scripts/
+
           install -d ${D}${sysconfdir}/init.d/
           install -m 0755 ${WORKDIR}/rc.firstrun ${D}${sysconfdir}/init.d/oprun-init
-          
-          install -d ${D}${datadir}/backgrounds/
-          install -m 0644 ${WORKDIR}/op_default.png ${D}${datadir}/backgrounds/
+
+          install -d ${D}${sysconfdir}/pandora/          
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"