first-run-wizard: Remove /tmp/nocleanwarn to prevent showing the "unit has crashed...
[openpandora.oe.git] / recipes / pandora-system / pandora-first-run-wizard.bb
index d9ae28d..bf8d2bd 100755 (executable)
@@ -2,11 +2,11 @@ DESCRIPTION = "Scripts to support the first run wizard on the OpenPandora."
 LICENSE = "GPLV2"
 
 DEPENDS = "hsetroot zenity dbus"
-RDEPENDS = "hsetroot zenity dbus pandora-wallpaper-official tslib tslib-calibrate "
+RDEPENDS = "hsetroot zenity dbus pandora-wallpaper-official tslib tslib-calibrate pandora-skel xmodmap"
 
 COMPATIBLE_MACHINE = "omap3-pandora"
 
-PR = "r2"
+PR = "r47"
 
 SRC_URI = " \
           file://first-run-wizard.sh \
@@ -26,6 +26,8 @@ do_install() {
 
           install -d ${D}${sysconfdir}/init.d/
           install -m 0755 ${WORKDIR}/rc.firstrun ${D}${sysconfdir}/init.d/oprun-init
+
+          install -d ${D}${sysconfdir}/pandora/          
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"