pandora-firmware: Removed wl1251-nvs.bin (not needed)
[openpandora.oe.git] / recipes / pandora-system / pandora-firmware.bb
index 0e78a1d..212238d 100755 (executable)
@@ -1,24 +1,26 @@
 DESCRIPTION = "Install binary firmware for Bluetooth and WiFi into the image."
 LICENSE = "proprietary-binary"
 RRECOMMENDS_${PN} = "kernel-module-firmware-class"
-PR = "r5"
+PR = "r3"
 
 SRC_URI = " \
         file://brf6300.bin \
         file://wl1251-fw.bin \
-        file://wl1251-nvs.bin \
+        file://bluetooth-conf \        
 "
 
 SUMMARY = "This is required to support the Bluetooth and WiFi modules on the Pandora"
 S = "${WORKDIR}"
 
 do_install() {
-        install -d ${D}/lib/firmware
-        install -m 0644 ${S}/brf6300.bin ${S}/wl1251-fw.bin ${S}/wl1251-nvs.bin ${D}/lib/firmware/
+        install -d ${D}${base_libdir}/firmware
+        install -m 0644 ${S}/brf6300.bin ${S}/wl1251-fw.bin ${D}${base_libdir}/firmware/
+        install -d ${D}${sysconfdir}/sysconfig
+        install -m 0755 ${S}/bluetooth-conf ${D}${sysconfdir}/sysconfig/bluetooth     
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-FILES_${PN} += "/lib/firmware"
+FILES_${PN} += "${base_libdir}/firmware ${sysconfdir}/sysconfig"
 
 COMPATIBLE_MACHINE = "omap3-pandora"