Update tree with local changes. Disable WiLink4 drivers in the image and enable the...
[openpandora.oe.git] / recipes / pandora-system / pandora-firmware.bb
index 5c7c7a1..0e78a1d 100755 (executable)
@@ -1,11 +1,12 @@
 DESCRIPTION = "Install binary firmware for Bluetooth and WiFi into the image."
 LICENSE = "proprietary-binary"
 RRECOMMENDS_${PN} = "kernel-module-firmware-class"
-PR = "r4"
+PR = "r5"
 
 SRC_URI = " \
         file://brf6300.bin \
-        file://Fw1251r1c.bin \
+        file://wl1251-fw.bin \
+        file://wl1251-nvs.bin \
 "
 
 SUMMARY = "This is required to support the Bluetooth and WiFi modules on the Pandora"
@@ -13,7 +14,7 @@ S = "${WORKDIR}"
 
 do_install() {
         install -d ${D}/lib/firmware
-        install -m 0644 ${S}/brf6300.bin ${S}/Fw1251r1c.bin ${D}/lib/firmware/
+        install -m 0644 ${S}/brf6300.bin ${S}/wl1251-fw.bin ${S}/wl1251-nvs.bin ${D}/lib/firmware/
 }
 
 PACKAGE_ARCH = "${MACHINE_ARCH}"