omap3-pandora-kernel: bump for cpu/PMON patches
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel_2.6.27-pandora.bb
index d9f6275..e6674cf 100755 (executable)
@@ -5,24 +5,7 @@ KERNEL_IMAGETYPE = "uImage"
 
 COMPATIBLE_MACHINE = "omap3-pandora"
 
-# ----- Revision 2 Boards -----
-
-#GIT HEAD for Rev2 - Same as Rev3 without Batt Fuel Guage and Nub/Button changes.
-
-#SRCREV = "45dce3afbd5c2d2af899ae7e7a107d01a5c15558"
-
-#SRC_URI = " \
-#           git://git.openpandora.org/pandora-kernel.git;protocol=git;branch=rev2 \
-#"
-
-# -----------------------------
-
-
-# ----- Revision 3 > Boards -----
-
-#GIT HEAD for Rev3 > (i.e. Shipping units) - Will run on Rev2 boards without Nubs and an incorrect Start button.
-
-SRCREV = "e2eaf64e85e435bb2405bfe8ff6ec1c5aa39bda6"
+SRCREV = "42fe5e655205146e03846719dc7eaac38c10d22e"
 
 SRC_URI = " \
            git://git.openpandora.org/pandora-kernel.git;protocol=git;branch=pandora-27-omap1 \
@@ -30,7 +13,7 @@ SRC_URI = " \
 
 # -------------------------------
 
-PV = "2.6.27-pandora+${PR}+git${SRCREV}"
+PV = "2.6.27-pandora+${PR}+git${SRCREV}.3"
 
 SRC_URI_append = " \
            file://defconfig \
@@ -41,25 +24,28 @@ SRC_URI_append = " \
            file://no-cortex-deadlock.patch;patch=1 \
            file://read_die_ids.patch;patch=1 \
            file://fix-install.patch;patch=1 \
-           file://musb-dma-iso-in.eml;patch=1 \
-           file://musb-support-high-bandwidth.patch.eml;patch=1 \
            file://mru-fix-timings.diff;patch=1 \
            file://mru-fix-display-panning.diff;patch=1 \
            file://mru-make-dpll4-m4-ck-programmable.diff;patch=1 \
            file://mru-improve-pixclock-config.diff;patch=1 \
            file://mru-make-video-timings-selectable.diff;patch=1 \
            file://mru-enable-overlay-optimalization.diff;patch=1 \
-           file://musb-fix-ISO-in-unlink.diff;patch=1 \
-           file://musb-fix-multiple-bulk-transfers.diff;patch=1 \
-           file://musb-fix-endpoints.diff;patch=1 \
            file://dvb-fix-dma.diff;patch=1 \
            file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
            file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
-           file://sitecomwl168-support.diff;patch=1 \
            file://musb-rxtx.patch;patch=1 \
-           file://0001-SDIO-patches-to-put-some-card-into-into-platform-dev.patch;patch=1 \
-           file://0002-Add-a-very-basic-platform-driver-module-to-bring-up-.patch;patch=1 \
-           file://0003-Remove-old-msm_wifi-hack-as-the-temp-platform-driver.patch;patch=1 \
 "
-       
+
+# SquashFS 4 Patches.
+
+SRC_URI_append = " \
+           file://squashfs/0006-SquashFS-Backport-SquashFS4-to-our-2.6.27-tree.patch;patch=1 \
+"           
+
+# AUFS2 Patches.
+
+SRC_URI_append = " \
+           file://aufs2/0007-AUFS2-Add-latest-AUFS2-in-tree-code-for-2.6.27.patch;patch=1 \
+"           
+
 S = "${WORKDIR}/git"