omap3-pandora-kernel2: update
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
index b6def4d..f4e5b2c 100644 (file)
@@ -4,12 +4,12 @@ LICENSE = "GPLv2"
 COMPATIBLE_MACHINE = "omap3-pandora"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-PR = "r2"
+PR = "r6"
 
 # we already build 2.6 kernel using OE infrastructure, and
 # as we don't know how to build another one into the same image
 # (especially out-of-tree modules), we just package manually prebuilt one
-SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r2.tar.bz2"
+SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r6.tar.bz2"
 
 S = "${WORKDIR}"
 
@@ -21,6 +21,10 @@ do_install() {
 FILES_${PN} = "boot lib"
 
 pkg_postinst_${PN} () {
+  # this will cause depmod to be run on next boot
+  rm -f /lib/modules/`uname -r`/modules.dep
+  sync
+
   if ! grep -q '[[:blank:]]/[[:blank:]]*ubifs' /proc/mounts; then
     test -e /media/PANDORABOOT/uImage && oldkernel=/media/PANDORABOOT/uImage
     test -e /media/PANDORABOOT/uImage-3 && oldkernel=/media/PANDORABOOT/uImage-3
@@ -37,6 +41,7 @@ where your kernel is booted from (usually set in boot.txt / autoboot.txt)."
 copy it to the location where kernel is booted from (usually set in \
 boot.txt / autoboot.txt) or the system might not start after reboot."
     fi
+    sync
     if test -n "$DISPLAY"; then
       zenity --info --text "$msg"
     else
@@ -48,5 +53,5 @@ boot.txt / autoboot.txt) or the system might not start after reboot."
 }
 
 PACKAGE_STRIP = "no"
-SRC_URI[md5sum] = "13649475902466af040ef418c629872f"
-SRC_URI[sha256sum] = "03eed87da0e5b6b3f13c7e5e1abd92949293b20c2d8849419065c84e57efd33b"
+SRC_URI[md5sum] = "db11aa3d4924e9684a8bf42f1435ba66"
+SRC_URI[sha256sum] = "0fe632636eb4d100f3f5b33902dd5a12294067f5beb5bb9e43d24c44f0ac7487"