omap3-pandora-kernel2: update
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
index c6cd9bc..c9c96fc 100644 (file)
@@ -4,12 +4,14 @@ LICENSE = "GPLv2"
 COMPATIBLE_MACHINE = "omap3-pandora"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-PR = "r3"
+PR = "r7"
 
 # we already build 2.6 kernel using OE infrastructure, and
 # as we don't know how to build another one into the same image
 # (especially out-of-tree modules), we just package manually prebuilt one
-SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r2.tar.bz2"
+# git://git.openpandora.org/pandora-kernel.git , branch pandora-3.2
+# commit: db4bd663ea5894d516f75d7a5973303998247f91
+SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r7.tar.bz2"
 
 S = "${WORKDIR}"
 
@@ -21,6 +23,10 @@ do_install() {
 FILES_${PN} = "boot lib"
 
 pkg_postinst_${PN} () {
+  # this will cause depmod to be run on next boot
+  rm -f /lib/modules/`uname -r`/modules.dep
+  sync
+
   if ! grep -q '[[:blank:]]/[[:blank:]]*ubifs' /proc/mounts; then
     test -e /media/PANDORABOOT/uImage && oldkernel=/media/PANDORABOOT/uImage
     test -e /media/PANDORABOOT/uImage-3 && oldkernel=/media/PANDORABOOT/uImage-3
@@ -37,6 +43,7 @@ where your kernel is booted from (usually set in boot.txt / autoboot.txt)."
 copy it to the location where kernel is booted from (usually set in \
 boot.txt / autoboot.txt) or the system might not start after reboot."
     fi
+    sync
     if test -n "$DISPLAY"; then
       zenity --info --text "$msg"
     else
@@ -48,5 +55,5 @@ boot.txt / autoboot.txt) or the system might not start after reboot."
 }
 
 PACKAGE_STRIP = "no"
-SRC_URI[md5sum] = "2370f29cdff0ae2621344dea04fe1d21"
-SRC_URI[sha256sum] = "d00755889f464426f9cc0b9791716005d9460777ad3c31938d0e562d1f6e9926"
+SRC_URI[md5sum] = "37d538020a4b39de549e182ebe4b8e52"
+SRC_URI[sha256sum] = "e007b755a09134f5995c954ed251f822749bf94ddf7ab4c3f773f0802b2669e9"