omap3-pandora-kernel2: update to 3.2.45 + wifi fixes
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
index b6def4d..a435aa6 100644 (file)
@@ -4,12 +4,14 @@ LICENSE = "GPLv2"
 COMPATIBLE_MACHINE = "omap3-pandora"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-PR = "r2"
+PR = "r8"
 
 # we already build 2.6 kernel using OE infrastructure, and
 # as we don't know how to build another one into the same image
 # (especially out-of-tree modules), we just package manually prebuilt one
-SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r2.tar.bz2"
+# git://git.openpandora.org/pandora-kernel.git , branch pandora-3.2
+# commit: 598a3aac17511c02f9884711b25463ec5a5eeb4b
+SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_r8.tar.bz2"
 
 S = "${WORKDIR}"
 
@@ -21,6 +23,10 @@ do_install() {
 FILES_${PN} = "boot lib"
 
 pkg_postinst_${PN} () {
+  # this will cause depmod to be run on next boot
+  rm -f /lib/modules/`uname -r`/modules.dep
+  sync
+
   if ! grep -q '[[:blank:]]/[[:blank:]]*ubifs' /proc/mounts; then
     test -e /media/PANDORABOOT/uImage && oldkernel=/media/PANDORABOOT/uImage
     test -e /media/PANDORABOOT/uImage-3 && oldkernel=/media/PANDORABOOT/uImage-3
@@ -37,6 +43,7 @@ where your kernel is booted from (usually set in boot.txt / autoboot.txt)."
 copy it to the location where kernel is booted from (usually set in \
 boot.txt / autoboot.txt) or the system might not start after reboot."
     fi
+    sync
     if test -n "$DISPLAY"; then
       zenity --info --text "$msg"
     else
@@ -48,5 +55,5 @@ boot.txt / autoboot.txt) or the system might not start after reboot."
 }
 
 PACKAGE_STRIP = "no"
-SRC_URI[md5sum] = "13649475902466af040ef418c629872f"
-SRC_URI[sha256sum] = "03eed87da0e5b6b3f13c7e5e1abd92949293b20c2d8849419065c84e57efd33b"
+SRC_URI[md5sum] = "1a98932c37b5516cd734f5a95620f0aa"
+SRC_URI[sha256sum] = "816c518470ab5c358bec86ddb1890df8764d3f6e23d8cf6150fd8907389c1ee3"