omap3-pandora-kernel2: update
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
index 5702b89..251d07a 100644 (file)
@@ -4,13 +4,13 @@ LICENSE = "GPLv2"
 COMPATIBLE_MACHINE = "omap3-pandora"
 PACKAGE_ARCH = "${MACHINE_ARCH}"
 
-PR = "r18"
+PR = "r30"
 
 # we already build 2.6 kernel using OE infrastructure, and
 # as we don't know how to build another one into the same image
 # (especially out-of-tree modules), we just package manually prebuilt one
 # git://git.openpandora.org/pandora-kernel.git , branch pandora-3.2
-# commit: 318d016e58d6c63cfb32ebb55194cd4554dfaf68
+# commit: 96301b3f33648a5880cfd65588a3105f7d51e9d4
 # out-of-tree modules are built from:
 # http://git.openpandora.org/cgi-bin/gitweb.cgi?p=sgx.git
 # http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_modules.tar.bz2
@@ -21,9 +21,17 @@ S = "${WORKDIR}"
 do_install() {
   cp -a ${S}/boot ${D}/
   cp -a ${S}/lib ${D}/
+  rm -f ${D}/lib/modules/*/modules.dep*
+
+  # dupes from other OE packages..
+  rm -rf ${D}/lib/firmware/vicam
+  rm -rf ${D}/lib/firmware/ttusb-budget
 }
 
+PACKAGES =+ "linux-firmware-media"
+
 FILES_${PN} = "boot lib"
+FILES_linux-firmware-media = "lib/firmware"
 
 pkg_postinst_${PN} () {
   # this will cause depmod to be run on next boot
@@ -58,5 +66,5 @@ boot.txt / autoboot.txt) or the system might not start after reboot."
 }
 
 PACKAGE_STRIP = "no"
-SRC_URI[md5sum] = "7434654f7996c2eaec4c8daf9c5340f6"
-SRC_URI[sha256sum] = "f951d9ff87e2b3769c818767c2c9808a2086dd8f5fc5fa09f09ff484865232bd"
+SRC_URI[md5sum] = "b6007ac85ffc9e54635a3651accc7962"
+SRC_URI[sha256sum] = "9037ec170769884adab123e4a025a03de4b57080f82fb344018524779faf27c7"