various: reset PR of tasks following mainline Angstrom DISTRO_PR bump. Cosmetic change.
[openpandora.oe.git] / recipes / images / pandora-xfce-image.bb
index c4f3400..dca5ed7 100755 (executable)
@@ -1,14 +1,8 @@
 # XFCE image for the Pandora handheld console
 
-XSERVER ?= " \
-    xserver-xorg \
-    xf86-input-evdev \
-    xf86-input-mouse \
-    xf86-video-fbdev \
-    xf86-input-keyboard \
-"
+IMAGE_LINGUAS = "de-de fr-fr en-gb en-us es-es tr-tr"
 
-IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
+IMAGE_LOGIN_MANAGER = "shadow"
 
 inherit image
 
@@ -19,6 +13,7 @@ SPLASH = "psplash-omap3pandora"
 DEPENDS = "task-base"
 
 IMAGE_INSTALL += " \
+    task-pandora-core \
     task-pandora-xfce \
     ${SPLASH} \        
 "
@@ -26,7 +21,7 @@ IMAGE_INSTALL += " \
 IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
 
 #zap root password for release images
-#ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
+ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
 
 # Helper to say what image we built, include GIT tag and image name.
 PANDORA_VERSION_FILE = "${IMAGE_ROOTFS}/${sysconfdir}/op-version"