vairous: add in local updates for tasks/images.
[openpandora.oe.git] / recipes / images / pandora-validation-image.bb
index c648045..f0b4df8 100755 (executable)
@@ -1,26 +1,27 @@
 # Validation image for Pandora handheld console
 # for hardware testing and flashing images to NAND if copied to the SD in the correct places.
 
-IMAGE_LINGUAS = "de-de fr-fr en-gb en-us pt-br es-es kn-in ml-in ta-in"
+XSERVER ?= " \
+    xserver-xorg \
+    xf86-input-evdev \
+    xf86-input-mouse \
+    xf86-video-fbdev \
+    xf86-input-keyboard \
+"
 
-ANGSTROM_EXTRA_INSTALL ?= ""
+inherit image
 
 export IMAGE_BASENAME = "pandora-validation-image"
 
 DEPENDS = "task-base"
 
 IMAGE_INSTALL += " \
-    ${ANGSTROM_EXTRA_INSTALL} \
-       task-pandora-validation \
+  task-pandora-core \
+  task-pandora-validation \
 "
  
 IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
 
-#zap root password for release images
-#ROOTFS_POSTPROCESS_COMMAND += '${@base_conditional("DISTRO_TYPE", "release", "zap_root_password; ", "",d)}'
-
-inherit image
-
 # Helper to say what image we built, include GIT tag and image name.
 PANDORA_VERSION_FILE = "${IMAGE_ROOTFS}/${sysconfdir}/op-version"
 ROOTFS_POSTPROCESS_COMMAND += "OLD_PWD=$PWD; cd `dirname '${FILE_DIRNAME}'`; echo Tag Name: `git tag|tail -n 1`> ${PANDORA_VERSION_FILE};cd $OLD_PWD;"