fusilli-client: update
[openpandora.oe.git] / recipes / fusilli-client / fusilli-client_git.bb
index 1ff70cb..ffac71b 100644 (file)
@@ -4,7 +4,8 @@ LICENSE = "GPLv3"
 DEPENDS = "virtual/libsdl libsdl-net pandora-libpnd"
 RDEPENDS = "libsdl-net pandora-libpnd"
 
-PR = "r0"
+PR = "r2"
+PR_append = "+gitr${SRCPV}"
 
 SRC_URI = " \
   git://github.com/theZiz/fusilli-client.git;protocol=git;branch=master \
@@ -13,21 +14,18 @@ SRC_URI = " \
   file://sparrowDefines.h \
 "
 
-SRCREV = "60bb6d2d121eb23a59e6502d33ca1246be033710"
+SRCREV = "73642236bbce54852e2a40c4b373b96ee6055691"
 
 S = "${WORKDIR}/git"
 
-CFLAGS += "-g -DPANDORA"
-# crazy
-CFLAGS += "-DX86CPU"
+CFLAGS += "-DMOBILE_DEVICE -DPANDORA"
 
 do_compile() {
        cp ${WORKDIR}/sparrowNet.c ${S}/
        cp ${WORKDIR}/sparrowNet.h ${S}/
        cp ${WORKDIR}/sparrowDefines.h ${S}/
 
-       # not everyone knows how to write makefiles..
-       oe_runmake CPP='${CC}' SPARROW_FOLDER=. LIB= STATIC=sparrowNet.c \
+       oe_runmake SPARROW_FOLDER=. LIB= STATIC=sparrowNet.c \
                DYNAMIC='${LDFLAGS} -lSDL_net -lSDL -lpnd'
 }