task-pandora-xfce: Removed e2fsprogs-tune2fs (no provider for it?)
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r57"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   xchat \
21   links-x11 \
22   enchant \
23   aspell \
24   xwininfo \
25   curl \
26   dosfstools \
27   e2fsprogs \
28 #  xournal \
29 #  arora \
30 "
31
32 BLUETOOTH_GUI = " \
33   gnome-bluetooth \
34 "
35
36 IM_CLIENT = " \
37 #  pidgin \
38 #  libpurple-protocol-msn \
39 #  libpurple-protocol-yahoo \
40 #  libpurple-protocol-icq \
41 #  libpurple-protocol-aim \
42 "
43
44 DISPMAN = " \
45   slim \
46   slim-op-themes \
47 "
48
49 FONTS = " \
50   font-adobe-75dpi \
51   fontconfig fontconfig-utils font-util \
52   ttf-arphic-uming \
53   ttf-dejavu-common \
54   ttf-dejavu-sans \
55   ttf-dejavu-serif \
56   ttf-dejavu-sans-mono \
57   ttf-liberation-sans \
58   ttf-liberation-serif \
59   ttf-liberation-mono \
60   xorg-minimal-fonts \
61 "  
62
63 # Any default games we want to ship.
64 GAMES = " \
65 #  scummvm \
66 #  frozen-bubble \
67 #  gnome-games \  
68 #  numptyphysics \
69 "
70
71 GNOME_APPS = " \
72 #  gnome-mplayer \
73   gcalctool \ 
74   gnome-keyring gnome-keyring-pam-plugin \
75   gksu \
76 "
77
78 GSTREAMER = " \
79 #  gstreamer-ti \
80   gst-ffmpeg \
81   gst-omapfb \
82 #  gst-plugin-pulse \
83   gst-plugin-xvimagesink \
84   gst-plugins-base-meta \
85 #  gst-plugins-good-meta \
86 #  gst-plugins-bad-meta \
87 #  gst-plugins-ugly-meta \
88   gst-plugin-gles \
89 "
90
91 ICON_THEME = " \
92   hicolor-icon-theme \
93   elementary-icon-theme \
94   elementary-icon-theme-enable \
95 "
96
97 LAUNCHERS = " \
98 #  netbook-launcher-efl \
99   pandora-libpnd-minimenu \
100 #  pandora-pmenu \
101 "
102
103 PANDORA = " \
104   pandora-first-run-wizard hsetroot \
105   pandora-scripts \
106   pandora-wallpaper-official \
107   pandora-xfce-defaults \
108 #  pandora-midori-defaults midori \
109   libgles2d \
110   pandora-misc \
111   pandora-pndstore \
112 "
113
114 PERL = " \
115   perl \
116   task-perl-module-all \
117   libnet-dbus-perl \
118   libxml-parser-perl \
119   libxml-twig-perl \
120 "
121
122 PULSEAUDIO = " \
123 #  pulseaudio-alsa-wrapper \
124 #  pulseaudio-esd-wrapper \
125 #  pulseaudio-module-gconf \
126 #  libasound-module-ctl-pulse \
127 #  libasound-module-pcm-pulse \
128 "
129
130 PYTHON_LIBS = " \
131   python-shell \
132   python-pygtk \
133   python-pycairo \
134   gnome-vfs-plugin-http \
135   gnome-vfs-plugin-ftp \
136 "
137
138 QT_SUPPORT = " \
139  libqt3support4 \ 
140  libqtassistantclient4 \ 
141  libqtclucene4 \ 
142  libqtcore4 \ 
143  libqtdbus4 \ 
144  libqtdesigner4 \ 
145  libqtdesignercomponents4 \ 
146  libqtgui4 \ 
147  libqthelp4 \ 
148  libqtnetwork4 \  
149  libqtscript4 \ 
150  libqtscripttools4 \ 
151  libqtsql4 \ 
152  libqtsvg4 \ 
153  libqttest4 \ 
154  libqtwebkit4 \ 
155  libqtxml4 \  
156  qt4-tools \ 
157  qt4-assistant \ 
158  qt4-common \ 
159  qt4-dbus \ 
160  qt4-designer \ 
161  qt4-fonts \ 
162  qt4-linguist \ 
163  qt4-mkspecs \ 
164  qt4-pixeltool \ 
165  qt4-qt3to4 \
166  qt4-plugin-imageformat-jpeg \
167  qt4-plugin-imageformat-gif \
168 "
169
170
171 TOTEM = " \
172 #  totem \
173 #  totem-browser-plugin \
174 #  totem-plugin-bemused \
175 #  totem-plugin-gromit \
176 #  totem-plugin-media-player-keys \
177 #  totem-plugin-ontop \
178 #  totem-plugin-properties \
179 #  totem-plugin-screensaver \
180 #  totem-plugin-skipto \
181 #  totem-plugin-thumbnail \
182 "
183
184 TOUCHSCREEN = " \
185   gtk-touchscreen-mode-enable \
186   libgtkstylus \
187 #  xinput-calibrator \
188 "
189
190 XFCE46_BASE = " \
191   xfce4-dev-tools \
192   xfwm4 \
193   xfwm4-theme-default \
194   xfce-utils \  
195   xfce4-session \     
196   xfconf \
197   xfdesktop \
198   xfce4-panel \
199   xfce4-power-manager \
200   \
201   gtk-xfce-engine \
202   \
203   xfce4-panel-plugin-actions \
204   xfce4-panel-plugin-clock \
205   xfce4-panel-plugin-iconbox \
206   xfce4-panel-plugin-launcher \
207   xfce4-panel-plugin-pager \
208   xfce4-panel-plugin-separator \
209   xfce4-panel-plugin-showdesktop \
210   xfce4-panel-plugin-systray \
211   xfce4-panel-plugin-tasklist \
212   xfce4-panel-plugin-windowlist \   
213   xfce4-settings \
214   xfce-terminal \
215   thunar \
216 "
217
218 XFCE46_EXTRAS = " \
219   xfce4-notifyd \
220   xfce4-mixer \
221   xfce4-appfinder \
222   xfce4-battery-plugin \
223   xfprint \    
224   orage \
225   squeeze \
226   ristretto \
227   mousepad \ 
228   gigolo \
229   xdotool \
230 "
231
232 XFCE_THEMES = " \
233   xfwm4-theme-daloa \
234   xfwm4-theme-moheli \
235   xfwm4-theme-kokodi \
236   xfwm4-theme-sassandra \
237   xfwm4-themes \
238 "
239
240 XSERVER_BASE = " \
241   ${XSERVER} \
242   dbus-x11 \
243   desktop-file-utils \
244   iso-codes \
245   mime-support \
246   notification-daemon inotify-tools \
247   xauth \
248   xdg-utils \
249   xhost \
250   xinetd \
251   xinit \
252   xlsfonts \
253   xrdb \
254   xrefresh \
255   xset \
256   xvinfo \
257   devilspie \
258   encodings \
259   xterm \
260   xmodmap \
261 "
262
263 ADD_LIBS = " \
264   libbonobo \
265   libetpan \
266   libfribidi \
267   libgsf \
268   libidn \
269   libxslt \
270   wv \
271   libsamplerate0 \
272   glibc-gconv-cp1252 \
273   glibc-gconv-ibm850 \
274   glibc-gconv-iso8859-15 \
275   
276
277
278 RDEPENDS_${PN} = " \
279   task-pandora-core \
280   angstrom-x11-base-depends \
281   ${ANGSTROM_EXTRA_INSTALL} \
282   ${APPS} \
283   ${BLUETOOTH_GUI} \
284   ${IM_CLIENT} \
285   ${DISPMAN} \
286   ${FONTS} \
287   ${GAMES} \  
288   ${GNOME_APPS} \
289   ${GSTREAMER} \
290   ${ICON_THEME} \
291   ${LAUNCHERS} \
292   ${PANDORA} \
293   ${PERL} \
294   ${PULSEAUDIO} \
295   ${PYTHON_LIBS} \
296   ${QT_SUPPORT} \
297   ${TOTEM} \
298   ${TOUCHSCREEN} \
299   ${XSERVER_BASE} \
300   ${XFCE46_BASE} \
301   ${XFCE46_EXTRAS} \
302   ${XFCE_THEMES} \
303   ${ADD_LIBS} \
304   \
305   rxvt-unicode \
306 #  xst \
307 #  suspend-desktop \
308 #  teleport \
309   gdk-pixbuf-loader-png \
310   gdk-pixbuf-loader-xpm \
311   gdk-pixbuf-loader-jpeg \
312   pango-module-basic-x \
313   pango-module-basic-fc \
314   xcursor-transparent-theme \   
315   xterm \
316   jaaa nmap iperf \
317 #  gnuplot \
318 "