task-pandora-*: Cleanup image tasks.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r6.1"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16   firefox \
17   gnumeric \   
18   gimp \
19   networkmanager network-manager-applet \ 
20   synergy \
21   vnc \
22   x11vnc angstrom-x11vnc-xinit \
23   xmms \
24   xterm \
25 "
26
27 IM_CLIENT = " \
28   pidgin \
29   libpurple-protocol-msn \
30   libpurple-protocol-yahoo \
31   libpurple-protocol-icq \
32   libpurple-protocol-aim \
33 "
34
35 DISPMAN = " \
36   slim \
37 "
38
39 FONTS = " \
40   font-adobe-75dpi \
41   fontconfig fontconfig-utils font-util \
42   ttf-arphic-uming \
43   ttf-dejavu-common \
44   ttf-dejavu-sans \
45   ttf-dejavu-serif \
46   ttf-dejavu-sans-mono \
47   ttf-liberation-sans \
48   ttf-liberation-serif \
49   ttf-liberation-mono \
50   xorg-minimal-fonts \
51 "  
52
53 GNOME_APPS = " \
54 #  epiphany epiphany-extensions \
55 #  evince \  
56   gnome-games \
57   gnome-mplayer \
58   gcalctool \ 
59   gnome-bluetooth \     
60   gnome-keyring gnome-keyring-pam-plugin \
61 "
62
63 GNOME_GTK = " \
64 #  hicolor-icon-theme \
65 #  gnome-icon-theme \
66 #  angstrom-gnome-icon-theme-enable \
67 "
68
69 GSTREAMER = " \
70   gst-ffmpeg \
71   gst-omapfb \
72   gst-plugin-pulse \
73   gst-plugins-base-meta \
74 #  gst-plugins-good-meta \
75   gst-plugins-bad-meta \
76 #  gst-plugins-ugly-meta \
77 "
78
79 ICON_THEME = " \
80   tango-icon-theme \
81   tango-icon-theme-enable \
82 "
83
84 PERL = " \
85   perl \
86   task-perl-module-all \
87   libnet-dbus-perl \
88   libxml-parser-perl \
89   libxml-twig-perl \
90 "
91
92 PULSEAUDIO = " \
93   pulseaudio-alsa-wrapper \
94   pulseaudio-esd-wrapper \
95   pulseaudio-module-gconf \
96   libasound-module-ctl-pulse \
97   libasound-module-pcm-pulse \
98 "
99
100 TOTEM = " \
101   totem \
102   totem-browser-plugin \
103   totem-plugin-bemused \
104   totem-plugin-gromit \
105   totem-plugin-media-player-keys \
106   totem-plugin-ontop \
107   totem-plugin-properties \
108   totem-plugin-screensaver \
109   totem-plugin-skipto \
110   totem-plugin-thumbnail \
111 "
112
113 TOUCHSCREEN = " \
114 #  xf86-input-evtouch \
115   xf86-input-tslib \
116   gtk-touchscreen-mode-enable \
117   libgtkstylus \
118 "
119
120 XFCE46_BASE = " \
121   xfce4-dev-tools \
122   xfwm4 \
123   xfwm4-theme-default \
124   xfce-utils \  
125   xfce4-session \     
126   xfconf \
127   xfdesktop \
128   xfce4-panel \
129   \
130   gtk-xfce-engine \
131   \
132   xfce4-panel-plugin-actions \
133   xfce4-panel-plugin-clock \
134   xfce4-panel-plugin-iconbox \
135   xfce4-panel-plugin-launcher \
136   xfce4-panel-plugin-pager \
137   xfce4-panel-plugin-separator \
138   xfce4-panel-plugin-showdesktop \
139   xfce4-panel-plugin-systray \
140   xfce4-panel-plugin-tasklist \
141   xfce4-panel-plugin-windowlist \   
142   xfce4-settings \
143   xfce-terminal \
144   thunar \
145 "
146
147 XFCE46_EXTRAS = " \
148   xfce4-notifyd \
149   xfce4-mixer \
150   xfce4-appfinder \
151   xfprint \    
152   midori \
153   orage \
154   squeeze \
155   ristretto \
156   mousepad \ 
157   gigolo \
158 "
159
160 XFCE_THEMES = " \
161   xfwm4-theme-daloa \
162   xfwm4-theme-moheli \
163   xfwm4-theme-default-4.0 \
164   xfwm4-theme-default-4.2 \
165   xfwm4-theme-default-4.4 \
166   xfwm4-theme-kokodi \
167   xfwm4-theme-moheli \
168   xfwm4-theme-sassandra \
169   xfwm4-theme-stoneage \
170   xfwm4-theme-therapy \
171   xfwm4-theme-tyrex \
172   xfwm4-theme-wallis \  
173 "
174
175 XSERVER_BASE = " \
176   ${XSERVER} \
177   dbus-x11 \
178   desktop-file-utils \
179   iso-codes \
180   mime-support \
181   notification-daemon inotify-tools \
182   xauth \
183   xdg-utils \
184   xhost \
185   xinetd \
186   xinit \
187   xlsfonts \
188   xrdb \
189   xrefresh \
190   xset \
191   xvinfo \
192 "
193
194 RDEPENDS_${PN} = " \
195   task-pandora-core \
196   angstrom-x11-base-depends \
197   ${ANGSTROM_EXTRA_INSTALL} \
198   ${APPS} \
199   ${IM_CLIENT} \
200   ${DISPMAN} \
201   ${FONTS} \
202   ${GNOME_GTK} \
203   ${GNOME_APPS} \
204   ${GSTREAMER} \
205   ${ICON_THEME} \
206   ${PERL} \
207   ${PULSEAUDIO} \
208   ${TOTEM} \
209   ${TOUCHSCREEN} \
210   ${XSERVER_BASE} \
211   ${XFCE46_BASE} \
212   ${XFCE46_EXTRAS} \
213   ${XFCE_THEMES} \
214   \
215 #       pandora-auto-startx \
216   pandora-first-run-wizard \
217   \
218   rxvt-unicode \
219   xst \
220   suspend-desktop \
221   teleport \
222   gdk-pixbuf-loader-png \
223   gdk-pixbuf-loader-xpm \
224   gdk-pixbuf-loader-jpeg \
225   pango-module-basic-x \
226   pango-module-basic-fc \
227   xcursor-transparent-theme \   
228   mime-support \
229   xterm xmms \
230   jaaa nmap iperf gnuplot \
231   x11vnc angstrom-x11vnc-xinit \
232 "