f39bfffc4ac2f00a9331f032017d51304ada7b98
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r1"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16   firefox \
17   gnumeric \   
18 #  gimp \
19   networkmanager network-manager-applet \ 
20 #  synergy \
21   vnc x11vnc angstrom-x11vnc-xinit \
22 #  xchat \
23   xournal \
24 "
25
26 BLUETOOTH_GUI = " \
27   blueman \
28   gnome-bluetooth \
29 "
30
31 IM_CLIENT = " \
32   pidgin \
33   libpurple-protocol-msn \
34   libpurple-protocol-yahoo \
35   libpurple-protocol-icq \
36   libpurple-protocol-aim \
37 "
38
39 DISPMAN = " \
40   slim \
41   slim-op-themes \
42 "
43
44 FONTS = " \
45   font-adobe-75dpi \
46   fontconfig fontconfig-utils font-util \
47   ttf-arphic-uming \
48   ttf-dejavu-common \
49   ttf-dejavu-sans \
50   ttf-dejavu-serif \
51   ttf-dejavu-sans-mono \
52   ttf-liberation-sans \
53   ttf-liberation-serif \
54   ttf-liberation-mono \
55   xorg-minimal-fonts \
56 "  
57
58 # Any default games we want to ship.
59 GAMES = " \
60 #  scummvm \
61 #  frozen-bubble \
62 #  gnome-games \  
63 "
64
65 GNOME_APPS = " \
66   gnome-mplayer \
67 #  gcalctool \ 
68   gnome-keyring gnome-keyring-pam-plugin \
69   gksu \
70 "
71
72 GNOME_GTK = " \
73 #  gnome-icon-theme \
74 #  angstrom-gnome-icon-theme-enable \
75 "
76
77 GSTREAMER = " \
78 #  gstreamer-ti \
79   gst-ffmpeg \
80   gst-omapfb \
81 #  gst-plugin-pulse \
82   gst-plugin-xvimagesink \
83   gst-plugins-base-meta \
84   gst-plugins-good-meta gst-plugins-bad-meta \
85 #  gst-plugins-ugly-meta \
86 "
87
88 ICON_THEME = " \
89   hicolor-icon-theme \
90   elementary-icon-theme \
91   elementary-icon-theme-enable \
92 "
93
94 LAUNCHERS = " \
95   netbook-launcher-efl \
96 "
97
98 PANDORA = " \
99   pandora-first-run-wizard hsetroot \
100   pandora-scripts \
101   pandora-wallpaper-official pandora-wallpaper-community \
102   pandora-xfce-defaults \
103   pandora-xmms-defaults xmms \
104   pandora-midori-defaults midori \
105   pandora-pmenu libgles2d \
106   libgles-omap3-x11demos \  
107 "
108
109 PERL = " \
110   perl \
111   task-perl-module-all \
112   libnet-dbus-perl \
113   libxml-parser-perl \
114   libxml-twig-perl \
115 "
116
117 PULSEAUDIO = " \
118 #  pulseaudio-alsa-wrapper \
119 #  pulseaudio-esd-wrapper \
120 #  pulseaudio-module-gconf \
121 #  libasound-module-ctl-pulse \
122 #  libasound-module-pcm-pulse \
123 "
124
125 QT_SELECTED = "qt4-x11-free"
126 #  qt4-x11-free-gles \
127
128 QT_SUPPORT = " \
129   ${QT_SELECTED} \
130 "
131
132 # We want all of the Qt metapackage (for dev use) without the demos/examples.
133 BAD_RRECOMMENDS += " \
134   ${QT_SELECTED}-demos \
135   ${QT_SELECTED}-examples \
136 "
137
138 TOTEM = " \
139   totem \
140   totem-browser-plugin \
141   totem-plugin-bemused \
142   totem-plugin-gromit \
143   totem-plugin-media-player-keys \
144   totem-plugin-ontop \
145   totem-plugin-properties \
146   totem-plugin-screensaver \
147   totem-plugin-skipto \
148   totem-plugin-thumbnail \
149 "
150
151 TOUCHSCREEN = " \
152   gtk-touchscreen-mode-enable \
153   libgtkstylus \
154   xinput-calibrator \
155 "
156
157 XFCE46_BASE = " \
158   xfce4-dev-tools \
159   xfwm4 \
160   xfwm4-theme-default \
161   xfce-utils \  
162   xfce4-session \     
163   xfconf \
164   xfdesktop \
165   xfce4-panel \
166   xfce4-power-manager \
167   \
168   gtk-xfce-engine \
169   \
170   xfce4-panel-plugin-actions \
171   xfce4-panel-plugin-clock \
172   xfce4-panel-plugin-iconbox \
173   xfce4-panel-plugin-launcher \
174   xfce4-panel-plugin-pager \
175   xfce4-panel-plugin-separator \
176   xfce4-panel-plugin-showdesktop \
177   xfce4-panel-plugin-systray \
178   xfce4-panel-plugin-tasklist \
179   xfce4-panel-plugin-windowlist \   
180   xfce4-settings \
181   xfce-terminal \
182   thunar \
183 "
184
185 XFCE46_EXTRAS = " \
186   xfce4-notifyd \
187   xfce4-mixer \
188   xfce4-appfinder \
189   xfce4-battery-plugin \
190   xfprint \    
191   orage \
192   squeeze \
193   ristretto \
194   mousepad \ 
195   gigolo \
196 "
197
198 XFCE_THEMES = " \
199   xfwm4-theme-daloa \
200   xfwm4-theme-moheli \
201 #  xfwm4-theme-default-4.0 \
202 #  xfwm4-theme-default-4.2 \
203 #  xfwm4-theme-default-4.4 \
204   xfwm4-theme-kokodi \
205   xfwm4-theme-sassandra \
206 #  xfwm4-theme-stoneage \
207 #  xfwm4-theme-therapy \
208 #  xfwm4-theme-tyrex \
209 #  xfwm4-theme-wallis \  
210   xfwm4-themes \
211 "
212
213 XSERVER_BASE = " \
214   ${XSERVER} \
215   dbus-x11 \
216   desktop-file-utils \
217   iso-codes \
218   mime-support \
219   notification-daemon inotify-tools \
220   xauth \
221   xdg-utils \
222   xhost \
223   xinetd \
224   xinit \
225   xlsfonts \
226   xrdb \
227   xrefresh \
228   xset \
229   xvinfo \
230   devilspie \
231   encodings \
232   xterm \
233   xmodmap \
234 "
235
236 RDEPENDS_${PN} = " \
237   task-pandora-core \
238   angstrom-x11-base-depends \
239   ${ANGSTROM_EXTRA_INSTALL} \
240   ${APPS} \
241   ${BLUETOOTH_GUI} \
242   ${IM_CLIENT} \
243   ${DISPMAN} \
244   ${FONTS} \
245   ${GAMES} \  
246   ${GNOME_GTK} \
247   ${GNOME_APPS} \
248   ${GSTREAMER} \
249   ${ICON_THEME} \
250   ${LAUNCHERS} \
251   ${PANDORA} \
252   ${PERL} \
253   ${PULSEAUDIO} \
254   ${QT_SUPPORT} \
255   ${TOTEM} \
256   ${TOUCHSCREEN} \
257   ${XSERVER_BASE} \
258   ${XFCE46_BASE} \
259   ${XFCE46_EXTRAS} \
260   ${XFCE_THEMES} \
261   \
262   rxvt-unicode \
263 #  xst \
264 #  suspend-desktop \
265 #  teleport \
266   gdk-pixbuf-loader-png \
267   gdk-pixbuf-loader-xpm \
268   gdk-pixbuf-loader-jpeg \
269   pango-module-basic-x \
270   pango-module-basic-fc \
271   xcursor-transparent-theme \   
272   xterm xmms \
273   jaaa nmap iperf \
274 #  gnuplot \
275 "