c4d8e335e8e1c5b007d65196516085e912163b8d
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r41"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   xchat \
21 #  xournal \
22   arora \
23 "
24
25 BLUETOOTH_GUI = " \
26   gnome-bluetooth \
27 "
28
29 IM_CLIENT = " \
30 #  pidgin \
31 #  libpurple-protocol-msn \
32 #  libpurple-protocol-yahoo \
33 #  libpurple-protocol-icq \
34 #  libpurple-protocol-aim \
35 "
36
37 DISPMAN = " \
38   slim \
39   slim-op-themes \
40 "
41
42 FONTS = " \
43   font-adobe-75dpi \
44   fontconfig fontconfig-utils font-util \
45   ttf-arphic-uming \
46   ttf-dejavu-common \
47   ttf-dejavu-sans \
48   ttf-dejavu-serif \
49   ttf-dejavu-sans-mono \
50   ttf-liberation-sans \
51   ttf-liberation-serif \
52   ttf-liberation-mono \
53   xorg-minimal-fonts \
54 "  
55
56 # Any default games we want to ship.
57 GAMES = " \
58 #  scummvm \
59 #  frozen-bubble \
60 #  gnome-games \  
61 #  numptyphysics \
62 "
63
64 GNOME_APPS = " \
65 #  gnome-mplayer \
66   gcalctool \ 
67   gnome-keyring gnome-keyring-pam-plugin \
68   gksu \
69 "
70
71 GSTREAMER = " \
72 #  gstreamer-ti \
73   gst-ffmpeg \
74   gst-omapfb \
75 #  gst-plugin-pulse \
76   gst-plugin-xvimagesink \
77   gst-plugins-base-meta \
78 #  gst-plugins-good-meta \
79 #  gst-plugins-bad-meta \
80 #  gst-plugins-ugly-meta \
81   gst-plugin-gles \
82 "
83
84 ICON_THEME = " \
85   hicolor-icon-theme \
86   elementary-icon-theme \
87   elementary-icon-theme-enable \
88 "
89
90 LAUNCHERS = " \
91 #  netbook-launcher-efl \
92   pandora-libpnd-minimenu \
93   pandora-pmenu \
94 "
95
96 PANDORA = " \
97   pandora-first-run-wizard hsetroot \
98   pandora-scripts \
99   pandora-wallpaper-official pandora-wallpaper-community \
100   pandora-xfce-defaults \
101   pandora-midori-defaults midori \
102   libgles2d \
103   pandora-misc \
104 "
105
106 PERL = " \
107   perl \
108   task-perl-module-all \
109   libnet-dbus-perl \
110   libxml-parser-perl \
111   libxml-twig-perl \
112 "
113
114 PULSEAUDIO = " \
115 #  pulseaudio-alsa-wrapper \
116 #  pulseaudio-esd-wrapper \
117 #  pulseaudio-module-gconf \
118 #  libasound-module-ctl-pulse \
119 #  libasound-module-pcm-pulse \
120 "
121
122 PYTHON_LIBS = " \
123   python-shell \
124   python-pygtk \
125   python-pycairo \
126   gnome-vfs-plugin-http \
127   gnome-vfs-plugin-ftp \
128 "
129
130 QT_SELECTED = " qt4-x11-free \
131 "
132 # qt4-x11-free"
133 # qt4-x11-free-gles"
134
135 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
136
137 QT_SUPPORT = " \
138   ${QT_SELECTED} \
139   qt4-plugin-imageformat-jpeg \
140   qt4-plugin-imageformat-gif \
141 "
142
143 # We want all of the Qt metapackage (for dev use) without the demos/examples.
144 BAD_RRECOMMENDS += " \
145   ${QT_SELECTED}-demos \
146   ${QT_SELECTED}-examples \
147 "
148
149 TOTEM = " \
150 #  totem \
151 #  totem-browser-plugin \
152 #  totem-plugin-bemused \
153 #  totem-plugin-gromit \
154 #  totem-plugin-media-player-keys \
155 #  totem-plugin-ontop \
156 #  totem-plugin-properties \
157 #  totem-plugin-screensaver \
158 #  totem-plugin-skipto \
159 #  totem-plugin-thumbnail \
160 "
161
162 TOUCHSCREEN = " \
163   gtk-touchscreen-mode-enable \
164   libgtkstylus \
165 #  xinput-calibrator \
166 "
167
168 XFCE46_BASE = " \
169   xfce4-dev-tools \
170   xfwm4 \
171   xfwm4-theme-default \
172   xfce-utils \  
173   xfce4-session \     
174   xfconf \
175   xfdesktop \
176   xfce4-panel \
177   xfce4-power-manager \
178   \
179   gtk-xfce-engine \
180   \
181   xfce4-panel-plugin-actions \
182   xfce4-panel-plugin-clock \
183   xfce4-panel-plugin-iconbox \
184   xfce4-panel-plugin-launcher \
185   xfce4-panel-plugin-pager \
186   xfce4-panel-plugin-separator \
187   xfce4-panel-plugin-showdesktop \
188   xfce4-panel-plugin-systray \
189   xfce4-panel-plugin-tasklist \
190   xfce4-panel-plugin-windowlist \   
191   xfce4-settings \
192   xfce-terminal \
193   thunar \
194 "
195
196 XFCE46_EXTRAS = " \
197   xfce4-notifyd \
198   xfce4-mixer \
199   xfce4-appfinder \
200   xfce4-battery-plugin \
201   xfprint \    
202   orage \
203   squeeze \
204   ristretto \
205   mousepad \ 
206   gigolo \
207 "
208
209 XFCE_THEMES = " \
210   xfwm4-theme-daloa \
211   xfwm4-theme-moheli \
212   xfwm4-theme-kokodi \
213   xfwm4-theme-sassandra \
214   xfwm4-themes \
215 "
216
217 XSERVER_BASE = " \
218   ${XSERVER} \
219   dbus-x11 \
220   desktop-file-utils \
221   iso-codes \
222   mime-support \
223   notification-daemon inotify-tools \
224   xauth \
225   xdg-utils \
226   xhost \
227   xinetd \
228   xinit \
229   xlsfonts \
230   xrdb \
231   xrefresh \
232   xset \
233   xvinfo \
234   devilspie \
235   encodings \
236   xterm \
237   xmodmap \
238 "
239
240 ADD_LIBS = " \
241   libbonobo \
242   libetpan \
243   libfribidi \
244   libgsf \
245   libidn \
246   wv \
247   libsamplerate0 \
248
249
250 RDEPENDS_${PN} = " \
251   task-pandora-core \
252   angstrom-x11-base-depends \
253   ${ANGSTROM_EXTRA_INSTALL} \
254   ${APPS} \
255   ${BLUETOOTH_GUI} \
256   ${IM_CLIENT} \
257   ${DISPMAN} \
258   ${FONTS} \
259   ${GAMES} \  
260   ${GNOME_APPS} \
261   ${GSTREAMER} \
262   ${ICON_THEME} \
263   ${LAUNCHERS} \
264   ${PANDORA} \
265   ${PERL} \
266   ${PULSEAUDIO} \
267   ${PYTHON_LIBS} \
268   ${QT_SUPPORT} \
269   ${TOTEM} \
270   ${TOUCHSCREEN} \
271   ${XSERVER_BASE} \
272   ${XFCE46_BASE} \
273   ${XFCE46_EXTRAS} \
274   ${XFCE_THEMES} \
275   ${ADD_LIBS} \
276   \
277   rxvt-unicode \
278 #  xst \
279 #  suspend-desktop \
280 #  teleport \
281   gdk-pixbuf-loader-png \
282   gdk-pixbuf-loader-xpm \
283   gdk-pixbuf-loader-jpeg \
284   pango-module-basic-x \
285   pango-module-basic-fc \
286   xcursor-transparent-theme \   
287   xterm \
288   jaaa nmap iperf \
289 #  gnuplot \
290 "