omap3-pandora-kernel: add a few more USB TV card modules
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r61"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   xchat \
21   links-x11 \
22   enchant \
23   aspell \
24   xwininfo \
25   curl \
26   dosfstools \
27 #  xournal \
28 #  arora \
29 "
30
31 BLUETOOTH_GUI = " \
32   gnome-bluetooth \
33 "
34
35 IM_CLIENT = " \
36 #  pidgin \
37 #  libpurple-protocol-msn \
38 #  libpurple-protocol-yahoo \
39 #  libpurple-protocol-icq \
40 #  libpurple-protocol-aim \
41 "
42
43 DISPMAN = " \
44   slim \
45   slim-op-themes \
46 "
47
48 FONTS = " \
49   font-adobe-75dpi \
50   fontconfig fontconfig-utils font-util \
51   ttf-arphic-uming \
52   ttf-dejavu-common \
53   ttf-dejavu-sans \
54   ttf-dejavu-serif \
55   ttf-dejavu-sans-mono \
56   ttf-liberation-sans \
57   ttf-liberation-serif \
58   ttf-liberation-mono \
59   xorg-minimal-fonts \
60 "  
61
62 # Any default games we want to ship.
63 GAMES = " \
64 #  scummvm \
65 #  frozen-bubble \
66 #  gnome-games \  
67 #  numptyphysics \
68 "
69
70 GNOME_APPS = " \
71 #  gnome-mplayer \
72   gcalctool \ 
73   gnome-keyring gnome-keyring-pam-plugin \
74   gksu \
75 "
76
77 GSTREAMER = " \
78 #  gstreamer-ti \
79   gst-ffmpeg \
80   gst-omapfb \
81 #  gst-plugin-pulse \
82   gst-plugin-xvimagesink \
83   gst-plugins-base-meta \
84 #  gst-plugins-good-meta \
85 #  gst-plugins-bad-meta \
86 #  gst-plugins-ugly-meta \
87   gst-plugin-gles \
88 "
89
90 ICON_THEME = " \
91   hicolor-icon-theme \
92   elementary-icon-theme \
93   elementary-icon-theme-enable \
94 "
95
96 LAUNCHERS = " \
97 #  netbook-launcher-efl \
98   pandora-libpnd-minimenu \
99 #  pandora-pmenu \
100 "
101
102 PANDORA = " \
103   pandora-first-run-wizard hsetroot \
104   pandora-scripts \
105   pandora-wallpaper-official \
106   pandora-xfce-defaults \
107 #  pandora-midori-defaults midori \
108   libgles2d \
109   pandora-misc \
110   pandora-pndstore \
111 "
112
113 PERL = " \
114   perl \
115   task-perl-module-all \
116   libnet-dbus-perl \
117   libxml-parser-perl \
118   libxml-twig-perl \
119 "
120
121 PULSEAUDIO = " \
122 #  pulseaudio-alsa-wrapper \
123 #  pulseaudio-esd-wrapper \
124 #  pulseaudio-module-gconf \
125 #  libasound-module-ctl-pulse \
126 #  libasound-module-pcm-pulse \
127 "
128
129 PYTHON_LIBS = " \
130   python-shell \
131   python-pygtk \
132   python-pycairo \
133   gnome-vfs-plugin-http \
134   gnome-vfs-plugin-ftp \
135 "
136
137 QT_SUPPORT = " \
138  libqt3support4 \ 
139  libqtassistantclient4 \ 
140  libqtclucene4 \ 
141  libqtcore4 \ 
142  libqtdbus4 \ 
143  libqtdesigner4 \ 
144  libqtdesignercomponents4 \ 
145  libqtgui4 \ 
146  libqthelp4 \ 
147  libqtnetwork4 \  
148  libqtscript4 \ 
149  libqtscripttools4 \ 
150  libqtsql4 \ 
151  libqtsvg4 \ 
152  libqttest4 \ 
153  libqtwebkit4 \ 
154  libqtxml4 \  
155  qt4-tools \ 
156  qt4-assistant \ 
157  qt4-common \ 
158  qt4-dbus \ 
159  qt4-designer \ 
160  qt4-fonts \ 
161  qt4-linguist \ 
162  qt4-mkspecs \ 
163  qt4-pixeltool \ 
164  qt4-qt3to4 \
165  qt4-plugin-imageformat-jpeg \
166  qt4-plugin-imageformat-gif \
167 "
168
169
170 TOTEM = " \
171 #  totem \
172 #  totem-browser-plugin \
173 #  totem-plugin-bemused \
174 #  totem-plugin-gromit \
175 #  totem-plugin-media-player-keys \
176 #  totem-plugin-ontop \
177 #  totem-plugin-properties \
178 #  totem-plugin-screensaver \
179 #  totem-plugin-skipto \
180 #  totem-plugin-thumbnail \
181 "
182
183 TOUCHSCREEN = " \
184   gtk-touchscreen-mode-enable \
185   libgtkstylus \
186 #  xinput-calibrator \
187 "
188
189 XFCE46_BASE = " \
190   xfce4-dev-tools \
191   xfwm4 \
192   xfwm4-theme-default \
193   xfce-utils \  
194   xfce4-session \     
195   xfconf \
196   xfdesktop \
197   xfce4-panel \
198   xfce4-power-manager \
199   \
200   gtk-xfce-engine \
201   \
202   xfce4-panel-plugin-actions \
203   xfce4-panel-plugin-clock \
204   xfce4-panel-plugin-iconbox \
205   xfce4-panel-plugin-launcher \
206   xfce4-panel-plugin-pager \
207   xfce4-panel-plugin-separator \
208   xfce4-panel-plugin-showdesktop \
209   xfce4-panel-plugin-systray \
210   xfce4-panel-plugin-tasklist \
211   xfce4-panel-plugin-windowlist \   
212   xfce4-settings \
213   xfce-terminal \
214   thunar \
215 "
216
217 XFCE46_EXTRAS = " \
218   xfce4-notifyd \
219   xfce4-mixer \
220   xfce4-appfinder \
221   xfce4-battery-plugin \
222   xfprint \    
223   orage \
224   squeeze \
225   ristretto \
226   mousepad \ 
227   gigolo \
228   xdotool \
229 "
230
231 XFCE_THEMES = " \
232   xfwm4-theme-daloa \
233   xfwm4-theme-moheli \
234   xfwm4-theme-kokodi \
235   xfwm4-theme-sassandra \
236   xfwm4-themes \
237 "
238
239 XSERVER_BASE = " \
240   ${XSERVER} \
241   dbus-x11 \
242   desktop-file-utils \
243   iso-codes \
244   mime-support \
245   notification-daemon inotify-tools \
246   xauth \
247   xdg-utils \
248   xhost \
249   xinetd \
250   xinit \
251   xlsfonts \
252   xrdb \
253   xrefresh \
254   xset \
255   xvinfo \
256   devilspie \
257   encodings \
258   xterm \
259   xmodmap \
260 "
261
262 ADD_LIBS = " \
263   libbonobo \
264   libetpan \
265   libfribidi \
266   libgsf \
267   libidn \
268   libxslt \
269   wv \
270   libsamplerate0 \
271   glibc-gconv-cp1252 \
272   glibc-gconv-ibm850 \
273   glibc-gconv-iso8859-15 \
274   gvfsd-sftp \
275   sshfs-fuse \
276   rtl8712-module \
277   rtl8192u-module \
278
279
280 RDEPENDS_${PN} = " \
281   task-pandora-core \
282   angstrom-x11-base-depends \
283   ${ANGSTROM_EXTRA_INSTALL} \
284   ${APPS} \
285   ${BLUETOOTH_GUI} \
286   ${IM_CLIENT} \
287   ${DISPMAN} \
288   ${FONTS} \
289   ${GAMES} \  
290   ${GNOME_APPS} \
291   ${GSTREAMER} \
292   ${ICON_THEME} \
293   ${LAUNCHERS} \
294   ${PANDORA} \
295   ${PERL} \
296   ${PULSEAUDIO} \
297   ${PYTHON_LIBS} \
298   ${QT_SUPPORT} \
299   ${TOTEM} \
300   ${TOUCHSCREEN} \
301   ${XSERVER_BASE} \
302   ${XFCE46_BASE} \
303   ${XFCE46_EXTRAS} \
304   ${XFCE_THEMES} \
305   ${ADD_LIBS} \
306   \
307   rxvt-unicode \
308 #  xst \
309 #  suspend-desktop \
310 #  teleport \
311   gdk-pixbuf-loader-png \
312   gdk-pixbuf-loader-xpm \
313   gdk-pixbuf-loader-jpeg \
314   pango-module-basic-x \
315   pango-module-basic-fc \
316   xcursor-transparent-theme \   
317   xterm \
318   jaaa nmap iperf \
319 #  gnuplot \
320 "