task-pandora-xfce: Add missing Python libs to the Xfce image task.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r31"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16 #  firefox \
17   gnumeric \   
18 #  gimp \
19   networkmanager network-manager-applet \ 
20 #  synergy \
21   vnc x11vnc angstrom-x11vnc-xinit \
22   xchat \
23 #  xournal \
24   arora \
25 "
26
27 BLUETOOTH_GUI = " \
28   gnome-bluetooth \
29 "
30
31 IM_CLIENT = " \
32   pidgin \
33   libpurple-protocol-msn \
34   libpurple-protocol-yahoo \
35   libpurple-protocol-icq \
36   libpurple-protocol-aim \
37 "
38
39 DISPMAN = " \
40   slim \
41   slim-op-themes \
42 "
43
44 FONTS = " \
45   font-adobe-75dpi \
46   fontconfig fontconfig-utils font-util \
47   ttf-arphic-uming \
48   ttf-dejavu-common \
49   ttf-dejavu-sans \
50   ttf-dejavu-serif \
51   ttf-dejavu-sans-mono \
52   ttf-liberation-sans \
53   ttf-liberation-serif \
54   ttf-liberation-mono \
55   xorg-minimal-fonts \
56 "  
57
58 # Any default games we want to ship.
59 GAMES = " \
60 #  scummvm \
61 #  frozen-bubble \
62 #  gnome-games \  
63 #  numptyphysics \
64 "
65
66 GNOME_APPS = " \
67 #  gnome-mplayer \
68 #  gcalctool \ 
69   gnome-keyring gnome-keyring-pam-plugin \
70   gksu \
71 "
72
73 GNOME_GTK = " \
74 #  gnome-icon-theme \
75 #  angstrom-gnome-icon-theme-enable \
76 "
77
78 GSTREAMER = " \
79 #  gstreamer-ti \
80   gst-ffmpeg \
81   gst-omapfb \
82 #  gst-plugin-pulse \
83   gst-plugin-xvimagesink \
84   gst-plugins-base-meta \
85 #  gst-plugins-good-meta \
86 #  gst-plugins-bad-meta \
87 #  gst-plugins-ugly-meta \
88   gst-plugin-gles \
89 "
90
91 ICON_THEME = " \
92   hicolor-icon-theme \
93   elementary-icon-theme \
94   elementary-icon-theme-enable \
95 "
96
97 LAUNCHERS = " \
98 #  netbook-launcher-efl \
99   pandora-libpnd-minimenu \
100   pandora-pmenu \
101 "
102
103 PANDORA = " \
104   pandora-first-run-wizard hsetroot \
105   pandora-scripts \
106   pandora-wallpaper-official pandora-wallpaper-community \
107   pandora-xfce-defaults \
108   pandora-midori-defaults midori \
109   libgles2d \
110   pandora-misc \
111 "
112
113 PERL = " \
114   perl \
115   task-perl-module-all \
116   libnet-dbus-perl \
117   libxml-parser-perl \
118   libxml-twig-perl \
119 "
120
121 PULSEAUDIO = " \
122 #  pulseaudio-alsa-wrapper \
123 #  pulseaudio-esd-wrapper \
124 #  pulseaudio-module-gconf \
125 #  libasound-module-ctl-pulse \
126 #  libasound-module-pcm-pulse \
127 "
128
129 PYTHON_LIBS = " \
130   python-shell \
131   python-pygtk \
132   python-pycairo \
133   gnome-vfs-plugin-http \
134   gnome-vfs-plugin-ftp \
135 "
136
137 QT_SELECTED = " qt4-x11-free \
138 "
139 # qt4-x11-free"
140 # qt4-x11-free-gles"
141
142 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
143
144 QT_SUPPORT = " \
145   ${QT_SELECTED} \
146   qt4-plugin-imageformat-jpeg \
147   qt4-plugin-imageformat-gif \
148 "
149
150 # We want all of the Qt metapackage (for dev use) without the demos/examples.
151 BAD_RRECOMMENDS += " \
152   ${QT_SELECTED}-demos \
153   ${QT_SELECTED}-examples \
154 "
155
156 TOTEM = " \
157 #  totem \
158 #  totem-browser-plugin \
159 #  totem-plugin-bemused \
160 #  totem-plugin-gromit \
161 #  totem-plugin-media-player-keys \
162 #  totem-plugin-ontop \
163 #  totem-plugin-properties \
164 #  totem-plugin-screensaver \
165 #  totem-plugin-skipto \
166 #  totem-plugin-thumbnail \
167 "
168
169 TOUCHSCREEN = " \
170   gtk-touchscreen-mode-enable \
171   libgtkstylus \
172 #  xinput-calibrator \
173 "
174
175 XFCE46_BASE = " \
176   xfce4-dev-tools \
177   xfwm4 \
178   xfwm4-theme-default \
179   xfce-utils \  
180   xfce4-session \     
181   xfconf \
182   xfdesktop \
183   xfce4-panel \
184   xfce4-power-manager \
185   \
186   gtk-xfce-engine \
187   \
188   xfce4-panel-plugin-actions \
189   xfce4-panel-plugin-clock \
190   xfce4-panel-plugin-iconbox \
191   xfce4-panel-plugin-launcher \
192   xfce4-panel-plugin-pager \
193   xfce4-panel-plugin-separator \
194   xfce4-panel-plugin-showdesktop \
195   xfce4-panel-plugin-systray \
196   xfce4-panel-plugin-tasklist \
197   xfce4-panel-plugin-windowlist \   
198   xfce4-settings \
199   xfce-terminal \
200   thunar \
201 "
202
203 XFCE46_EXTRAS = " \
204   xfce4-notifyd \
205   xfce4-mixer \
206   xfce4-appfinder \
207   xfce4-battery-plugin \
208   xfprint \    
209   orage \
210   squeeze \
211   ristretto \
212   mousepad \ 
213   gigolo \
214 "
215
216 XFCE_THEMES = " \
217   xfwm4-theme-daloa \
218   xfwm4-theme-moheli \
219   xfwm4-theme-kokodi \
220   xfwm4-theme-sassandra \
221   xfwm4-themes \
222 "
223
224 XSERVER_BASE = " \
225   ${XSERVER} \
226   dbus-x11 \
227   desktop-file-utils \
228   iso-codes \
229   mime-support \
230   notification-daemon inotify-tools \
231   xauth \
232   xdg-utils \
233   xhost \
234   xinetd \
235   xinit \
236   xlsfonts \
237   xrdb \
238   xrefresh \
239   xset \
240   xvinfo \
241   devilspie \
242   encodings \
243   xterm \
244   xmodmap \
245 "
246
247 RDEPENDS_${PN} = " \
248   task-pandora-core \
249   angstrom-x11-base-depends \
250   ${ANGSTROM_EXTRA_INSTALL} \
251   ${APPS} \
252   ${BLUETOOTH_GUI} \
253   ${IM_CLIENT} \
254   ${DISPMAN} \
255   ${FONTS} \
256   ${GAMES} \  
257   ${GNOME_GTK} \
258   ${GNOME_APPS} \
259   ${GSTREAMER} \
260   ${ICON_THEME} \
261   ${LAUNCHERS} \
262   ${PANDORA} \
263   ${PERL} \
264   ${PULSEAUDIO} \
265   ${PYTHON_LIBS} \
266   ${QT_SUPPORT} \
267   ${TOTEM} \
268   ${TOUCHSCREEN} \
269   ${XSERVER_BASE} \
270   ${XFCE46_BASE} \
271   ${XFCE46_EXTRAS} \
272   ${XFCE_THEMES} \
273   \
274   rxvt-unicode \
275 #  xst \
276 #  suspend-desktop \
277 #  teleport \
278   gdk-pixbuf-loader-png \
279   gdk-pixbuf-loader-xpm \
280   gdk-pixbuf-loader-jpeg \
281   pango-module-basic-x \
282   pango-module-basic-fc \
283   xcursor-transparent-theme \   
284   xterm \
285   jaaa nmap iperf \
286 #  gnuplot \
287 "