Merge branch 'master' of git://git.openpandora.org/openpandora.oe
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r22"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16 #  firefox \
17   gnumeric \   
18 #  gimp \
19   networkmanager network-manager-applet \ 
20 #  synergy \
21   vnc x11vnc angstrom-x11vnc-xinit \
22   xchat \
23 #  xournal \
24   arora \
25 "
26
27 BLUETOOTH_GUI = " \
28   blueman \
29   gnome-bluetooth \
30 "
31
32 IM_CLIENT = " \
33   pidgin \
34   libpurple-protocol-msn \
35   libpurple-protocol-yahoo \
36   libpurple-protocol-icq \
37   libpurple-protocol-aim \
38 "
39
40 DISPMAN = " \
41   slim \
42   slim-op-themes \
43 "
44
45 FONTS = " \
46   font-adobe-75dpi \
47   fontconfig fontconfig-utils font-util \
48   ttf-arphic-uming \
49   ttf-dejavu-common \
50   ttf-dejavu-sans \
51   ttf-dejavu-serif \
52   ttf-dejavu-sans-mono \
53   ttf-liberation-sans \
54   ttf-liberation-serif \
55   ttf-liberation-mono \
56   xorg-minimal-fonts \
57 "  
58
59 # Any default games we want to ship.
60 GAMES = " \
61 #  scummvm \
62 #  frozen-bubble \
63 #  gnome-games \  
64   numptyphysics \
65 "
66
67 GNOME_APPS = " \
68   gnome-mplayer \
69 #  gcalctool \ 
70   gnome-keyring gnome-keyring-pam-plugin \
71   gksu \
72 "
73
74 GNOME_GTK = " \
75 #  gnome-icon-theme \
76 #  angstrom-gnome-icon-theme-enable \
77 "
78
79 GSTREAMER = " \
80 #  gstreamer-ti \
81   gst-ffmpeg \
82   gst-omapfb \
83 #  gst-plugin-pulse \
84   gst-plugin-xvimagesink \
85   gst-plugins-base-meta \
86   gst-plugins-good-meta \
87   gst-plugins-bad-meta \
88 #  gst-plugins-ugly-meta \
89   gst-plugin-gles \
90 "
91
92 ICON_THEME = " \
93   hicolor-icon-theme \
94   elementary-icon-theme \
95   elementary-icon-theme-enable \
96 "
97
98 LAUNCHERS = " \
99 #  netbook-launcher-efl \
100   pandora-libpnd-minimenu \
101   pandora-pmenu \
102 "
103
104 PANDORA = " \
105   pandora-first-run-wizard hsetroot \
106   pandora-scripts \
107   pandora-lcd-state \
108   pandora-wallpaper-official pandora-wallpaper-community \
109   pandora-xfce-defaults \
110   pandora-xmms-defaults xmms \
111 #  pandora-midori-defaults midori \
112   libgles2d \
113 "
114
115 PERL = " \
116   perl \
117   task-perl-module-all \
118   libnet-dbus-perl \
119   libxml-parser-perl \
120   libxml-twig-perl \
121 "
122
123 PULSEAUDIO = " \
124 #  pulseaudio-alsa-wrapper \
125 #  pulseaudio-esd-wrapper \
126 #  pulseaudio-module-gconf \
127 #  libasound-module-ctl-pulse \
128 #  libasound-module-pcm-pulse \
129 "
130
131 QT_SELECTED = " qt4-x11-free \
132 "
133 # qt4-x11-free"
134 # qt4-x11-free-gles"
135
136 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
137
138 QT_SUPPORT = " \
139   ${QT_SELECTED} \
140   qt4-plugin-imageformat-jpeg \
141   qt4-plugin-imageformat-gif \
142 "
143
144 # We want all of the Qt metapackage (for dev use) without the demos/examples.
145 BAD_RRECOMMENDS += " \
146   ${QT_SELECTED}-demos \
147   ${QT_SELECTED}-examples \
148 "
149
150 TOTEM = " \
151   totem \
152   totem-browser-plugin \
153   totem-plugin-bemused \
154   totem-plugin-gromit \
155   totem-plugin-media-player-keys \
156   totem-plugin-ontop \
157   totem-plugin-properties \
158   totem-plugin-screensaver \
159   totem-plugin-skipto \
160   totem-plugin-thumbnail \
161 "
162
163 TOUCHSCREEN = " \
164   gtk-touchscreen-mode-enable \
165   libgtkstylus \
166   xinput-calibrator \
167 "
168
169 XFCE46_BASE = " \
170   xfce4-dev-tools \
171   xfwm4 \
172   xfwm4-theme-default \
173   xfce-utils \  
174   xfce4-session \     
175   xfconf \
176   xfdesktop \
177   xfce4-panel \
178   xfce4-power-manager \
179   \
180   gtk-xfce-engine \
181   \
182   xfce4-panel-plugin-actions \
183   xfce4-panel-plugin-clock \
184   xfce4-panel-plugin-iconbox \
185   xfce4-panel-plugin-launcher \
186   xfce4-panel-plugin-pager \
187   xfce4-panel-plugin-separator \
188   xfce4-panel-plugin-showdesktop \
189   xfce4-panel-plugin-systray \
190   xfce4-panel-plugin-tasklist \
191   xfce4-panel-plugin-windowlist \   
192   xfce4-settings \
193   xfce-terminal \
194   thunar \
195 "
196
197 XFCE46_EXTRAS = " \
198   xfce4-notifyd \
199   xfce4-mixer \
200   xfce4-appfinder \
201   xfce4-battery-plugin \
202   xfprint \    
203   orage \
204   squeeze \
205   ristretto \
206   mousepad \ 
207   gigolo \
208 "
209
210 XFCE_THEMES = " \
211   xfwm4-theme-daloa \
212   xfwm4-theme-moheli \
213 #  xfwm4-theme-default-4.0 \
214 #  xfwm4-theme-default-4.2 \
215 #  xfwm4-theme-default-4.4 \
216   xfwm4-theme-kokodi \
217   xfwm4-theme-sassandra \
218 #  xfwm4-theme-stoneage \
219 #  xfwm4-theme-therapy \
220 #  xfwm4-theme-tyrex \
221 #  xfwm4-theme-wallis \  
222   xfwm4-themes \
223 "
224
225 XSERVER_BASE = " \
226   ${XSERVER} \
227   dbus-x11 \
228   desktop-file-utils \
229   iso-codes \
230   mime-support \
231   notification-daemon inotify-tools \
232   xauth \
233   xdg-utils \
234   xhost \
235   xinetd \
236   xinit \
237   xlsfonts \
238   xrdb \
239   xrefresh \
240   xset \
241   xvinfo \
242   devilspie \
243   encodings \
244   xterm \
245   xmodmap \
246 "
247
248 RDEPENDS_${PN} = " \
249   task-pandora-core \
250   angstrom-x11-base-depends \
251   ${ANGSTROM_EXTRA_INSTALL} \
252   ${APPS} \
253   ${BLUETOOTH_GUI} \
254   ${IM_CLIENT} \
255   ${DISPMAN} \
256   ${FONTS} \
257   ${GAMES} \  
258   ${GNOME_GTK} \
259   ${GNOME_APPS} \
260   ${GSTREAMER} \
261   ${ICON_THEME} \
262   ${LAUNCHERS} \
263   ${PANDORA} \
264   ${PERL} \
265   ${PULSEAUDIO} \
266   ${QT_SUPPORT} \
267   ${TOTEM} \
268   ${TOUCHSCREEN} \
269   ${XSERVER_BASE} \
270   ${XFCE46_BASE} \
271   ${XFCE46_EXTRAS} \
272   ${XFCE_THEMES} \
273   \
274   rxvt-unicode \
275 #  xst \
276 #  suspend-desktop \
277 #  teleport \
278   gdk-pixbuf-loader-png \
279   gdk-pixbuf-loader-xpm \
280   gdk-pixbuf-loader-jpeg \
281   pango-module-basic-x \
282   pango-module-basic-fc \
283   xcursor-transparent-theme \   
284   xterm xmms \
285   jaaa nmap iperf \
286 #  gnuplot \
287 "