a8b9815452792f96f54518e45419a694f01182a6
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r28"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13   abiword \
14   claws-mail \
15   swfdec swfdec-gnome swfdec-mozilla \
16 #  firefox \
17   gnumeric \   
18 #  gimp \
19   networkmanager network-manager-applet \ 
20 #  synergy \
21   vnc x11vnc angstrom-x11vnc-xinit \
22   xchat \
23 #  xournal \
24   arora \
25 "
26
27 BLUETOOTH_GUI = " \
28   gnome-bluetooth \
29 "
30
31 IM_CLIENT = " \
32   pidgin \
33   libpurple-protocol-msn \
34   libpurple-protocol-yahoo \
35   libpurple-protocol-icq \
36   libpurple-protocol-aim \
37 "
38
39 DISPMAN = " \
40   slim \
41   slim-op-themes \
42 "
43
44 FONTS = " \
45   font-adobe-75dpi \
46   fontconfig fontconfig-utils font-util \
47   ttf-arphic-uming \
48   ttf-dejavu-common \
49   ttf-dejavu-sans \
50   ttf-dejavu-serif \
51   ttf-dejavu-sans-mono \
52   ttf-liberation-sans \
53   ttf-liberation-serif \
54   ttf-liberation-mono \
55   xorg-minimal-fonts \
56 "  
57
58 # Any default games we want to ship.
59 GAMES = " \
60 #  scummvm \
61 #  frozen-bubble \
62 #  gnome-games \  
63 #  numptyphysics \
64 "
65
66 GNOME_APPS = " \
67 #  gnome-mplayer \
68 #  gcalctool \ 
69   gnome-keyring gnome-keyring-pam-plugin \
70   gksu \
71 "
72
73 GNOME_GTK = " \
74 #  gnome-icon-theme \
75 #  angstrom-gnome-icon-theme-enable \
76 "
77
78 GSTREAMER = " \
79 #  gstreamer-ti \
80 #  gst-ffmpeg \
81   gst-omapfb \
82 #  gst-plugin-pulse \
83   gst-plugin-xvimagesink \
84 #  gst-plugins-base-meta \
85 #  gst-plugins-good-meta \
86 #  gst-plugins-bad-meta \
87 #  gst-plugins-ugly-meta \
88   gst-plugin-gles \
89 "
90
91 ICON_THEME = " \
92   hicolor-icon-theme \
93   elementary-icon-theme \
94   elementary-icon-theme-enable \
95 "
96
97 LAUNCHERS = " \
98 #  netbook-launcher-efl \
99   pandora-libpnd-minimenu \
100   pandora-pmenu \
101 "
102
103 PANDORA = " \
104   pandora-first-run-wizard hsetroot \
105   pandora-scripts \
106   pandora-wallpaper-official pandora-wallpaper-community \
107   pandora-xfce-defaults \
108   pandora-midori-defaults midori \
109   libgles2d \
110   pandora-misc \
111 "
112
113 PERL = " \
114   perl \
115   task-perl-module-all \
116   libnet-dbus-perl \
117   libxml-parser-perl \
118   libxml-twig-perl \
119 "
120
121 PULSEAUDIO = " \
122 #  pulseaudio-alsa-wrapper \
123 #  pulseaudio-esd-wrapper \
124 #  pulseaudio-module-gconf \
125 #  libasound-module-ctl-pulse \
126 #  libasound-module-pcm-pulse \
127 "
128
129 QT_SELECTED = " qt4-x11-free \
130 "
131 # qt4-x11-free"
132 # qt4-x11-free-gles"
133
134 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
135
136 QT_SUPPORT = " \
137   ${QT_SELECTED} \
138   qt4-plugin-imageformat-jpeg \
139   qt4-plugin-imageformat-gif \
140 "
141
142 # We want all of the Qt metapackage (for dev use) without the demos/examples.
143 BAD_RRECOMMENDS += " \
144   ${QT_SELECTED}-demos \
145   ${QT_SELECTED}-examples \
146 "
147
148 TOTEM = " \
149 #  totem \
150 #  totem-browser-plugin \
151 #  totem-plugin-bemused \
152 #  totem-plugin-gromit \
153 #  totem-plugin-media-player-keys \
154 #  totem-plugin-ontop \
155 #  totem-plugin-properties \
156 #  totem-plugin-screensaver \
157 #  totem-plugin-skipto \
158 #  totem-plugin-thumbnail \
159 "
160
161 TOUCHSCREEN = " \
162   gtk-touchscreen-mode-enable \
163   libgtkstylus \
164 #  xinput-calibrator \
165 "
166
167 XFCE46_BASE = " \
168   xfce4-dev-tools \
169   xfwm4 \
170   xfwm4-theme-default \
171   xfce-utils \  
172   xfce4-session \     
173   xfconf \
174   xfdesktop \
175   xfce4-panel \
176   xfce4-power-manager \
177   \
178   gtk-xfce-engine \
179   \
180   xfce4-panel-plugin-actions \
181   xfce4-panel-plugin-clock \
182   xfce4-panel-plugin-iconbox \
183   xfce4-panel-plugin-launcher \
184   xfce4-panel-plugin-pager \
185   xfce4-panel-plugin-separator \
186   xfce4-panel-plugin-showdesktop \
187   xfce4-panel-plugin-systray \
188   xfce4-panel-plugin-tasklist \
189   xfce4-panel-plugin-windowlist \   
190   xfce4-settings \
191   xfce-terminal \
192   thunar \
193 "
194
195 XFCE46_EXTRAS = " \
196   xfce4-notifyd \
197   xfce4-mixer \
198   xfce4-appfinder \
199   xfce4-battery-plugin \
200   xfprint \    
201   orage \
202   squeeze \
203   ristretto \
204   mousepad \ 
205   gigolo \
206 "
207
208 XFCE_THEMES = " \
209   xfwm4-theme-daloa \
210   xfwm4-theme-moheli \
211   xfwm4-theme-kokodi \
212   xfwm4-theme-sassandra \
213   xfwm4-themes \
214 "
215
216 XSERVER_BASE = " \
217   ${XSERVER} \
218   dbus-x11 \
219   desktop-file-utils \
220   iso-codes \
221   mime-support \
222   notification-daemon inotify-tools \
223   xauth \
224   xdg-utils \
225   xhost \
226   xinetd \
227   xinit \
228   xlsfonts \
229   xrdb \
230   xrefresh \
231   xset \
232   xvinfo \
233   devilspie \
234   encodings \
235   xterm \
236   xmodmap \
237 "
238
239 RDEPENDS_${PN} = " \
240   task-pandora-core \
241   angstrom-x11-base-depends \
242   ${ANGSTROM_EXTRA_INSTALL} \
243   ${APPS} \
244   ${BLUETOOTH_GUI} \
245   ${IM_CLIENT} \
246   ${DISPMAN} \
247   ${FONTS} \
248   ${GAMES} \  
249   ${GNOME_GTK} \
250   ${GNOME_APPS} \
251   ${GSTREAMER} \
252   ${ICON_THEME} \
253   ${LAUNCHERS} \
254   ${PANDORA} \
255   ${PERL} \
256   ${PULSEAUDIO} \
257   ${QT_SUPPORT} \
258   ${TOTEM} \
259   ${TOUCHSCREEN} \
260   ${XSERVER_BASE} \
261   ${XFCE46_BASE} \
262   ${XFCE46_EXTRAS} \
263   ${XFCE_THEMES} \
264   \
265   rxvt-unicode \
266 #  xst \
267 #  suspend-desktop \
268 #  teleport \
269   gdk-pixbuf-loader-png \
270   gdk-pixbuf-loader-xpm \
271   gdk-pixbuf-loader-jpeg \
272   pango-module-basic-x \
273   pango-module-basic-fc \
274   xcursor-transparent-theme \   
275   xterm \
276   jaaa nmap iperf \
277 #  gnuplot \
278 "