task-pandora-xfce: Removed libphonon4 (stopped the image from building)
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r55"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   xchat \
21   links-x11 \
22   enchant \
23   aspell \
24   xwininfo \
25 #  xournal \
26 #  arora \
27 "
28
29 BLUETOOTH_GUI = " \
30   gnome-bluetooth \
31 "
32
33 IM_CLIENT = " \
34 #  pidgin \
35 #  libpurple-protocol-msn \
36 #  libpurple-protocol-yahoo \
37 #  libpurple-protocol-icq \
38 #  libpurple-protocol-aim \
39 "
40
41 DISPMAN = " \
42   slim \
43   slim-op-themes \
44 "
45
46 FONTS = " \
47   font-adobe-75dpi \
48   fontconfig fontconfig-utils font-util \
49   ttf-arphic-uming \
50   ttf-dejavu-common \
51   ttf-dejavu-sans \
52   ttf-dejavu-serif \
53   ttf-dejavu-sans-mono \
54   ttf-liberation-sans \
55   ttf-liberation-serif \
56   ttf-liberation-mono \
57   xorg-minimal-fonts \
58 "  
59
60 # Any default games we want to ship.
61 GAMES = " \
62 #  scummvm \
63 #  frozen-bubble \
64 #  gnome-games \  
65 #  numptyphysics \
66 "
67
68 GNOME_APPS = " \
69 #  gnome-mplayer \
70   gcalctool \ 
71   gnome-keyring gnome-keyring-pam-plugin \
72   gksu \
73 "
74
75 GSTREAMER = " \
76 #  gstreamer-ti \
77   gst-ffmpeg \
78   gst-omapfb \
79 #  gst-plugin-pulse \
80   gst-plugin-xvimagesink \
81   gst-plugins-base-meta \
82 #  gst-plugins-good-meta \
83 #  gst-plugins-bad-meta \
84 #  gst-plugins-ugly-meta \
85   gst-plugin-gles \
86 "
87
88 ICON_THEME = " \
89   hicolor-icon-theme \
90   elementary-icon-theme \
91   elementary-icon-theme-enable \
92 "
93
94 LAUNCHERS = " \
95 #  netbook-launcher-efl \
96   pandora-libpnd-minimenu \
97 #  pandora-pmenu \
98 "
99
100 PANDORA = " \
101   pandora-first-run-wizard hsetroot \
102   pandora-scripts \
103   pandora-wallpaper-official \
104   pandora-xfce-defaults \
105 #  pandora-midori-defaults midori \
106   libgles2d \
107   pandora-misc \
108   pandora-pndstore \
109 "
110
111 PERL = " \
112   perl \
113   task-perl-module-all \
114   libnet-dbus-perl \
115   libxml-parser-perl \
116   libxml-twig-perl \
117 "
118
119 PULSEAUDIO = " \
120 #  pulseaudio-alsa-wrapper \
121 #  pulseaudio-esd-wrapper \
122 #  pulseaudio-module-gconf \
123 #  libasound-module-ctl-pulse \
124 #  libasound-module-pcm-pulse \
125 "
126
127 PYTHON_LIBS = " \
128   python-shell \
129   python-pygtk \
130   python-pycairo \
131   gnome-vfs-plugin-http \
132   gnome-vfs-plugin-ftp \
133 "
134
135 QT_SUPPORT = " \
136  libqt3support4 \ 
137  libqtassistantclient4 \ 
138  libqtclucene4 \ 
139  libqtcore4 \ 
140  libqtdbus4 \ 
141  libqtdesigner4 \ 
142  libqtdesignercomponents4 \ 
143  libqtgui4 \ 
144  libqthelp4 \ 
145  libqtnetwork4 \  
146  libqtscript4 \ 
147  libqtscripttools4 \ 
148  libqtsql4 \ 
149  libqtsvg4 \ 
150  libqttest4 \ 
151  libqtuitools4 \ 
152  libqtwebkit4 \ 
153  libqtxml4 \  
154  qt4-tools \ 
155  qt4-assistant \ 
156  qt4-common \ 
157  qt4-dbus \ 
158  qt4-designer \ 
159  qt4-fonts \ 
160  qt4-linguist \ 
161  qt4-mkspecs \ 
162  qt4-pixeltool \ 
163  qt4-qt3to4 \
164  qt4-plugin-imageformat-jpeg \
165  qt4-plugin-imageformat-gif \
166 "
167
168
169 TOTEM = " \
170 #  totem \
171 #  totem-browser-plugin \
172 #  totem-plugin-bemused \
173 #  totem-plugin-gromit \
174 #  totem-plugin-media-player-keys \
175 #  totem-plugin-ontop \
176 #  totem-plugin-properties \
177 #  totem-plugin-screensaver \
178 #  totem-plugin-skipto \
179 #  totem-plugin-thumbnail \
180 "
181
182 TOUCHSCREEN = " \
183   gtk-touchscreen-mode-enable \
184   libgtkstylus \
185 #  xinput-calibrator \
186 "
187
188 XFCE46_BASE = " \
189   xfce4-dev-tools \
190   xfwm4 \
191   xfwm4-theme-default \
192   xfce-utils \  
193   xfce4-session \     
194   xfconf \
195   xfdesktop \
196   xfce4-panel \
197   xfce4-power-manager \
198   \
199   gtk-xfce-engine \
200   \
201   xfce4-panel-plugin-actions \
202   xfce4-panel-plugin-clock \
203   xfce4-panel-plugin-iconbox \
204   xfce4-panel-plugin-launcher \
205   xfce4-panel-plugin-pager \
206   xfce4-panel-plugin-separator \
207   xfce4-panel-plugin-showdesktop \
208   xfce4-panel-plugin-systray \
209   xfce4-panel-plugin-tasklist \
210   xfce4-panel-plugin-windowlist \   
211   xfce4-settings \
212   xfce-terminal \
213   thunar \
214 "
215
216 XFCE46_EXTRAS = " \
217   xfce4-notifyd \
218   xfce4-mixer \
219   xfce4-appfinder \
220   xfce4-battery-plugin \
221   xfprint \    
222   orage \
223   squeeze \
224   ristretto \
225   mousepad \ 
226   gigolo \
227   xdotool \
228 "
229
230 XFCE_THEMES = " \
231   xfwm4-theme-daloa \
232   xfwm4-theme-moheli \
233   xfwm4-theme-kokodi \
234   xfwm4-theme-sassandra \
235   xfwm4-themes \
236 "
237
238 XSERVER_BASE = " \
239   ${XSERVER} \
240   dbus-x11 \
241   desktop-file-utils \
242   iso-codes \
243   mime-support \
244   notification-daemon inotify-tools \
245   xauth \
246   xdg-utils \
247   xhost \
248   xinetd \
249   xinit \
250   xlsfonts \
251   xrdb \
252   xrefresh \
253   xset \
254   xvinfo \
255   devilspie \
256   encodings \
257   xterm \
258   xmodmap \
259 "
260
261 ADD_LIBS = " \
262   libbonobo \
263   libetpan \
264   libfribidi \
265   libgsf \
266   libidn \
267   libxslt \
268   wv \
269   libsamplerate0 \
270   glibc-gconv-cp1252 \
271   glibc-gconv-ibm850 \
272   glibc-gconv-iso8859-15 \
273   
274
275
276 RDEPENDS_${PN} = " \
277   task-pandora-core \
278   angstrom-x11-base-depends \
279   ${ANGSTROM_EXTRA_INSTALL} \
280   ${APPS} \
281   ${BLUETOOTH_GUI} \
282   ${IM_CLIENT} \
283   ${DISPMAN} \
284   ${FONTS} \
285   ${GAMES} \  
286   ${GNOME_APPS} \
287   ${GSTREAMER} \
288   ${ICON_THEME} \
289   ${LAUNCHERS} \
290   ${PANDORA} \
291   ${PERL} \
292   ${PULSEAUDIO} \
293   ${PYTHON_LIBS} \
294   ${QT_SUPPORT} \
295   ${TOTEM} \
296   ${TOUCHSCREEN} \
297   ${XSERVER_BASE} \
298   ${XFCE46_BASE} \
299   ${XFCE46_EXTRAS} \
300   ${XFCE_THEMES} \
301   ${ADD_LIBS} \
302   \
303   rxvt-unicode \
304 #  xst \
305 #  suspend-desktop \
306 #  teleport \
307   gdk-pixbuf-loader-png \
308   gdk-pixbuf-loader-xpm \
309   gdk-pixbuf-loader-jpeg \
310   pango-module-basic-x \
311   pango-module-basic-fc \
312   xcursor-transparent-theme \   
313   xterm \
314   jaaa nmap iperf \
315 #  gnuplot \
316 "