task-pandora-xfce: Added links2
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r50"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet netm-cli \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   xchat \
21   links \
22 #  xournal \
23 #  arora \
24 "
25
26 BLUETOOTH_GUI = " \
27   gnome-bluetooth \
28 "
29
30 IM_CLIENT = " \
31 #  pidgin \
32 #  libpurple-protocol-msn \
33 #  libpurple-protocol-yahoo \
34 #  libpurple-protocol-icq \
35 #  libpurple-protocol-aim \
36 "
37
38 DISPMAN = " \
39   slim \
40   slim-op-themes \
41 "
42
43 FONTS = " \
44   font-adobe-75dpi \
45   fontconfig fontconfig-utils font-util \
46   ttf-arphic-uming \
47   ttf-dejavu-common \
48   ttf-dejavu-sans \
49   ttf-dejavu-serif \
50   ttf-dejavu-sans-mono \
51   ttf-liberation-sans \
52   ttf-liberation-serif \
53   ttf-liberation-mono \
54   xorg-minimal-fonts \
55 "  
56
57 # Any default games we want to ship.
58 GAMES = " \
59 #  scummvm \
60 #  frozen-bubble \
61 #  gnome-games \  
62 #  numptyphysics \
63 "
64
65 GNOME_APPS = " \
66 #  gnome-mplayer \
67   gcalctool \ 
68   gnome-keyring gnome-keyring-pam-plugin \
69   gksu \
70 "
71
72 GSTREAMER = " \
73 #  gstreamer-ti \
74   gst-ffmpeg \
75   gst-omapfb \
76 #  gst-plugin-pulse \
77   gst-plugin-xvimagesink \
78   gst-plugins-base-meta \
79 #  gst-plugins-good-meta \
80 #  gst-plugins-bad-meta \
81 #  gst-plugins-ugly-meta \
82   gst-plugin-gles \
83 "
84
85 ICON_THEME = " \
86   hicolor-icon-theme \
87   elementary-icon-theme \
88   elementary-icon-theme-enable \
89 "
90
91 LAUNCHERS = " \
92 #  netbook-launcher-efl \
93   pandora-libpnd-minimenu \
94 #  pandora-pmenu \
95 "
96
97 PANDORA = " \
98   pandora-first-run-wizard hsetroot \
99   pandora-scripts \
100   pandora-wallpaper-official \
101   pandora-xfce-defaults \
102   pandora-midori-defaults midori \
103   libgles2d \
104   pandora-misc \
105 "
106
107 PERL = " \
108   perl \
109   task-perl-module-all \
110   libnet-dbus-perl \
111   libxml-parser-perl \
112   libxml-twig-perl \
113 "
114
115 PULSEAUDIO = " \
116 #  pulseaudio-alsa-wrapper \
117 #  pulseaudio-esd-wrapper \
118 #  pulseaudio-module-gconf \
119 #  libasound-module-ctl-pulse \
120 #  libasound-module-pcm-pulse \
121 "
122
123 PYTHON_LIBS = " \
124   python-shell \
125   python-pygtk \
126   python-pycairo \
127   gnome-vfs-plugin-http \
128   gnome-vfs-plugin-ftp \
129 "
130
131 QT_SELECTED = " qt4-x11-free \
132 "
133 # qt4-x11-free"
134 # qt4-x11-free-gles"
135
136 #PREFERRED_PROVIDER_qt4-x11-free = "${QT_SELECTED}"
137
138 QT_SUPPORT = " \
139   ${QT_SELECTED} \
140   qt4-plugin-imageformat-jpeg \
141   qt4-plugin-imageformat-gif \
142 "
143
144 # We want all of the Qt metapackage (for dev use) without the demos/examples.
145 BAD_RECOMMENDATIONS += " \
146   qt4-demos \
147   qt4-examples \
148 "
149
150 TOTEM = " \
151 #  totem \
152 #  totem-browser-plugin \
153 #  totem-plugin-bemused \
154 #  totem-plugin-gromit \
155 #  totem-plugin-media-player-keys \
156 #  totem-plugin-ontop \
157 #  totem-plugin-properties \
158 #  totem-plugin-screensaver \
159 #  totem-plugin-skipto \
160 #  totem-plugin-thumbnail \
161 "
162
163 TOUCHSCREEN = " \
164   gtk-touchscreen-mode-enable \
165   libgtkstylus \
166 #  xinput-calibrator \
167 "
168
169 XFCE46_BASE = " \
170   xfce4-dev-tools \
171   xfwm4 \
172   xfwm4-theme-default \
173   xfce-utils \  
174   xfce4-session \     
175   xfconf \
176   xfdesktop \
177   xfce4-panel \
178   xfce4-power-manager \
179   \
180   gtk-xfce-engine \
181   \
182   xfce4-panel-plugin-actions \
183   xfce4-panel-plugin-clock \
184   xfce4-panel-plugin-iconbox \
185   xfce4-panel-plugin-launcher \
186   xfce4-panel-plugin-pager \
187   xfce4-panel-plugin-separator \
188   xfce4-panel-plugin-showdesktop \
189   xfce4-panel-plugin-systray \
190   xfce4-panel-plugin-tasklist \
191   xfce4-panel-plugin-windowlist \   
192   xfce4-settings \
193   xfce-terminal \
194   thunar \
195 "
196
197 XFCE46_EXTRAS = " \
198   xfce4-notifyd \
199   xfce4-mixer \
200   xfce4-appfinder \
201   xfce4-battery-plugin \
202   xfprint \    
203   orage \
204   squeeze \
205   ristretto \
206   mousepad \ 
207   gigolo \
208   xdotool \
209 "
210
211 XFCE_THEMES = " \
212   xfwm4-theme-daloa \
213   xfwm4-theme-moheli \
214   xfwm4-theme-kokodi \
215   xfwm4-theme-sassandra \
216   xfwm4-themes \
217 "
218
219 XSERVER_BASE = " \
220   ${XSERVER} \
221   dbus-x11 \
222   desktop-file-utils \
223   iso-codes \
224   mime-support \
225   notification-daemon inotify-tools \
226   xauth \
227   xdg-utils \
228   xhost \
229   xinetd \
230   xinit \
231   xlsfonts \
232   xrdb \
233   xrefresh \
234   xset \
235   xvinfo \
236   devilspie \
237   encodings \
238   xterm \
239   xmodmap \
240 "
241
242 ADD_LIBS = " \
243   libbonobo \
244   libetpan \
245   libfribidi \
246   libgsf \
247   libidn \
248   wv \
249   libsamplerate0 \
250   glibc-gconv-cp1252 \
251   glibc-gconv-ibm850 \
252   glibc-gconv-iso8859-15 \
253   
254
255
256 RDEPENDS_${PN} = " \
257   task-pandora-core \
258   angstrom-x11-base-depends \
259   ${ANGSTROM_EXTRA_INSTALL} \
260   ${APPS} \
261   ${BLUETOOTH_GUI} \
262   ${IM_CLIENT} \
263   ${DISPMAN} \
264   ${FONTS} \
265   ${GAMES} \  
266   ${GNOME_APPS} \
267   ${GSTREAMER} \
268   ${ICON_THEME} \
269   ${LAUNCHERS} \
270   ${PANDORA} \
271   ${PERL} \
272   ${PULSEAUDIO} \
273   ${PYTHON_LIBS} \
274   ${QT_SUPPORT} \
275   ${TOTEM} \
276   ${TOUCHSCREEN} \
277   ${XSERVER_BASE} \
278   ${XFCE46_BASE} \
279   ${XFCE46_EXTRAS} \
280   ${XFCE_THEMES} \
281   ${ADD_LIBS} \
282   \
283   rxvt-unicode \
284 #  xst \
285 #  suspend-desktop \
286 #  teleport \
287   gdk-pixbuf-loader-png \
288   gdk-pixbuf-loader-xpm \
289   gdk-pixbuf-loader-jpeg \
290   pango-module-basic-x \
291   pango-module-basic-fc \
292   xcursor-transparent-theme \   
293   xterm \
294   jaaa nmap iperf \
295 #  gnuplot \
296 "