task-pandora-xfce.bb: Added netkit-ftp
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r62"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   openvpn networkmanager-openvpn \
21   xchat \
22   links-x11 \
23   enchant \
24   aspell \
25   xwininfo \
26   curl \
27   dosfstools \
28   netkit-ftp \
29 #  xournal \
30 #  arora \
31 "
32
33 BLUETOOTH_GUI = " \
34   gnome-bluetooth \
35 "
36
37 IM_CLIENT = " \
38 #  pidgin \
39 #  libpurple-protocol-msn \
40 #  libpurple-protocol-yahoo \
41 #  libpurple-protocol-icq \
42 #  libpurple-protocol-aim \
43 "
44
45 DISPMAN = " \
46   slim \
47   slim-op-themes \
48 "
49
50 FONTS = " \
51   font-adobe-75dpi \
52   fontconfig fontconfig-utils font-util \
53   ttf-arphic-uming \
54   ttf-dejavu-common \
55   ttf-dejavu-sans \
56   ttf-dejavu-serif \
57   ttf-dejavu-sans-mono \
58   ttf-liberation-sans \
59   ttf-liberation-serif \
60   ttf-liberation-mono \
61   xorg-minimal-fonts \
62 "  
63
64 # Any default games we want to ship.
65 GAMES = " \
66 #  scummvm \
67 #  frozen-bubble \
68 #  gnome-games \  
69 #  numptyphysics \
70 "
71
72 GNOME_APPS = " \
73 #  gnome-mplayer \
74   gcalctool \ 
75   gnome-keyring gnome-keyring-pam-plugin \
76   gksu \
77 "
78
79 GSTREAMER = " \
80 #  gstreamer-ti \
81   gst-ffmpeg \
82   gst-omapfb \
83 #  gst-plugin-pulse \
84   gst-plugin-xvimagesink \
85   gst-plugins-base-meta \
86 #  gst-plugins-good-meta \
87 #  gst-plugins-bad-meta \
88 #  gst-plugins-ugly-meta \
89   gst-plugin-gles \
90 "
91
92 ICON_THEME = " \
93   hicolor-icon-theme \
94   elementary-icon-theme \
95   elementary-icon-theme-enable \
96 "
97
98 LAUNCHERS = " \
99 #  netbook-launcher-efl \
100   pandora-libpnd-minimenu \
101 #  pandora-pmenu \
102 "
103
104 PANDORA = " \
105   pandora-first-run-wizard hsetroot \
106   pandora-scripts \
107   pandora-wallpaper-official \
108   pandora-xfce-defaults \
109 #  pandora-midori-defaults midori \
110   libgles2d \
111   pandora-misc \
112   pandora-pndstore \
113 "
114
115 PERL = " \
116   perl \
117   task-perl-module-all \
118   libnet-dbus-perl \
119   libxml-parser-perl \
120   libxml-twig-perl \
121 "
122
123 PULSEAUDIO = " \
124 #  pulseaudio-alsa-wrapper \
125 #  pulseaudio-esd-wrapper \
126 #  pulseaudio-module-gconf \
127 #  libasound-module-ctl-pulse \
128 #  libasound-module-pcm-pulse \
129 "
130
131 PYTHON_LIBS = " \
132   python-shell \
133   python-pygtk \
134   python-pycairo \
135   gnome-vfs-plugin-http \
136   gnome-vfs-plugin-ftp \
137 "
138
139 QT_SUPPORT = " \
140  libqt3support4 \ 
141  libqtassistantclient4 \ 
142  libqtclucene4 \ 
143  libqtcore4 \ 
144  libqtdbus4 \ 
145  libqtdesigner4 \ 
146  libqtdesignercomponents4 \ 
147  libqtgui4 \ 
148  libqthelp4 \ 
149  libqtnetwork4 \  
150  libqtscript4 \ 
151  libqtscripttools4 \ 
152  libqtsql4 \ 
153  libqtsvg4 \ 
154  libqttest4 \ 
155  libqtwebkit4 \ 
156  libqtxml4 \  
157  qt4-tools \ 
158  qt4-assistant \ 
159  qt4-common \ 
160  qt4-dbus \ 
161  qt4-designer \ 
162  qt4-fonts \ 
163  qt4-linguist \ 
164  qt4-mkspecs \ 
165  qt4-pixeltool \ 
166  qt4-qt3to4 \
167  qt4-plugin-imageformat-jpeg \
168  qt4-plugin-imageformat-gif \
169 "
170
171
172 TOTEM = " \
173 #  totem \
174 #  totem-browser-plugin \
175 #  totem-plugin-bemused \
176 #  totem-plugin-gromit \
177 #  totem-plugin-media-player-keys \
178 #  totem-plugin-ontop \
179 #  totem-plugin-properties \
180 #  totem-plugin-screensaver \
181 #  totem-plugin-skipto \
182 #  totem-plugin-thumbnail \
183 "
184
185 TOUCHSCREEN = " \
186   gtk-touchscreen-mode-enable \
187   libgtkstylus \
188 #  xinput-calibrator \
189 "
190
191 XFCE46_BASE = " \
192   xfce4-dev-tools \
193   xfwm4 \
194   xfwm4-theme-default \
195   xfce-utils \  
196   xfce4-session \     
197   xfconf \
198   xfdesktop \
199   xfce4-panel \
200   xfce4-power-manager \
201   \
202   gtk-xfce-engine \
203   \
204   xfce4-panel-plugin-actions \
205   xfce4-panel-plugin-clock \
206   xfce4-panel-plugin-iconbox \
207   xfce4-panel-plugin-launcher \
208   xfce4-panel-plugin-pager \
209   xfce4-panel-plugin-separator \
210   xfce4-panel-plugin-showdesktop \
211   xfce4-panel-plugin-systray \
212   xfce4-panel-plugin-tasklist \
213   xfce4-panel-plugin-windowlist \   
214   xfce4-settings \
215   xfce-terminal \
216   thunar \
217 "
218
219 XFCE46_EXTRAS = " \
220   xfce4-notifyd \
221   xfce4-mixer \
222   xfce4-appfinder \
223   xfce4-battery-plugin \
224   xfprint \    
225   orage \
226   squeeze \
227   ristretto \
228   mousepad \ 
229   gigolo \
230   xdotool \
231 "
232
233 XFCE_THEMES = " \
234   xfwm4-theme-daloa \
235   xfwm4-theme-moheli \
236   xfwm4-theme-kokodi \
237   xfwm4-theme-sassandra \
238   xfwm4-themes \
239 "
240
241 XSERVER_BASE = " \
242   ${XSERVER} \
243   dbus-x11 \
244   desktop-file-utils \
245   iso-codes \
246   mime-support \
247   notification-daemon inotify-tools \
248   xauth \
249   xdg-utils \
250   xhost \
251   xinetd \
252   xinit \
253   xlsfonts \
254   xrdb \
255   xrefresh \
256   xset \
257   xvinfo \
258   devilspie \
259   encodings \
260   xterm \
261   xmodmap \
262 "
263
264 ADD_LIBS = " \
265   libbonobo \
266   libetpan \
267   libfribidi \
268   libgsf \
269   libidn \
270   libxslt \
271   wv \
272   libsamplerate0 \
273   glibc-gconv-cp1252 \
274   glibc-gconv-ibm850 \
275   glibc-gconv-iso8859-15 \
276   gvfsd-sftp \
277   sshfs-fuse \
278   rtl8712-module \
279   rtl8192u-module \
280
281
282 RDEPENDS_${PN} = " \
283   task-pandora-core \
284   angstrom-x11-base-depends \
285   ${ANGSTROM_EXTRA_INSTALL} \
286   ${APPS} \
287   ${BLUETOOTH_GUI} \
288   ${IM_CLIENT} \
289   ${DISPMAN} \
290   ${FONTS} \
291   ${GAMES} \  
292   ${GNOME_APPS} \
293   ${GSTREAMER} \
294   ${ICON_THEME} \
295   ${LAUNCHERS} \
296   ${PANDORA} \
297   ${PERL} \
298   ${PULSEAUDIO} \
299   ${PYTHON_LIBS} \
300   ${QT_SUPPORT} \
301   ${TOTEM} \
302   ${TOUCHSCREEN} \
303   ${XSERVER_BASE} \
304   ${XFCE46_BASE} \
305   ${XFCE46_EXTRAS} \
306   ${XFCE_THEMES} \
307   ${ADD_LIBS} \
308   \
309   rxvt-unicode \
310 #  xst \
311 #  suspend-desktop \
312 #  teleport \
313   gdk-pixbuf-loader-png \
314   gdk-pixbuf-loader-xpm \
315   gdk-pixbuf-loader-jpeg \
316   pango-module-basic-x \
317   pango-module-basic-fc \
318   xcursor-transparent-theme \   
319   xterm \
320   jaaa nmap iperf \
321 #  gnuplot \
322 "