task-pandora-xfce-jap.bb: Fixed configtray-recipe
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r72"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   openvpn networkmanager-openvpn \
21   modemmanager \
22   xchat \
23   links-x11 \
24   enchant \
25   aspell \
26   xwininfo \
27   curl \
28   dosfstools \
29   netkit-ftp \
30 #  xournal \
31 #  arora \
32 "
33
34 BLUETOOTH_GUI = " \
35   gnome-bluetooth \
36 "
37
38 IM_CLIENT = " \
39 #  pidgin \
40 #  libpurple-protocol-msn \
41 #  libpurple-protocol-yahoo \
42 #  libpurple-protocol-icq \
43 #  libpurple-protocol-aim \
44 "
45
46 DISPMAN = " \
47   slim \
48   slim-op-themes \
49 "
50
51 FONTS = " \
52   font-adobe-75dpi \
53   fontconfig fontconfig-utils font-util \
54   ttf-arphic-uming \
55   ttf-dejavu-common \
56   ttf-dejavu-sans \
57   ttf-dejavu-serif \
58   ttf-dejavu-sans-mono \
59   ttf-liberation-sans \
60   ttf-liberation-serif \
61   ttf-liberation-mono \
62   xorg-minimal-fonts \
63 "  
64
65 # Any default games we want to ship.
66 GAMES = " \
67 #  scummvm \
68 #  frozen-bubble \
69 #  gnome-games \  
70 #  numptyphysics \
71 "
72
73 GNOME_APPS = " \
74 #  gnome-mplayer \
75   gcalctool \ 
76   gnome-keyring gnome-keyring-pam-plugin \
77   gksu \
78 "
79
80 GSTREAMER = " \
81 #  gstreamer-ti \
82   gst-ffmpeg \
83   gst-omapfb \
84 #  gst-plugin-pulse \
85   gst-plugin-xvimagesink \
86   gst-plugins-base-meta \
87 #  gst-plugins-good-meta \
88 #  gst-plugins-bad-meta \
89 #  gst-plugins-ugly-meta \
90   gst-plugin-gles \
91 "
92
93 ICON_THEME = " \
94   hicolor-icon-theme \
95   elementary-icon-theme \
96   elementary-icon-theme-enable \
97 "
98
99 LAUNCHERS = " \
100 #  netbook-launcher-efl \
101   pandora-libpnd-minimenu \
102 #  pandora-pmenu \
103 "
104
105 PANDORA = " \
106   pandora-first-run-wizard hsetroot \
107   pandora-scripts \
108   pandora-scripts-wifi \
109   pandora-wallpaper-official \
110   pandora-xfce-defaults \
111 #  pandora-midori-defaults midori \
112   libgles2d \
113   pandora-misc \
114   pandora-pndstore \
115   pandora-configtray \
116   pandora-configtray-wifi \
117 "
118
119 PERL = " \
120   perl \
121   task-perl-module-all \
122   libnet-dbus-perl \
123   libxml-parser-perl \
124   libxml-twig-perl \
125 "
126
127 PULSEAUDIO = " \
128 #  pulseaudio-alsa-wrapper \
129 #  pulseaudio-esd-wrapper \
130 #  pulseaudio-module-gconf \
131 #  libasound-module-ctl-pulse \
132 #  libasound-module-pcm-pulse \
133 "
134
135 PYTHON_LIBS = " \
136   python-shell \
137   python-pygtk \
138   python-pycairo \
139   gnome-vfs-plugin-http \
140   gnome-vfs-plugin-ftp \
141 "
142
143 QT_SUPPORT = " \
144  libqt3support4 \ 
145  libqtassistantclient4 \ 
146  libqtclucene4 \ 
147  libqtcore4 \ 
148  libqtdbus4 \ 
149  libqtdesigner4 \ 
150  libqtdesignercomponents4 \ 
151  libqtgui4 \ 
152  libqthelp4 \ 
153  libqtnetwork4 \  
154  libqtscript4 \ 
155  libqtscripttools4 \ 
156  libqtsql4 \ 
157  libqtsvg4 \ 
158  libqttest4 \ 
159  libqtwebkit4 \ 
160  libqtxml4 \  
161  qt4-tools \ 
162  qt4-assistant \ 
163  qt4-common \ 
164  qt4-dbus \ 
165  qt4-designer \ 
166  qt4-fonts \ 
167  qt4-linguist \ 
168  qt4-mkspecs \ 
169  qt4-pixeltool \ 
170  qt4-qt3to4 \
171  qt4-plugin-imageformat-jpeg \
172  qt4-plugin-imageformat-gif \
173 "
174
175
176 TOTEM = " \
177 #  totem \
178 #  totem-browser-plugin \
179 #  totem-plugin-bemused \
180 #  totem-plugin-gromit \
181 #  totem-plugin-media-player-keys \
182 #  totem-plugin-ontop \
183 #  totem-plugin-properties \
184 #  totem-plugin-screensaver \
185 #  totem-plugin-skipto \
186 #  totem-plugin-thumbnail \
187 "
188
189 TOUCHSCREEN = " \
190 #  gtk-touchscreen-mode-enable \
191   libgtkstylus \
192 #  xinput-calibrator \
193 "
194
195 XFCE46_BASE = " \
196   xfce4-dev-tools \
197   xfwm4 \
198   xfwm4-theme-default \
199   xfce-utils \  
200   xfce4-session \     
201   xfconf \
202   xfdesktop \
203   xfce4-panel \
204   xfce4-power-manager \
205   \
206   gtk-xfce-engine \
207   \
208   xfce4-panel-plugin-actions \
209   xfce4-panel-plugin-clock \
210   xfce4-panel-plugin-iconbox \
211   xfce4-panel-plugin-launcher \
212   xfce4-panel-plugin-pager \
213   xfce4-panel-plugin-separator \
214   xfce4-panel-plugin-showdesktop \
215   xfce4-panel-plugin-systray \
216   xfce4-panel-plugin-tasklist \
217   xfce4-panel-plugin-windowlist \   
218   xfce4-settings \
219   xfce-terminal \
220   thunar \
221 "
222
223 XFCE46_EXTRAS = " \
224   xfce4-notifyd \
225   xfce4-mixer \
226   xfce4-appfinder \
227   xfce4-battery-plugin \
228   xfprint \    
229   orage \
230   squeeze \
231   ristretto \
232   mousepad \ 
233   gigolo \
234   xdotool \
235 "
236
237 XFCE_THEMES = " \
238   xfwm4-theme-daloa \
239   xfwm4-theme-moheli \
240   xfwm4-theme-kokodi \
241   xfwm4-theme-sassandra \
242   xfwm4-themes \
243 "
244
245 XSERVER_BASE = " \
246   ${XSERVER} \
247   dbus-x11 \
248   desktop-file-utils \
249   iso-codes \
250   mime-support \
251   notification-daemon inotify-tools \
252   xauth \
253   xdg-utils \
254   xhost \
255   xinetd \
256   xinit \
257   xlsfonts \
258   xrdb \
259   xrefresh \
260   xset \
261   xvinfo \
262   devilspie \
263   encodings \
264   xterm \
265   xmodmap \
266 "
267
268 ADD_LIBS = " \
269   libbonobo \
270   libetpan \
271   libfribidi \
272   libgsf \
273   libidn \
274   libxslt \
275   wv \
276   libsamplerate0 \
277   glibc-gconv-cp1252 \
278   glibc-gconv-ibm850 \
279   glibc-gconv-iso8859-15 \
280   glibc-gconv-cp1250 \
281   glibc-gconv-koi8-r \
282   glibc-gconv-unicode \
283   glibc-gconv-utf-16 \
284   gvfsd-sftp \
285   sshfs-fuse \
286   directfb \
287   rtl8712-module \
288   rtl8192u-module \
289
290
291 DSP = " \
292   ti-dsplink-module \
293   ti-cmem-module \
294   ti-lpm-module \
295   ti-sdma-module \
296   ti-codecs-omap3530-server \
297 "
298
299 RDEPENDS_${PN} = " \
300   task-pandora-core \
301   angstrom-x11-base-depends \
302   ${ANGSTROM_EXTRA_INSTALL} \
303   ${APPS} \
304   ${BLUETOOTH_GUI} \
305   ${IM_CLIENT} \
306   ${DISPMAN} \
307   ${FONTS} \
308   ${GAMES} \  
309   ${GNOME_APPS} \
310   ${GSTREAMER} \
311   ${ICON_THEME} \
312   ${LAUNCHERS} \
313   ${PANDORA} \
314   ${PERL} \
315   ${PULSEAUDIO} \
316   ${PYTHON_LIBS} \
317   ${QT_SUPPORT} \
318   ${TOTEM} \
319   ${TOUCHSCREEN} \
320   ${XSERVER_BASE} \
321   ${XFCE46_BASE} \
322   ${XFCE46_EXTRAS} \
323   ${XFCE_THEMES} \
324   ${ADD_LIBS} \
325   ${DSP} \
326   \
327   rxvt-unicode \
328 #  xst \
329 #  suspend-desktop \
330 #  teleport \
331   gdk-pixbuf-loader-png \
332   gdk-pixbuf-loader-xpm \
333   gdk-pixbuf-loader-jpeg \
334   pango-module-basic-x \
335   pango-module-basic-fc \
336   xcursor-transparent-theme \   
337   xterm \
338   jaaa nmap iperf \
339   xf86-video-udlfb \
340 #  gnuplot \
341 "