task-pandora-xfce.bb: Bump.
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r66"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   openvpn networkmanager-openvpn \
21   modemmanager \
22   xchat \
23   links-x11 \
24   enchant \
25   aspell \
26   xwininfo \
27   curl \
28   dosfstools \
29   netkit-ftp \
30 #  xournal \
31 #  arora \
32 "
33
34 BLUETOOTH_GUI = " \
35   gnome-bluetooth \
36 "
37
38 IM_CLIENT = " \
39 #  pidgin \
40 #  libpurple-protocol-msn \
41 #  libpurple-protocol-yahoo \
42 #  libpurple-protocol-icq \
43 #  libpurple-protocol-aim \
44 "
45
46 DISPMAN = " \
47   slim \
48   slim-op-themes \
49 "
50
51 FONTS = " \
52   font-adobe-75dpi \
53   fontconfig fontconfig-utils font-util \
54   ttf-arphic-uming \
55   ttf-dejavu-common \
56   ttf-dejavu-sans \
57   ttf-dejavu-serif \
58   ttf-dejavu-sans-mono \
59   ttf-liberation-sans \
60   ttf-liberation-serif \
61   ttf-liberation-mono \
62   xorg-minimal-fonts \
63 "  
64
65 # Any default games we want to ship.
66 GAMES = " \
67 #  scummvm \
68 #  frozen-bubble \
69 #  gnome-games \  
70 #  numptyphysics \
71 "
72
73 GNOME_APPS = " \
74 #  gnome-mplayer \
75   gcalctool \ 
76   gnome-keyring gnome-keyring-pam-plugin \
77   gksu \
78 "
79
80 GSTREAMER = " \
81 #  gstreamer-ti \
82   gst-ffmpeg \
83   gst-omapfb \
84 #  gst-plugin-pulse \
85   gst-plugin-xvimagesink \
86   gst-plugins-base-meta \
87 #  gst-plugins-good-meta \
88 #  gst-plugins-bad-meta \
89 #  gst-plugins-ugly-meta \
90   gst-plugin-gles \
91 "
92
93 ICON_THEME = " \
94   hicolor-icon-theme \
95   elementary-icon-theme \
96   elementary-icon-theme-enable \
97 "
98
99 LAUNCHERS = " \
100 #  netbook-launcher-efl \
101   pandora-libpnd-minimenu \
102 #  pandora-pmenu \
103 "
104
105 PANDORA = " \
106   pandora-first-run-wizard hsetroot \
107   pandora-scripts \
108   pandora-wallpaper-official \
109   pandora-xfce-defaults \
110 #  pandora-midori-defaults midori \
111   libgles2d \
112   pandora-misc \
113   pandora-pndstore \
114 "
115
116 PERL = " \
117   perl \
118   task-perl-module-all \
119   libnet-dbus-perl \
120   libxml-parser-perl \
121   libxml-twig-perl \
122 "
123
124 PULSEAUDIO = " \
125 #  pulseaudio-alsa-wrapper \
126 #  pulseaudio-esd-wrapper \
127 #  pulseaudio-module-gconf \
128 #  libasound-module-ctl-pulse \
129 #  libasound-module-pcm-pulse \
130 "
131
132 PYTHON_LIBS = " \
133   python-shell \
134   python-pygtk \
135   python-pycairo \
136   gnome-vfs-plugin-http \
137   gnome-vfs-plugin-ftp \
138 "
139
140 QT_SUPPORT = " \
141  libqt3support4 \ 
142  libqtassistantclient4 \ 
143  libqtclucene4 \ 
144  libqtcore4 \ 
145  libqtdbus4 \ 
146  libqtdesigner4 \ 
147  libqtdesignercomponents4 \ 
148  libqtgui4 \ 
149  libqthelp4 \ 
150  libqtnetwork4 \  
151  libqtscript4 \ 
152  libqtscripttools4 \ 
153  libqtsql4 \ 
154  libqtsvg4 \ 
155  libqttest4 \ 
156  libqtwebkit4 \ 
157  libqtxml4 \  
158  qt4-tools \ 
159  qt4-assistant \ 
160  qt4-common \ 
161  qt4-dbus \ 
162  qt4-designer \ 
163  qt4-fonts \ 
164  qt4-linguist \ 
165  qt4-mkspecs \ 
166  qt4-pixeltool \ 
167  qt4-qt3to4 \
168  qt4-plugin-imageformat-jpeg \
169  qt4-plugin-imageformat-gif \
170 "
171
172
173 TOTEM = " \
174 #  totem \
175 #  totem-browser-plugin \
176 #  totem-plugin-bemused \
177 #  totem-plugin-gromit \
178 #  totem-plugin-media-player-keys \
179 #  totem-plugin-ontop \
180 #  totem-plugin-properties \
181 #  totem-plugin-screensaver \
182 #  totem-plugin-skipto \
183 #  totem-plugin-thumbnail \
184 "
185
186 TOUCHSCREEN = " \
187   gtk-touchscreen-mode-enable \
188   libgtkstylus \
189 #  xinput-calibrator \
190 "
191
192 XFCE46_BASE = " \
193   xfce4-dev-tools \
194   xfwm4 \
195   xfwm4-theme-default \
196   xfce-utils \  
197   xfce4-session \     
198   xfconf \
199   xfdesktop \
200   xfce4-panel \
201   xfce4-power-manager \
202   \
203   gtk-xfce-engine \
204   \
205   xfce4-panel-plugin-actions \
206   xfce4-panel-plugin-clock \
207   xfce4-panel-plugin-iconbox \
208   xfce4-panel-plugin-launcher \
209   xfce4-panel-plugin-pager \
210   xfce4-panel-plugin-separator \
211   xfce4-panel-plugin-showdesktop \
212   xfce4-panel-plugin-systray \
213   xfce4-panel-plugin-tasklist \
214   xfce4-panel-plugin-windowlist \   
215   xfce4-settings \
216   xfce-terminal \
217   thunar \
218 "
219
220 XFCE46_EXTRAS = " \
221   xfce4-notifyd \
222   xfce4-mixer \
223   xfce4-appfinder \
224   xfce4-battery-plugin \
225   xfprint \    
226   orage \
227   squeeze \
228   ristretto \
229   mousepad \ 
230   gigolo \
231   xdotool \
232 "
233
234 XFCE_THEMES = " \
235   xfwm4-theme-daloa \
236   xfwm4-theme-moheli \
237   xfwm4-theme-kokodi \
238   xfwm4-theme-sassandra \
239   xfwm4-themes \
240 "
241
242 XSERVER_BASE = " \
243   ${XSERVER} \
244   dbus-x11 \
245   desktop-file-utils \
246   iso-codes \
247   mime-support \
248   notification-daemon inotify-tools \
249   xauth \
250   xdg-utils \
251   xhost \
252   xinetd \
253   xinit \
254   xlsfonts \
255   xrdb \
256   xrefresh \
257   xset \
258   xvinfo \
259   devilspie \
260   encodings \
261   xterm \
262   xmodmap \
263 "
264
265 ADD_LIBS = " \
266   libbonobo \
267   libetpan \
268   libfribidi \
269   libgsf \
270   libidn \
271   libxslt \
272   wv \
273   libsamplerate0 \
274   glibc-gconv-cp1252 \
275   glibc-gconv-ibm850 \
276   glibc-gconv-iso8859-15 \
277   glibc-gconv-cp1250 \
278   glibc-gconv-koi8-r \
279   glibc-gconv-unicode \
280   glibc-gconv-utf-16 \
281   gvfsd-sftp \
282   sshfs-fuse \
283   rtl8712-module \
284   rtl8192u-module \
285
286
287 DSP = " \
288   ti-dsplink-module \
289   ti-cmem-module \
290   ti-lpm-module \
291   ti-sdma-module \
292   ti-codecs-omap3530-server \
293 "
294
295 RDEPENDS_${PN} = " \
296   task-pandora-core \
297   angstrom-x11-base-depends \
298   ${ANGSTROM_EXTRA_INSTALL} \
299   ${APPS} \
300   ${BLUETOOTH_GUI} \
301   ${IM_CLIENT} \
302   ${DISPMAN} \
303   ${FONTS} \
304   ${GAMES} \  
305   ${GNOME_APPS} \
306   ${GSTREAMER} \
307   ${ICON_THEME} \
308   ${LAUNCHERS} \
309   ${PANDORA} \
310   ${PERL} \
311   ${PULSEAUDIO} \
312   ${PYTHON_LIBS} \
313   ${QT_SUPPORT} \
314   ${TOTEM} \
315   ${TOUCHSCREEN} \
316   ${XSERVER_BASE} \
317   ${XFCE46_BASE} \
318   ${XFCE46_EXTRAS} \
319   ${XFCE_THEMES} \
320   ${ADD_LIBS} \
321   ${DSP} \
322   \
323   rxvt-unicode \
324 #  xst \
325 #  suspend-desktop \
326 #  teleport \
327   gdk-pixbuf-loader-png \
328   gdk-pixbuf-loader-xpm \
329   gdk-pixbuf-loader-jpeg \
330   pango-module-basic-x \
331   pango-module-basic-fc \
332   xcursor-transparent-theme \   
333   xterm \
334   jaaa nmap iperf \
335 #  gnuplot \
336 "