pandora-configtray-wifi.bb: Wifi-Plugin for Configtray
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r72"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   openvpn networkmanager-openvpn \
21   modemmanager \
22   xchat \
23   links-x11 \
24   enchant \
25   aspell \
26   xwininfo \
27   curl \
28   dosfstools \
29   netkit-ftp \
30 #  xournal \
31 #  arora \
32 "
33
34 BLUETOOTH_GUI = " \
35   gnome-bluetooth \
36 "
37
38 IM_CLIENT = " \
39 #  pidgin \
40 #  libpurple-protocol-msn \
41 #  libpurple-protocol-yahoo \
42 #  libpurple-protocol-icq \
43 #  libpurple-protocol-aim \
44 "
45
46 DISPMAN = " \
47   slim \
48   slim-op-themes \
49 "
50
51 FONTS = " \
52   font-adobe-75dpi \
53   fontconfig fontconfig-utils font-util \
54   ttf-arphic-uming \
55   ttf-dejavu-common \
56   ttf-dejavu-sans \
57   ttf-dejavu-serif \
58   ttf-dejavu-sans-mono \
59   ttf-liberation-sans \
60   ttf-liberation-serif \
61   ttf-liberation-mono \
62   xorg-minimal-fonts \
63 "  
64
65 # Any default games we want to ship.
66 GAMES = " \
67 #  scummvm \
68 #  frozen-bubble \
69 #  gnome-games \  
70 #  numptyphysics \
71 "
72
73 GNOME_APPS = " \
74 #  gnome-mplayer \
75   gcalctool \ 
76   gnome-keyring gnome-keyring-pam-plugin \
77   gksu \
78 "
79
80 GSTREAMER = " \
81 #  gstreamer-ti \
82   gst-ffmpeg \
83   gst-omapfb \
84 #  gst-plugin-pulse \
85   gst-plugin-xvimagesink \
86   gst-plugins-base-meta \
87 #  gst-plugins-good-meta \
88 #  gst-plugins-bad-meta \
89 #  gst-plugins-ugly-meta \
90   gst-plugin-gles \
91 "
92
93 ICON_THEME = " \
94   hicolor-icon-theme \
95   elementary-icon-theme \
96   elementary-icon-theme-enable \
97 "
98
99 LAUNCHERS = " \
100 #  netbook-launcher-efl \
101   pandora-libpnd-minimenu \
102 #  pandora-pmenu \
103 "
104
105 PANDORA = " \
106   pandora-first-run-wizard hsetroot \
107   pandora-scripts \
108   pandora-scripts-wifi \
109   pandora-wallpaper-official \
110   pandora-xfce-defaults \
111 #  pandora-midori-defaults midori \
112   libgles2d \
113   pandora-misc \
114   pandora-pndstore \
115   pandora-configtray \
116 "
117
118 PERL = " \
119   perl \
120   task-perl-module-all \
121   libnet-dbus-perl \
122   libxml-parser-perl \
123   libxml-twig-perl \
124 "
125
126 PULSEAUDIO = " \
127 #  pulseaudio-alsa-wrapper \
128 #  pulseaudio-esd-wrapper \
129 #  pulseaudio-module-gconf \
130 #  libasound-module-ctl-pulse \
131 #  libasound-module-pcm-pulse \
132 "
133
134 PYTHON_LIBS = " \
135   python-shell \
136   python-pygtk \
137   python-pycairo \
138   gnome-vfs-plugin-http \
139   gnome-vfs-plugin-ftp \
140 "
141
142 QT_SUPPORT = " \
143  libqt3support4 \ 
144  libqtassistantclient4 \ 
145  libqtclucene4 \ 
146  libqtcore4 \ 
147  libqtdbus4 \ 
148  libqtdesigner4 \ 
149  libqtdesignercomponents4 \ 
150  libqtgui4 \ 
151  libqthelp4 \ 
152  libqtnetwork4 \  
153  libqtscript4 \ 
154  libqtscripttools4 \ 
155  libqtsql4 \ 
156  libqtsvg4 \ 
157  libqttest4 \ 
158  libqtwebkit4 \ 
159  libqtxml4 \  
160  qt4-tools \ 
161  qt4-assistant \ 
162  qt4-common \ 
163  qt4-dbus \ 
164  qt4-designer \ 
165  qt4-fonts \ 
166  qt4-linguist \ 
167  qt4-mkspecs \ 
168  qt4-pixeltool \ 
169  qt4-qt3to4 \
170  qt4-plugin-imageformat-jpeg \
171  qt4-plugin-imageformat-gif \
172 "
173
174
175 TOTEM = " \
176 #  totem \
177 #  totem-browser-plugin \
178 #  totem-plugin-bemused \
179 #  totem-plugin-gromit \
180 #  totem-plugin-media-player-keys \
181 #  totem-plugin-ontop \
182 #  totem-plugin-properties \
183 #  totem-plugin-screensaver \
184 #  totem-plugin-skipto \
185 #  totem-plugin-thumbnail \
186 "
187
188 TOUCHSCREEN = " \
189 #  gtk-touchscreen-mode-enable \
190   libgtkstylus \
191 #  xinput-calibrator \
192 "
193
194 XFCE46_BASE = " \
195   xfce4-dev-tools \
196   xfwm4 \
197   xfwm4-theme-default \
198   xfce-utils \  
199   xfce4-session \     
200   xfconf \
201   xfdesktop \
202   xfce4-panel \
203   xfce4-power-manager \
204   \
205   gtk-xfce-engine \
206   \
207   xfce4-panel-plugin-actions \
208   xfce4-panel-plugin-clock \
209   xfce4-panel-plugin-iconbox \
210   xfce4-panel-plugin-launcher \
211   xfce4-panel-plugin-pager \
212   xfce4-panel-plugin-separator \
213   xfce4-panel-plugin-showdesktop \
214   xfce4-panel-plugin-systray \
215   xfce4-panel-plugin-tasklist \
216   xfce4-panel-plugin-windowlist \   
217   xfce4-settings \
218   xfce-terminal \
219   thunar \
220 "
221
222 XFCE46_EXTRAS = " \
223   xfce4-notifyd \
224   xfce4-mixer \
225   xfce4-appfinder \
226   xfce4-battery-plugin \
227   xfprint \    
228   orage \
229   squeeze \
230   ristretto \
231   mousepad \ 
232   gigolo \
233   xdotool \
234 "
235
236 XFCE_THEMES = " \
237   xfwm4-theme-daloa \
238   xfwm4-theme-moheli \
239   xfwm4-theme-kokodi \
240   xfwm4-theme-sassandra \
241   xfwm4-themes \
242 "
243
244 XSERVER_BASE = " \
245   ${XSERVER} \
246   dbus-x11 \
247   desktop-file-utils \
248   iso-codes \
249   mime-support \
250   notification-daemon inotify-tools \
251   xauth \
252   xdg-utils \
253   xhost \
254   xinetd \
255   xinit \
256   xlsfonts \
257   xrdb \
258   xrefresh \
259   xset \
260   xvinfo \
261   devilspie \
262   encodings \
263   xterm \
264   xmodmap \
265 "
266
267 ADD_LIBS = " \
268   libbonobo \
269   libetpan \
270   libfribidi \
271   libgsf \
272   libidn \
273   libxslt \
274   wv \
275   libsamplerate0 \
276   glibc-gconv-cp1252 \
277   glibc-gconv-ibm850 \
278   glibc-gconv-iso8859-15 \
279   glibc-gconv-cp1250 \
280   glibc-gconv-koi8-r \
281   glibc-gconv-unicode \
282   glibc-gconv-utf-16 \
283   gvfsd-sftp \
284   sshfs-fuse \
285   directfb \
286   rtl8712-module \
287   rtl8192u-module \
288
289
290 DSP = " \
291   ti-dsplink-module \
292   ti-cmem-module \
293   ti-lpm-module \
294   ti-sdma-module \
295   ti-codecs-omap3530-server \
296 "
297
298 RDEPENDS_${PN} = " \
299   task-pandora-core \
300   angstrom-x11-base-depends \
301   ${ANGSTROM_EXTRA_INSTALL} \
302   ${APPS} \
303   ${BLUETOOTH_GUI} \
304   ${IM_CLIENT} \
305   ${DISPMAN} \
306   ${FONTS} \
307   ${GAMES} \  
308   ${GNOME_APPS} \
309   ${GSTREAMER} \
310   ${ICON_THEME} \
311   ${LAUNCHERS} \
312   ${PANDORA} \
313   ${PERL} \
314   ${PULSEAUDIO} \
315   ${PYTHON_LIBS} \
316   ${QT_SUPPORT} \
317   ${TOTEM} \
318   ${TOUCHSCREEN} \
319   ${XSERVER_BASE} \
320   ${XFCE46_BASE} \
321   ${XFCE46_EXTRAS} \
322   ${XFCE_THEMES} \
323   ${ADD_LIBS} \
324   ${DSP} \
325   \
326   rxvt-unicode \
327 #  xst \
328 #  suspend-desktop \
329 #  teleport \
330   gdk-pixbuf-loader-png \
331   gdk-pixbuf-loader-xpm \
332   gdk-pixbuf-loader-jpeg \
333   pango-module-basic-x \
334   pango-module-basic-fc \
335   xcursor-transparent-theme \   
336   xterm \
337   jaaa nmap iperf \
338   xf86-video-udlfb \
339 #  gnuplot \
340 "