23171dd7bed219388f6f709fc9e0d21c46301de3
[openpandora.oe.git] / recipes / tasks / task-pandora-xfce.bb
1 DESCRIPTION = "Task file for the XFCE Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r56"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   avahi-ui \
13 #  abiword \
14   evince \
15 #  claws-mail \
16   swfdec swfdec-gnome swfdec-mozilla \
17 #  gnumeric \   
18   networkmanager network-manager-applet \ 
19   vnc x11vnc angstrom-x11vnc-xinit \
20   xchat \
21   links-x11 \
22   enchant \
23   aspell \
24   xwininfo \
25 #  xournal \
26 #  arora \
27 "
28
29 BLUETOOTH_GUI = " \
30   gnome-bluetooth \
31 "
32
33 IM_CLIENT = " \
34 #  pidgin \
35 #  libpurple-protocol-msn \
36 #  libpurple-protocol-yahoo \
37 #  libpurple-protocol-icq \
38 #  libpurple-protocol-aim \
39 "
40
41 DISPMAN = " \
42   slim \
43   slim-op-themes \
44 "
45
46 FONTS = " \
47   font-adobe-75dpi \
48   fontconfig fontconfig-utils font-util \
49   ttf-arphic-uming \
50   ttf-dejavu-common \
51   ttf-dejavu-sans \
52   ttf-dejavu-serif \
53   ttf-dejavu-sans-mono \
54   ttf-liberation-sans \
55   ttf-liberation-serif \
56   ttf-liberation-mono \
57   xorg-minimal-fonts \
58 "  
59
60 # Any default games we want to ship.
61 GAMES = " \
62 #  scummvm \
63 #  frozen-bubble \
64 #  gnome-games \  
65 #  numptyphysics \
66 "
67
68 GNOME_APPS = " \
69 #  gnome-mplayer \
70   gcalctool \ 
71   gnome-keyring gnome-keyring-pam-plugin \
72   gksu \
73 "
74
75 GSTREAMER = " \
76 #  gstreamer-ti \
77   gst-ffmpeg \
78   gst-omapfb \
79 #  gst-plugin-pulse \
80   gst-plugin-xvimagesink \
81   gst-plugins-base-meta \
82 #  gst-plugins-good-meta \
83 #  gst-plugins-bad-meta \
84 #  gst-plugins-ugly-meta \
85   gst-plugin-gles \
86 "
87
88 ICON_THEME = " \
89   hicolor-icon-theme \
90   elementary-icon-theme \
91   elementary-icon-theme-enable \
92 "
93
94 LAUNCHERS = " \
95 #  netbook-launcher-efl \
96   pandora-libpnd-minimenu \
97 #  pandora-pmenu \
98 "
99
100 PANDORA = " \
101   pandora-first-run-wizard hsetroot \
102   pandora-scripts \
103   pandora-wallpaper-official \
104   pandora-xfce-defaults \
105 #  pandora-midori-defaults midori \
106   libgles2d \
107   pandora-misc \
108   pandora-pndstore \
109 "
110
111 PERL = " \
112   perl \
113   task-perl-module-all \
114   libnet-dbus-perl \
115   libxml-parser-perl \
116   libxml-twig-perl \
117 "
118
119 PULSEAUDIO = " \
120 #  pulseaudio-alsa-wrapper \
121 #  pulseaudio-esd-wrapper \
122 #  pulseaudio-module-gconf \
123 #  libasound-module-ctl-pulse \
124 #  libasound-module-pcm-pulse \
125 "
126
127 PYTHON_LIBS = " \
128   python-shell \
129   python-pygtk \
130   python-pycairo \
131   gnome-vfs-plugin-http \
132   gnome-vfs-plugin-ftp \
133 "
134
135 QT_SUPPORT = " \
136  libqt3support4 \ 
137  libqtassistantclient4 \ 
138  libqtclucene4 \ 
139  libqtcore4 \ 
140  libqtdbus4 \ 
141  libqtdesigner4 \ 
142  libqtdesignercomponents4 \ 
143  libqtgui4 \ 
144  libqthelp4 \ 
145  libqtnetwork4 \  
146  libqtscript4 \ 
147  libqtscripttools4 \ 
148  libqtsql4 \ 
149  libqtsvg4 \ 
150  libqttest4 \ 
151  libqtwebkit4 \ 
152  libqtxml4 \  
153  qt4-tools \ 
154  qt4-assistant \ 
155  qt4-common \ 
156  qt4-dbus \ 
157  qt4-designer \ 
158  qt4-fonts \ 
159  qt4-linguist \ 
160  qt4-mkspecs \ 
161  qt4-pixeltool \ 
162  qt4-qt3to4 \
163  qt4-plugin-imageformat-jpeg \
164  qt4-plugin-imageformat-gif \
165 "
166
167
168 TOTEM = " \
169 #  totem \
170 #  totem-browser-plugin \
171 #  totem-plugin-bemused \
172 #  totem-plugin-gromit \
173 #  totem-plugin-media-player-keys \
174 #  totem-plugin-ontop \
175 #  totem-plugin-properties \
176 #  totem-plugin-screensaver \
177 #  totem-plugin-skipto \
178 #  totem-plugin-thumbnail \
179 "
180
181 TOUCHSCREEN = " \
182   gtk-touchscreen-mode-enable \
183   libgtkstylus \
184 #  xinput-calibrator \
185 "
186
187 XFCE46_BASE = " \
188   xfce4-dev-tools \
189   xfwm4 \
190   xfwm4-theme-default \
191   xfce-utils \  
192   xfce4-session \     
193   xfconf \
194   xfdesktop \
195   xfce4-panel \
196   xfce4-power-manager \
197   \
198   gtk-xfce-engine \
199   \
200   xfce4-panel-plugin-actions \
201   xfce4-panel-plugin-clock \
202   xfce4-panel-plugin-iconbox \
203   xfce4-panel-plugin-launcher \
204   xfce4-panel-plugin-pager \
205   xfce4-panel-plugin-separator \
206   xfce4-panel-plugin-showdesktop \
207   xfce4-panel-plugin-systray \
208   xfce4-panel-plugin-tasklist \
209   xfce4-panel-plugin-windowlist \   
210   xfce4-settings \
211   xfce-terminal \
212   thunar \
213 "
214
215 XFCE46_EXTRAS = " \
216   xfce4-notifyd \
217   xfce4-mixer \
218   xfce4-appfinder \
219   xfce4-battery-plugin \
220   xfprint \    
221   orage \
222   squeeze \
223   ristretto \
224   mousepad \ 
225   gigolo \
226   xdotool \
227 "
228
229 XFCE_THEMES = " \
230   xfwm4-theme-daloa \
231   xfwm4-theme-moheli \
232   xfwm4-theme-kokodi \
233   xfwm4-theme-sassandra \
234   xfwm4-themes \
235 "
236
237 XSERVER_BASE = " \
238   ${XSERVER} \
239   dbus-x11 \
240   desktop-file-utils \
241   iso-codes \
242   mime-support \
243   notification-daemon inotify-tools \
244   xauth \
245   xdg-utils \
246   xhost \
247   xinetd \
248   xinit \
249   xlsfonts \
250   xrdb \
251   xrefresh \
252   xset \
253   xvinfo \
254   devilspie \
255   encodings \
256   xterm \
257   xmodmap \
258 "
259
260 ADD_LIBS = " \
261   libbonobo \
262   libetpan \
263   libfribidi \
264   libgsf \
265   libidn \
266   libxslt \
267   wv \
268   libsamplerate0 \
269   glibc-gconv-cp1252 \
270   glibc-gconv-ibm850 \
271   glibc-gconv-iso8859-15 \
272   
273
274
275 RDEPENDS_${PN} = " \
276   task-pandora-core \
277   angstrom-x11-base-depends \
278   ${ANGSTROM_EXTRA_INSTALL} \
279   ${APPS} \
280   ${BLUETOOTH_GUI} \
281   ${IM_CLIENT} \
282   ${DISPMAN} \
283   ${FONTS} \
284   ${GAMES} \  
285   ${GNOME_APPS} \
286   ${GSTREAMER} \
287   ${ICON_THEME} \
288   ${LAUNCHERS} \
289   ${PANDORA} \
290   ${PERL} \
291   ${PULSEAUDIO} \
292   ${PYTHON_LIBS} \
293   ${QT_SUPPORT} \
294   ${TOTEM} \
295   ${TOUCHSCREEN} \
296   ${XSERVER_BASE} \
297   ${XFCE46_BASE} \
298   ${XFCE46_EXTRAS} \
299   ${XFCE_THEMES} \
300   ${ADD_LIBS} \
301   \
302   rxvt-unicode \
303 #  xst \
304 #  suspend-desktop \
305 #  teleport \
306   gdk-pixbuf-loader-png \
307   gdk-pixbuf-loader-xpm \
308   gdk-pixbuf-loader-jpeg \
309   pango-module-basic-x \
310   pango-module-basic-fc \
311   xcursor-transparent-theme \   
312   xterm \
313   jaaa nmap iperf \
314 #  gnuplot \
315 "