task-pandora-xfce: Added e2fsprogs, curl and dosfstools
[openpandora.oe.git] / recipes / tasks / task-pandora-gui.bb
1 rDESCRIPTION = "Task file for default GUI apps in the Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r1"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   abiword \
13   cheese \
14   claws-mail \
15   epiphany epiphany-extensions \
16   swfdec swfdec-gnome swfdec-mozilla \
17   evince \
18   gcalctool \
19   gedit \
20   gimp \
21   gnome-games \
22   gnome-mplayer \
23   gnumeric \
24   gphoto2 \
25   gthumb \
26   pidgin \
27   synergy \
28   vnc \
29   x11vnc angstrom-x11vnc-xinit \
30   xmms \
31   xterm \
32 "
33
34 FONTS = " \
35   font-adobe-75dpi \
36   fontconfig fontconfig-utils font-util \
37   ttf-arphic-uming \
38   ttf-dejavu-common \
39   ttf-dejavu-sans \
40   ttf-dejavu-serif \
41   ttf-dejavu-sans-mono \
42   ttf-liberation-sans \
43   ttf-liberation-serif \
44   ttf-liberation-mono \
45   xorg-minimal-fonts \
46 "  
47
48 GSTREAMER = " \
49   gst-ffmpeg \
50   gst-omapfb \
51   gst-plugin-pulse \
52   gst-plugins-base-meta \
53   gst-plugins-good-meta \
54   gst-plugins-bad-meta \
55 #  gst-plugins-ugly-meta \
56 "
57
58 PERL = " \
59   perl \
60 #  task-perl-module-all \
61 #  libnet-dbus-perl \
62   libxml-parser-perl \
63   libxml-twig-perl \
64 "
65
66 PULSEAUDIO = " \
67   pulseaudio-alsa-wrapper \
68   pulseaudio-esd-wrapper \
69   pulseaudio-module-gconf \
70   libasound-module-ctl-pulse \
71   libasound-module-pcm-pulse \
72 "
73
74 XSERVER_BASE = " \
75   ${XSERVER} \
76   dbus-x11 \
77   desktop-file-utils \
78   iso-codes \
79   mime-support \
80   notification-daemon inotify-tools \
81   xauth \
82 #  xdg-utils \
83   xhost \
84   xinetd \
85   xinit \
86   xlsfonts \
87   xrdb \
88   xrefresh \
89   xset \
90   xvinfo \
91 "
92
93 RDEPENDS_${PN} = " \
94   task-pandora-core \
95   ${ANGSTROM_EXTRA_INSTALL} \
96   ${APPS} \
97   ${FONTS} \
98   ${GSTREAMER} \
99   ${PERL} \
100   ${PULSEAUDIO} \
101   ${XSERVER_BASE} \
102         angstrom-x11-base-depends \
103         angstrom-gpe-task-base angstrom-gpe-task-game angstrom-gpe-task-apps angstrom-gpe-task-settings \
104         angstrom-zeroconf-audio \
105         angstrom-led-config \ 
106         angstrom-gnome-icon-theme-enable \
107         gpe-scap \
108         xterm xmms \
109         firefox \
110         swfdec-mozilla \
111         abiword \
112         claws-mail \
113         evince \
114         pidgin \
115         gnome-games \
116         synergy \
117         x11vnc angstrom-x11vnc-xinit \
118         xmms \
119         xterm \
120         xtscal \
121         matchbox2 \
122         matchbox-terminal \
123         matchbox-themes-gtk pandora-matchbox-gtk-theme \
124         pcmanfm \
125         ttf-liberation-sans ttf-liberation-serif ttf-liberation-mono \
126         xauth xhost xset xrandr \
127         xcursor-transparent-theme \
128         settings-daemon \
129         matchbox-applet-cards \
130         matchbox-applet-inputmanager \
131         matchbox-applet-volume \
132         matchbox-applet-startup-monitor \
133 #       connman-gnome \
134         networkmanager \
135         scummvm \
136         gnome-bluetooth \
137 "