vairous: add in local updates for tasks/images.
[openpandora.oe.git] / recipes / tasks / task-pandora-gnome.bb
1 DESCRIPTION = "Task file for the 'gnome' Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r3.1"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   abiword \
13   cheese \
14   claws-mail \
15   epiphany epiphany-extensions \
16   swfdec swfdec-gnome swfdec-mozilla \
17   evince \
18   gcalctool \
19   gedit \
20   gimp \
21   gnome-games \
22   gnome-mplayer \
23   gnumeric \
24   gphoto2 \
25   gthumb \
26   pidgin \
27   synergy \
28   vnc \
29   x11vnc angstrom-x11vnc-xinit \
30   xmms \
31   xterm \
32 "
33
34 FONTS = " \
35   font-adobe-75dpi \
36   fontconfig fontconfig-utils font-util \
37   ttf-arphic-uming \
38   ttf-dejavu-common \
39   ttf-dejavu-sans \
40   ttf-dejavu-serif \
41   ttf-dejavu-sans-mono \
42   ttf-liberation-sans \
43   ttf-liberation-serif \
44   ttf-liberation-mono \
45   xorg-minimal-fonts \
46 "  
47
48 GNOME = " \
49   at-spi \
50   file-roller \
51   gconf gconf-editor \
52   gdm \
53   gnome-control-center \
54   gnome-applets \
55   gnome-bluetooth \
56   gnome-desktop \
57   gnome-doc-utils \
58   gnome-keyring gnome-keyring-pam-plugin \
59   gnome-media \
60   gnome-menus \
61   gnome-mime-data \
62 #  gnome-packagekit packagekit packagekit-gtkmodule \
63   gnome-panel libpanel-applet libgweather-locationdata\
64   gnome-power-manager gnome-power-manager-applets \
65   gnome-python \
66 # gnome-python-extras \
67   gnome-python-desktop \
68   gnome-screensaver \
69   gnome-session \
70   gnome-settings-daemon \
71   gnome-system-monitor \
72 #  gnome-system-tools system-tools-backends\
73   gnome-terminal \
74 #  gnome-utils \
75   gnome-vfs \
76   gnome-vfs-plugin-bzip2 \
77   gnome-vfs-plugin-computer \
78   gnome-vfs-plugin-dns-sd \
79   gnome-vfs-plugin-file \
80   gnome-vfs-plugin-ftp \
81   gnome-vfs-plugin-gzip \
82   gnome-vfs-plugin-http \
83   gnome-vfs-plugin-network \
84   gnome-vfs-plugin-nntp \
85   gnome-vfs-plugin-sftp \
86   gnome-vfs-plugin-tar \
87   gvfs \
88   metacity \
89   nautilus nautilus-cd-burner desktop-file-utils\
90   networkmanager network-manager-applet \
91 #networkmanager-openvpn \
92   policykit-gnome policykit \
93   zenity \
94 "
95
96 GSTREAMER = " \
97   gst-ffmpeg \
98   gst-omapfb \
99   gst-plugin-pulse \
100   gst-plugins-base-meta \
101   gst-plugins-good-meta \
102   gst-plugins-bad-meta \
103 #  gst-plugins-ugly-meta \
104 "
105
106 UIM = " \
107   uim \
108   uim-common \
109   uim-utils \
110   uim-gtk2.0 \
111   uim-anthy \
112   uim-fep \
113   uim-skk \
114   uim-xim \
115 "
116
117 PERL = " \
118   perl \
119 #  task-perl-module-all \
120 #  libnet-dbus-perl \
121   libxml-parser-perl \
122   libxml-twig-perl \
123 "
124
125 PRINT = " \
126   cups \
127   cups-backend-hal \
128 #  cups-gs \
129   gnome-cups-manager \
130   gtk-printbackend-cups \
131 #  gutenprint \
132   hal-cups-utils \
133 "
134
135 PULSEAUDIO = " \
136   pulseaudio-alsa-wrapper \
137   pulseaudio-esd-wrapper \
138   pulseaudio-module-gconf \
139   libasound-module-ctl-pulse \
140   libasound-module-pcm-pulse \
141 "
142
143 THEMES = " \
144   gnome-icon-theme \
145   gnome-themes \
146   gtk-engine-clearlooks \
147   gtk-engine-glide \
148   gtk-engine-thinice \
149   gtk-engine-redmond95 \
150   gtk-theme-clearlooks \
151   gtk-theme-thinice \
152   gtk-theme-redmond \
153   hicolor-icon-theme \
154 #  sound-theme-freedesktop \
155 "
156
157 TOTEM = " \
158 #  totem \
159 #  totem-browser-plugin \
160 #  totem-plugin-bemused \
161 #  totem-plugin-gromit \
162 #  totem-plugin-media-player-keys \
163 #  totem-plugin-ontop \
164 #  totem-plugin-properties \
165 #  totem-plugin-screensaver \
166 #  totem-plugin-skipto \
167 #  totem-plugin-thumbnail \
168 "
169
170 XSERVER_BASE = " \
171   ${XSERVER} \
172   dbus-x11 \
173   desktop-file-utils \
174   iso-codes \
175   mime-support \
176   notification-daemon inotify-tools \
177   xauth \
178 #  xdg-utils \
179   xhost \
180   xinetd \
181   xinit \
182   xlsfonts \
183   xrdb \
184   xrefresh \
185   xset \
186   xvinfo \
187 "
188
189 RDEPENDS_${PN} = " \
190   task-pandora-core \
191   ${ANGSTROM_EXTRA_INSTALL} \
192   ${APPS} \
193   ${FONTS} \
194   ${GNOME} \
195   ${GSTREAMER} \
196   ${PERL} \
197   ${PRINT} \
198   ${PULSEAUDIO} \
199   ${THEMES} \
200   ${TOTEM} \
201   ${XSERVER_BASE} \
202 "