Bumped recipes
[openpandora.oe.git] / recipes / tasks / task-pandora-gnome.bb
1 DESCRIPTION = "Task file for the 'gnome' Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r1"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   abiword \
13   cheese \
14   claws-mail \
15   epiphany epiphany-extensions \
16   swfdec swfdec-gnome swfdec-mozilla \
17   evince \
18   gcalctool \
19   gedit \
20   gimp \
21   gnome-games \
22   gnome-mplayer \
23   gnumeric \
24   gphoto2 \
25   gthumb \
26   pidgin \
27   synergy \
28   vnc \
29   x11vnc angstrom-x11vnc-xinit \
30   xmms \
31   xterm \
32 "
33
34 FONTS = " \
35   font-adobe-75dpi \
36   fontconfig fontconfig-utils font-util \
37   ttf-arphic-uming \
38   ttf-dejavu-common \
39   ttf-dejavu-sans \
40   ttf-dejavu-serif \
41   ttf-dejavu-sans-mono \
42   ttf-liberation-sans \
43   ttf-liberation-serif \
44   ttf-liberation-mono \
45   xorg-minimal-fonts \
46 "  
47
48 GNOME = " \
49   at-spi \
50   file-roller \
51   gconf gconf-editor \
52   gdm \
53   gnome-control-center \
54   gnome-applets \
55   gnome-bluetooth \
56   gnome-desktop \
57   gnome-doc-utils \
58   gnome-keyring gnome-keyring-pam-plugin \
59   gnome-media \
60   gnome-menus \
61   gnome-mime-data \
62 #  gnome-packagekit packagekit packagekit-gtkmodule \
63   gnome-panel libpanel-applet libgweather-locationdata\
64   gnome-power-manager gnome-power-manager-applets \
65   gnome-python \
66   gnome-python-extras \
67   gnome-python-desktop \
68   gnome-screensaver \
69   gnome-session \
70   gnome-settings-daemon \
71   gnome-system-monitor \
72   gnome-system-tools system-tools-backends \
73   gnome-terminal \
74   gnome-utils \
75   gnome-vfs \
76   gnome-vfs-plugin-bzip2 \
77   gnome-vfs-plugin-computer \
78   gnome-vfs-plugin-dns-sd \
79   gnome-vfs-plugin-file \
80   gnome-vfs-plugin-ftp \
81   gnome-vfs-plugin-gzip \
82   gnome-vfs-plugin-http \
83   gnome-vfs-plugin-network \
84   gnome-vfs-plugin-nntp \
85   gnome-vfs-plugin-sftp \
86   gnome-vfs-plugin-tar \
87   gvfs \
88   metacity \
89   nautilus nautilus-cd-burner desktop-file-utils\
90   networkmanager network-manager-applet networkmanager-openvpn \
91   policykit-gnome policykit \
92   zenity \
93 "
94
95 GSTREAMER = " \
96   gst-ffmpeg \
97   gst-omapfb \
98   gst-plugin-pulse \
99   gst-plugins-base-meta \
100   gst-plugins-good-meta \
101   gst-plugins-bad-meta \
102 #  gst-plugins-ugly-meta \
103 "
104
105 UIM = " \
106   uim \
107   uim-common \
108   uim-utils \
109   uim-gtk2.0 \
110   uim-anthy \
111   uim-fep \
112   uim-skk \
113   uim-xim \
114 "
115
116 PERL = " \
117   perl \
118 #  task-perl-module-all \
119   libnet-dbus-perl \
120   libxml-parser-perl \
121   libxml-twig-perl \
122 "
123
124 PRINT = " \
125   cups \
126   cups-backend-hal \
127 #  cups-gs \
128   gnome-cups-manager \
129   gtk-printbackend-cups \
130 #  gutenprint \
131   hal-cups-utils \
132 "
133
134 PULSEAUDIO = " \
135   pulseaudio-alsa-wrapper \
136   pulseaudio-esd-wrapper \
137   pulseaudio-module-gconf \
138   libasound-module-ctl-pulse \
139   libasound-module-pcm-pulse \
140 "
141
142 THEMES = " \
143   gnome-icon-theme \
144   gnome-themes \
145   gtk-engine-clearlooks \
146   gtk-engine-glide \
147   gtk-engine-thinice \
148   gtk-engine-redmond95 \
149   gtk-theme-clearlooks \
150   gtk-theme-thinice \
151   gtk-theme-redmond \
152   hicolor-icon-theme \
153 #  sound-theme-freedesktop \
154 "
155
156 TOTEM = " \
157   totem \
158   totem-browser-plugin \
159   totem-plugin-bemused \
160   totem-plugin-gromit \
161   totem-plugin-media-player-keys \
162   totem-plugin-ontop \
163   totem-plugin-properties \
164   totem-plugin-screensaver \
165   totem-plugin-skipto \
166   totem-plugin-thumbnail \
167 "
168
169 XSERVER_BASE = " \
170   ${XSERVER} \
171   dbus-x11 \
172   desktop-file-utils \
173   iso-codes \
174   mime-support \
175   notification-daemon inotify-tools \
176   xauth \
177   xdg-utils \
178   xhost \
179   xinetd \
180   xinit \
181   xlsfonts \
182   xrdb \
183   xrefresh \
184   xset \
185   xvinfo \
186 "
187
188 RDEPENDS_${PN} = " \
189   task-pandora-core \
190   ${ANGSTROM_EXTRA_INSTALL} \
191   ${APPS} \
192   ${FONTS} \
193   ${GNOME} \
194   ${GSTREAMER} \
195   ${PERL} \
196   ${PRINT} \
197   ${PULSEAUDIO} \
198   ${THEMES} \
199   ${TOTEM} \
200   ${XSERVER_BASE} \
201 "