pandora-scripts.bb: Fixed missing tvout-profiles.conf
[openpandora.oe.git] / recipes / tasks / task-pandora-desktop.bb
1 DESCRIPTION = "Task file for the 'desktop' Pandora image"
2
3 # Don't forget to bump the PR if you change it.
4
5 PR = "r1"
6
7 inherit task
8
9 ANGSTROM_EXTRA_INSTALL ?= ""
10
11 APPS = " \
12   abiword \
13   cheese \
14   claws-mail \
15   epiphany epiphany-extensions \
16   swfdec swfdec-gnome swfdec-mozilla \
17   evince \
18   gcalctool \
19   gedit \
20   gimp \
21   gnome-games \
22   gnome-mplayer \
23   gnumeric \
24   gphoto2 \
25   gthumb \
26   pidgin \
27   synergy \
28   vnc \
29   x11vnc angstrom-x11vnc-xinit \
30   xmms \
31   xterm \
32 "
33
34 E17 = " \
35   e-wm \
36   places \
37   e-wm-config-angstrom e-wm-config-angstrom-touchscreen e-wm-config-angstrom-widescreen e-wm-config-default \
38 "
39
40 FONTS = " \
41   font-adobe-75dpi \
42   fontconfig fontconfig-utils font-util \
43   ttf-arphic-uming \
44   ttf-dejavu-common \
45   ttf-dejavu-sans \
46   ttf-dejavu-serif \
47   ttf-dejavu-sans-mono \
48   ttf-liberation-sans \
49   ttf-liberation-serif \
50   ttf-liberation-mono \
51   xorg-minimal-fonts \
52 "  
53
54 GSTREAMER = " \
55   gst-ffmpeg \
56   gst-omapfb \
57   gst-plugin-pulse \
58   gst-plugins-base-meta \
59   gst-plugins-good-meta \
60   gst-plugins-bad-meta \
61 #  gst-plugins-ugly-meta \
62 "
63
64 PERL = " \
65   perl \
66 #  task-perl-module-all \
67 #  libnet-dbus-perl \
68   libxml-parser-perl \
69   libxml-twig-perl \
70 "
71
72 PULSEAUDIO = " \
73   pulseaudio-alsa-wrapper \
74   pulseaudio-esd-wrapper \
75   pulseaudio-module-gconf \
76   libasound-module-ctl-pulse \
77   libasound-module-pcm-pulse \
78 "
79
80 XSERVER_BASE = " \
81   ${XSERVER} \
82   dbus-x11 \
83   desktop-file-utils \
84   iso-codes \
85   mime-support \
86   notification-daemon inotify-tools \
87   xauth \
88 #  xdg-utils \
89   xhost \
90   xinetd \
91   xinit \
92   xlsfonts \
93   xrdb \
94   xrefresh \
95   xset \
96   xvinfo \
97 "
98
99 RDEPENDS_${PN} = " \
100   task-pandora-core \
101   ${ANGSTROM_EXTRA_INSTALL} \
102   ${APPS} \
103   ${E17} \
104   ${FONTS} \
105   ${GSTREAMER} \
106   ${PERL} \
107   ${PULSEAUDIO} \
108   ${XSERVER_BASE} \
109         angstrom-x11-base-depends \
110         angstrom-gpe-task-base angstrom-gpe-task-settings \
111         angstrom-zeroconf-audio \
112         angstrom-led-config \ 
113         gpe-scap \
114         mime-support \
115         xterm xmms \
116         firefox midori \
117         gecko-mediaplayer-firefox-hack \
118         hicolor-icon-theme gnome-icon-theme \
119         jaaa nmap iperf gnuplot \
120         abiword \
121         gnumeric \
122         gimp \
123         pidgin \
124         gnome-games \
125         stalonetray \
126         synergy \
127         x11vnc angstrom-x11vnc-xinit \
128         angstrom-gnome-icon-theme-enable \
129 #       connman-gnome \
130         networkmanager network-manager-applet \
131         gnome-bluetooth \
132 "