task-pandora-core/xfce: Commit latest image tasks.
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r13"
9
10 inherit task 
11
12 AUFS = " \
13 #  aufs2-27 \
14   aufs2-util \
15 "
16
17 BLUETOOTH = " \
18   blueprobe \
19   bluez4 gst-plugin-bluez \
20   libsndfile1 libasound-module-bluez \
21 "
22
23 # Package up the boot scripts and bootchart to help us work to drop the startup time.
24 BOOT = " \
25   pandora-uboot-scripts \
26   bootchart \
27 "
28
29 WIRELESS = " \
30   pandora-firmware \
31   wl1251-modules \
32 #  pandora-wifi pandora-wifi-tools \
33   wireless-tools \
34   wpa-supplicant \  
35   networkmanager netm-cli \  
36 "
37
38 MEDIA_LIBS = " \
39   libmodplug \
40   libsdl-x11 libsdl-mixer libsdl-image \
41   libsdl-gfx libsdl-net libsdl-ttf \
42   mikmod \
43   speex \  
44   
45 "
46 OPENGLES = " \
47   omap3-sgx-modules devmem2 \
48   libgles-omap3 \
49 #  libgles-omap3-demos \
50 "
51
52 PAM = " \
53   libpam \
54   libpam-meta \
55 "
56
57 PANDORA_LIBS = " \
58   pandora-libpnd lsof \
59   omap3-deviceid \
60   pandora-skel \
61 "
62
63 SUDO = " \
64   sudo sudo-enable-wheel-group \ 
65   pandora-sudoers \
66 "
67
68 SSH = " \
69   openssh-scp \
70   openssh-ssh \
71 "
72
73 TOUCHSCREEN = " \
74   tslib tslib-tests tslib-calibrate pointercal \
75 "
76
77 FS_SUPPORT = " \
78 #  nfs-utils \
79   nfs-utils-client \
80   fuse fuse-utils \
81   sshfs-fuse gmailfs curlftpfs \
82   ntfs-3g \
83   squashfs-tools \
84 "
85
86 EXTRA_TOOLS = " \
87   avahi \
88   fbgrab fbset fbset-modes \
89   portmap \
90   file \
91   socat \
92   strace \
93   ksymoops \
94   kexec-tools \
95   zip \        
96   gzip \
97   bash \
98   bzip2 \  
99   minicom \
100   nano \
101   gdb \
102   sessreg \
103 "
104
105 # Add extra util-linux-ng utils to image. 
106 # TODO: Fix util-linux-ng to meta depend on all subpackages.
107 UTIL_LINUX_NG_EXTRAS = " \
108   util-linux-ng-losetup util-linux-ng-mountall \
109   util-linux-ng-swaponoff \
110 "
111   
112 RDEPENDS_${PN} = "\
113   task-base-extended \
114   task-proper-tools \
115   ${AUFS} \
116   ${WIRELESS} \
117   ${BLUETOOTH} \  
118   ${BOOT} \
119   ${MEDIA_LIBS} \
120   ${OPENGLES} \
121   ${PANDORA_LIBS} \
122   ${SSH} \
123   ${SUDO} \
124   ${TOUCHSCREEN} \
125   ${FS_SUPPORT} \
126   ${EXTRA_TOOLS} \
127   ${UTIL_LINUX_NG_EXTRAS} \
128 #        packagekit \
129   python-pygame \
130   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
131   rdesktop \
132   mplayer \
133   \
134 #  angstrom-zeroconf-audio \
135   angstrom-led-config \ 
136   \
137   ${PAM} \
138 "
139
140 # Make sure we install all kernel modules with the Pandora images
141 RRECOMMENDS_${PN} += "kernel-modules"
142
143 PACKAGE_ARCH = "${MACHINE_ARCH}"
144
145 RRECOMMENDS_${PN}_append_armv7a = " \
146 #       gnash gnash-browser-plugin \
147         omapfbplay \
148 "