task-pandora-core.bb: Added ca-certificates
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r44"
9
10 inherit task 
11
12 AUFS = " \
13   aufs2-util \
14 "
15
16 BLUETOOTH = " \
17   blueprobe \
18   bluez4 gst-plugin-bluez \
19   libsndfile1 libasound-module-bluez \
20 "
21
22 # Package up the boot scripts and bootchart to help us work to drop the startup time.
23 BOOT = " \
24   pandora-uboot-scripts \
25   bootchart \
26   mtd-utils \
27 "
28
29 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
30 BOOST = " \
31   boost \
32 "
33
34 WIRELESS = " \
35 #  pandora-firmware \
36 #  wl1251-modules \
37 #  pandora-wifi pandora-wifi-tools \
38   wireless-tools \
39   wpa-supplicant \  
40   networkmanager netm-cli \
41 "
42
43 MEDIA_LIBS = " \
44   libmodplug \
45   libsdl-x11 libsdl-mixer libsdl-image \
46   libsdl-gfx libsdl-net libsdl-ttf \
47   libpng libpng12 libpng3 \
48   faad2 \
49   mikmod \
50   speex \  
51   flac \
52   audiofile \
53 "
54 OPENGLES = " \
55   omap3-sgx-modules devmem2 \
56   libgles-omap3-es23 \
57   libgles-omap3-dm3730 \
58 #  libgles-omap3-rawdemos \
59 "
60
61 PAM = " \
62   libpam \
63   libpam-meta \
64 "
65
66 PANDORA_LIBS = " \
67   pandora-libpnd lsof \
68   omap3-deviceid \
69   pandora-skel \
70   pandora-state \
71   pandora-usbhost \
72 "
73
74 SUDO = " \
75   sudo sudo-enable-wheel-group \ 
76   pandora-sudoers \
77 "
78
79 SSH = " \
80   openssh-scp \
81   openssh-ssh \
82 "
83
84 TOUCHSCREEN = " \
85   tslib tslib-tests tslib-calibrate pointercal \
86 "
87
88 FS_SUPPORT = " \
89 #  nfs-utils \
90   nfs-utils-client \
91   fuse fuse-utils \
92   sshfs-fuse gmailfs curlftpfs \
93   ntfs-3g \
94   squashfs-tools \
95 "
96
97 EXTRA_TOOLS = " \
98   avahi \
99   fbgrab fbset fbset-modes \
100   portmap \
101   file \
102   socat \
103   strace \
104   screen \
105   rsync \
106   unrar \
107   ksymoops \
108   kexec-tools \
109   zip \        
110   gzip \
111   bash \
112   bzip2 \  
113   minicom \
114   nano \
115   gdb \
116   sessreg \
117   lua5.1 \
118   tzdata \
119   ca-certificates \
120 "
121
122 # Add extra util-linux-ng utils to image. 
123 # TODO: Fix util-linux-ng to meta depend on all subpackages.
124 UTIL_LINUX_NG_EXTRAS = " \
125   util-linux-ng-losetup util-linux-ng-mountall \
126   util-linux-ng-swaponoff \
127 "
128
129 # sysvinit-* used to not be needed, but after adding
130 # recipes/sysvinit/sysvinit/omap3-pandora/*
131 # they are no longer included automatically?
132 SYSVINIT = " \
133   sysvinit-inittab \
134   sysvinit-sulogin \
135   sysvinit-utils \
136 "
137
138 RDEPENDS_${PN} = "\
139   task-base-extended \
140   task-proper-tools \
141   ${SYSVINIT} \
142   ${AUFS} \
143   ${BOOST} \
144   ${WIRELESS} \
145   ${BLUETOOTH} \  
146   ${BOOT} \
147   ${MEDIA_LIBS} \
148   ${OPENGLES} \
149   ${PANDORA_LIBS} \
150   ${PAM} \  
151   ${SSH} \
152   ${SUDO} \
153   ${TOUCHSCREEN} \
154   ${FS_SUPPORT} \
155   ${EXTRA_TOOLS} \
156   ${UTIL_LINUX_NG_EXTRAS} \
157 #        packagekit \
158   python-pygame \
159   python-misc \
160   python-modules \
161   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
162   openal-soft \
163   rdesktop \
164   \
165 #  angstrom-zeroconf-audio \
166   angstrom-led-config \ 
167   ntpdate \ 
168   omap3-pandora-kernel2 \
169 "
170
171 # Make sure we install all kernel modules with the Pandora images
172 RRECOMMENDS_${PN} += "kernel-modules"
173
174 PACKAGE_ARCH = "${MACHINE_ARCH}"