1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
6 # Don't forget to bump the PR if you change it.
18 bluez4 gst-plugin-bluez \
19 libsndfile1 libasound-module-bluez \
22 # Package up the boot scripts and bootchart to help us work to drop the startup time.
24 pandora-uboot-scripts \
29 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
37 # pandora-wifi pandora-wifi-tools \
40 networkmanager netm-cli \
45 libsdl-x11 libsdl-mixer libsdl-image \
46 libsdl-gfx libsdl-net libsdl-ttf \
47 libpng libpng12 libpng3 \
55 omap3-sgx-modules devmem2 \
57 libgles-omap3-rawdemos \
73 sudo sudo-enable-wheel-group \
83 tslib tslib-tests tslib-calibrate pointercal \
90 sshfs-fuse gmailfs curlftpfs \
97 fbgrab fbset fbset-modes \
118 # Add extra util-linux-ng utils to image.
119 # TODO: Fix util-linux-ng to meta depend on all subpackages.
120 UTIL_LINUX_NG_EXTRAS = " \
121 util-linux-ng-losetup util-linux-ng-mountall \
122 util-linux-ng-swaponoff \
142 ${UTIL_LINUX_NG_EXTRAS} \
145 alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
148 # angstrom-zeroconf-audio \
149 angstrom-led-config \
152 # Make sure we install all kernel modules with the Pandora images
153 RRECOMMENDS_${PN} += "kernel-modules"
155 PACKAGE_ARCH = "${MACHINE_ARCH}"