Back to: qt4-x11-free since qt4-x11-free-gles lead to an error.
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r34"
9
10 inherit task 
11
12 AUFS = " \
13   aufs2-util \
14 "
15
16 BLUETOOTH = " \
17   blueprobe \
18   bluez4 gst-plugin-bluez \
19   libsndfile1 libasound-module-bluez \
20 "
21
22 # Package up the boot scripts and bootchart to help us work to drop the startup time.
23 BOOT = " \
24   pandora-uboot-scripts \
25   bootchart \
26   mtd-utils \
27 "
28
29 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
30 BOOST = " \
31   boost \
32 "
33
34 WIRELESS = " \
35   pandora-firmware \
36   wl1251-modules \
37 #  pandora-wifi pandora-wifi-tools \
38   wireless-tools \
39   wpa-supplicant \  
40   networkmanager netm-cli \
41 "
42
43 MEDIA_LIBS = " \
44   libmodplug \
45   libsdl-x11 libsdl-mixer libsdl-image \
46   libsdl-gfx libsdl-net libsdl-ttf \
47   libpng libpng12 libpng3 \
48   faad2 \
49   mikmod \
50   speex \  
51   flac \ 
52   audiofile \
53 "
54 OPENGLES = " \
55   omap3-sgx-modules devmem2 \
56   libgles-omap3 \
57 #  libgles-omap3-rawdemos \
58 "
59
60 PAM = " \
61   libpam \
62   libpam-meta \
63 "
64
65 PANDORA_LIBS = " \
66   pandora-libpnd lsof \
67   omap3-deviceid \
68   pandora-skel \
69   pandora-state \
70 "
71
72 SUDO = " \
73   sudo sudo-enable-wheel-group \ 
74   pandora-sudoers \
75 "
76
77 SSH = " \
78   openssh-scp \
79   openssh-ssh \
80 "
81
82 TOUCHSCREEN = " \
83   tslib tslib-tests tslib-calibrate pointercal \
84 "
85
86 FS_SUPPORT = " \
87 #  nfs-utils \
88   nfs-utils-client \
89   fuse fuse-utils \
90   sshfs-fuse gmailfs curlftpfs \
91   ntfs-3g \
92   squashfs-tools \
93 "
94
95 EXTRA_TOOLS = " \
96   avahi \
97   fbgrab fbset fbset-modes \
98   portmap \
99   file \
100   socat \
101   strace \
102   ksymoops \
103   kexec-tools \
104   zip \        
105   gzip \
106   bash \
107   bzip2 \  
108   minicom \
109   nano \
110   gdb \
111   sessreg \
112   lua5.1 \
113   tzdata \
114 "
115
116 # Add extra util-linux-ng utils to image. 
117 # TODO: Fix util-linux-ng to meta depend on all subpackages.
118 UTIL_LINUX_NG_EXTRAS = " \
119   util-linux-ng-losetup util-linux-ng-mountall \
120   util-linux-ng-swaponoff \
121 "
122   
123 RDEPENDS_${PN} = "\
124   task-base-extended \
125   task-proper-tools \
126   ${AUFS} \
127   ${BOOST} \
128   ${WIRELESS} \
129   ${BLUETOOTH} \  
130   ${BOOT} \
131   ${MEDIA_LIBS} \
132   ${OPENGLES} \
133   ${PANDORA_LIBS} \
134   ${PAM} \  
135   ${SSH} \
136   ${SUDO} \
137   ${TOUCHSCREEN} \
138   ${FS_SUPPORT} \
139   ${EXTRA_TOOLS} \
140   ${UTIL_LINUX_NG_EXTRAS} \
141 #        packagekit \
142   python-pygame \
143   python-misc \
144   python-modules \
145   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
146   rdesktop \
147   \
148 #  angstrom-zeroconf-audio \
149   angstrom-led-config \ 
150 "
151
152 # Make sure we install all kernel modules with the Pandora images
153 RRECOMMENDS_${PN} += "kernel-modules"
154
155 PACKAGE_ARCH = "${MACHINE_ARCH}"