c96638533d8f77e0f22bd173c75237373a4e444a
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r32"
9
10 inherit task 
11
12 AUFS = " \
13   aufs2-util \
14 "
15
16 BLUETOOTH = " \
17   blueprobe \
18   bluez4 gst-plugin-bluez \
19   libsndfile1 libasound-module-bluez \
20 "
21
22 # Package up the boot scripts and bootchart to help us work to drop the startup time.
23 BOOT = " \
24   pandora-uboot-scripts \
25   bootchart \
26   mtd-utils \
27 "
28
29 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
30 BOOST = " \
31   boost \
32 "
33
34 WIRELESS = " \
35   pandora-firmware \
36   wl1251-modules \
37 #  pandora-wifi pandora-wifi-tools \
38   wireless-tools \
39   wpa-supplicant \  
40   networkmanager netm-cli \
41 "
42
43 MEDIA_LIBS = " \
44   libmodplug \
45   libsdl-x11 libsdl-mixer libsdl-image \
46   libsdl-gfx libsdl-net libsdl-ttf \
47   libpng libpng12 libpng3 \
48   faad2 \
49   mikmod \
50   speex \  
51   flac \  
52 "
53 OPENGLES = " \
54   omap3-sgx-modules devmem2 \
55   libgles-omap3 \
56 #  libgles-omap3-rawdemos \
57 "
58
59 PAM = " \
60   libpam \
61   libpam-meta \
62 "
63
64 PANDORA_LIBS = " \
65   pandora-libpnd lsof \
66   omap3-deviceid \
67   pandora-skel \
68   pandora-state \
69 "
70
71 SUDO = " \
72   sudo sudo-enable-wheel-group \ 
73   pandora-sudoers \
74 "
75
76 SSH = " \
77   openssh-scp \
78   openssh-ssh \
79 "
80
81 TOUCHSCREEN = " \
82   tslib tslib-tests tslib-calibrate pointercal \
83 "
84
85 FS_SUPPORT = " \
86 #  nfs-utils \
87   nfs-utils-client \
88   fuse fuse-utils \
89   sshfs-fuse gmailfs curlftpfs \
90   ntfs-3g \
91   squashfs-tools \
92 "
93
94 EXTRA_TOOLS = " \
95   avahi \
96   fbgrab fbset fbset-modes \
97   portmap \
98   file \
99   socat \
100   strace \
101   ksymoops \
102   kexec-tools \
103   zip \        
104   gzip \
105   bash \
106   bzip2 \  
107   minicom \
108   nano \
109   gdb \
110   sessreg \
111   lua5.1 \
112   tzdata \
113 "
114
115 # Add extra util-linux-ng utils to image. 
116 # TODO: Fix util-linux-ng to meta depend on all subpackages.
117 UTIL_LINUX_NG_EXTRAS = " \
118   util-linux-ng-losetup util-linux-ng-mountall \
119   util-linux-ng-swaponoff \
120 "
121   
122 RDEPENDS_${PN} = "\
123   task-base-extended \
124   task-proper-tools \
125   ${AUFS} \
126   ${BOOST} \
127   ${WIRELESS} \
128   ${BLUETOOTH} \  
129   ${BOOT} \
130   ${MEDIA_LIBS} \
131   ${OPENGLES} \
132   ${PANDORA_LIBS} \
133   ${PAM} \  
134   ${SSH} \
135   ${SUDO} \
136   ${TOUCHSCREEN} \
137   ${FS_SUPPORT} \
138   ${EXTRA_TOOLS} \
139   ${UTIL_LINUX_NG_EXTRAS} \
140 #        packagekit \
141   python-pygame \
142   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
143   rdesktop \
144   \
145 #  angstrom-zeroconf-audio \
146   angstrom-led-config \ 
147 "
148
149 # Make sure we install all kernel modules with the Pandora images
150 RRECOMMENDS_${PN} += "kernel-modules"
151
152 PACKAGE_ARCH = "${MACHINE_ARCH}"