task-pandora-*: Cleanup image tasks.
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r2.3"
9
10 inherit task 
11
12 BLUETOOTH = " \
13   blueprobe \
14   bluez4 gst-plugin-bluez \
15   libsndfile1 libasound-module-bluez \
16 "
17
18 WIRELESS = " \
19   pandora-firmware \
20   wl1251-modules \
21 #  pandora-wifi pandora-wifi-tools \
22   wireless-tools \
23   wpa-supplicant \  
24   networkmanager netm-cli \  
25 "
26
27 OPENGLES = " \
28   omap3-sgx-modules devmem2 \
29   libgles-omap3 libgles-omap3-demos \
30 "
31
32 PAM = " \
33   libpam pam-plugins-group pam-plugins-xauth pam-plugins-wheel \
34   pam-plugins-loginuid pam-plugins-localuser \
35 "
36
37 SSH = " \
38   openssh-scp \
39   openssh-ssh \
40 "
41
42 PANDORA_LIBS = " \
43   pandora-libpnd lsof \
44   omap3-deviceid \  
45 "
46
47 TOUCHSCREEN = " \
48   tslib tslib-tests tslib-calibrate pointercal \
49 "
50
51 FS_SUPPORT = " \
52   nfs-utils nfs-utils-client \
53   aufs aufs-tools \
54   fuse sshfs-fuse ntfs-3g \
55 "
56
57 EXTRA_TOOLS = " \
58   avahi \
59   fbgrab fbset fbset-modes \
60   portmap \
61   file \
62   socat \
63   strace \
64   ksymoops \
65   kexec-tools \
66   zip \        
67   gzip \
68   bash \
69   bzip2 \  
70   sudo \ 
71   minicom \
72   nano \
73 "
74
75 RDEPENDS_${PN} = "\
76   task-base-extended \
77   task-proper-tools \
78   ${WIRELESS} \
79   ${BLUETOOTH} \  
80   ${OPENGLES} \
81   ${PANDORA_LIBS} \
82   ${SSH} \
83   ${TOUCHSCREEN} \
84   ${FS_SUPPORT} \
85   ${EXTRA_TOOLS} \
86 #        packagekit \
87   libsdl-gfx libsdl-net mikmod \
88   python-pygame \
89   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
90   rdesktop \
91   mplayer \
92   \
93   angstrom-zeroconf-audio \
94   angstrom-led-config \ 
95   \
96   ${PAM} \
97 "
98
99 # Make sure we install all kernel modules with the Pandora images
100 RRECOMMENDS_${PN} += "kernel-modules"
101
102 PACKAGE_ARCH = "${MACHINE_ARCH}"
103
104 RRECOMMENDS_${PN}_append_armv7a = " \
105         gnash gnash-browser-plugin \
106         omapfbplay \
107 "