task-pandora-*: Update task files used by images.
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r3.1"
9
10 inherit task 
11
12 RDEPENDS_${PN} = "\
13   task-base-extended \
14   task-proper-tools \
15   pandora-firmware \
16   wl1251-modules \
17 #        pandora-wifi pandora-wifi-tools \
18   wpa-supplicant \
19   pandora-libpnd lsof \
20   omap3-deviceid \      
21   omap3-sgx-modules devmem2 \
22   libgles-omap3 libgles-omap3-demos \
23 #        packagekit \
24   libsdl-gfx libsdl-net mikmod \
25   nfs-utils nfs-utils-client \
26   tslib tslib-tests tslib-calibrate pointercal \
27   fbgrab fbset fbset-modes \
28   portmap \
29   fuse sshfs-fuse ntfs-3g \
30   file \
31   aufs aufs-tools \
32   socat \
33   strace \
34   python-pygame \
35   ksymoops \
36   kexec-tools \
37   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
38   openssh-scp \
39   openssh-ssh \
40   bluez4 \
41   wireless-tools \
42   rdesktop \
43   networkmanager netm-cli \
44   openssh-scp openssh-ssh \
45   mplayer \
46   \
47   zip \        
48   gzip \
49   bash \
50   bzip2 \  
51   sudo \ 
52   minicom \
53   nano \        
54   \
55 "
56
57 # Make sure we install all kernel modules with the Pandora images
58 RRECOMMENDS_${PN} += "kernel-modules"
59
60 PACKAGE_ARCH = "${MACHINE_ARCH}"
61
62 RRECOMMENDS_${PN}_append_armv7a = " \
63         gnash gnash-browser-plugin \
64         omapfbplay \
65 "