various: reset PR of tasks following mainline Angstrom DISTRO_PR bump. Cosmetic change.
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r1"
9
10 inherit task 
11
12 AUFS = " \
13   aufs2-27 \
14   aufs2-util \
15 "
16
17 BLUETOOTH = " \
18   blueprobe \
19   bluez4 gst-plugin-bluez \
20   libsndfile1 libasound-module-bluez \
21 "
22
23 WIRELESS = " \
24   pandora-firmware \
25   wl1251-modules \
26 #  pandora-wifi pandora-wifi-tools \
27   wireless-tools \
28   wpa-supplicant \  
29   networkmanager netm-cli \  
30 "
31
32 OPENGLES = " \
33   omap3-sgx-modules devmem2 \
34   libgles-omap3 \
35 #  libgles-omap3-demos \
36 "
37
38 PAM = " \
39   libpam \
40   libpam-meta \
41 "
42
43 SSH = " \
44   openssh-scp \
45   openssh-ssh \
46 "
47
48 PANDORA_LIBS = " \
49   pandora-libpnd lsof \
50   omap3-deviceid \
51   pandora-skel \
52 "
53
54 TOUCHSCREEN = " \
55   tslib tslib-tests tslib-calibrate pointercal \
56 "
57
58 FS_SUPPORT = " \
59   nfs-utils nfs-utils-client \
60   fuse sshfs-fuse ntfs-3g \
61 "
62
63 EXTRA_TOOLS = " \
64   avahi \
65   fbgrab fbset fbset-modes \
66   portmap \
67   file \
68   socat \
69   strace \
70   ksymoops \
71   kexec-tools \
72   zip \        
73   gzip \
74   bash \
75   bzip2 \  
76   sudo sudo-enable-wheel-group \ 
77   minicom \
78   nano \
79 "
80
81 RDEPENDS_${PN} = "\
82   task-base-extended \
83   task-proper-tools \
84   ${AUFS} \
85   ${WIRELESS} \
86   ${BLUETOOTH} \  
87   ${OPENGLES} \
88   ${PANDORA_LIBS} \
89   ${SSH} \
90   ${TOUCHSCREEN} \
91   ${FS_SUPPORT} \
92   ${EXTRA_TOOLS} \
93 #        packagekit \
94   libsdl-gfx libsdl-net mikmod \
95   python-pygame \
96   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
97   rdesktop \
98   mplayer \
99   \
100   angstrom-zeroconf-audio \
101   angstrom-led-config \ 
102   \
103   ${PAM} \
104 "
105
106 # Make sure we install all kernel modules with the Pandora images
107 RRECOMMENDS_${PN} += "kernel-modules"
108
109 PACKAGE_ARCH = "${MACHINE_ARCH}"
110
111 RRECOMMENDS_${PN}_append_armv7a = " \
112         gnash gnash-browser-plugin \
113         omapfbplay \
114 "